summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-04-08 04:39:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-04-08 04:39:17 +0000
commit92e352a7e1c7bdf09301edc5b4475bbae4b58177 (patch)
tree68d3ac841c83b638c3ca9906b0ef42ab8947909c /sci-astronomy
parentAdded django-registration to the tree. Thanks to Arne Babenhauserheide for (diff)
downloadgentoo-2-92e352a7e1c7bdf09301edc5b4475bbae4b58177.tar.gz
gentoo-2-92e352a7e1c7bdf09301edc5b4475bbae4b58177.tar.bz2
gentoo-2-92e352a7e1c7bdf09301edc5b4475bbae4b58177.zip
Version bump
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/cpl/ChangeLog7
-rw-r--r--sci-astronomy/cpl/cpl-5.3.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sci-astronomy/cpl/ChangeLog b/sci-astronomy/cpl/ChangeLog
index b96f8f0dbcaf..e2ee596396fa 100644
--- a/sci-astronomy/cpl/ChangeLog
+++ b/sci-astronomy/cpl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/cpl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.5 2011/02/24 17:30:50 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.6 2011/04/08 04:39:17 bicatali Exp $
+
+*cpl-5.3.1 (08 Apr 2011)
+
+ 08 Apr 2011; Sébastien Fabbro <bicatali@gentoo.org> +cpl-5.3.1.ebuild:
+ Version bump
24 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> cpl-5.2.0-r1.ebuild:
Updated homepage and prexified
diff --git a/sci-astronomy/cpl/cpl-5.3.1.ebuild b/sci-astronomy/cpl/cpl-5.3.1.ebuild
new file mode 100644
index 000000000000..8b3fb1abbc6d
--- /dev/null
+++ b/sci-astronomy/cpl/cpl-5.3.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/cpl-5.3.1.ebuild,v 1.1 2011/04/08 04:39:17 bicatali Exp $
+
+EAPI=4
+JAVA_PKG_OPT_USE=gasgano
+inherit eutils java-pkg-opt-2
+
+DESCRIPTION="ESO common pipeline library for astronomical data reduction"
+HOMEPAGE="http://www.eso.org/sci/software/cpl/"
+SRC_URI="ftp://ftp.eso.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc gasgano static-libs"
+
+RDEPEND=">=sci-libs/cfitsio-3.09
+ sci-astronomy/wcslib
+ sci-libs/fftw:3.0
+ gasgano? ( sci-astronomy/gasgano )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( app-doc/doxygen dev-texlive/texlive-fontsrecommended )
+ gasgano? ( >=virtual/jdk-1.5 )"
+
+src_configure() {
+ has_version sci-libs/cfitsio[static-libs] || \
+ sed -i -e 's/libcfitsio.a/libcfitsio.so/' configure
+ local myconf="--without-gasgano"
+ use gasgano && \
+ myconf="--with-gasgano=${EPREFIX}/usr
+ --with-gasgano-classpath=${EPREFIX}/usr/share/gasgano/lib"
+ econf \
+ $(use_enable static-libs static) \
+ --with-cfitsio="${EPREFIX}/usr" \
+ --with-wcs="${EPREFIX}/usr" \
+ --with-fftw="${EPREFIX}/usr" \
+ ${myconf}
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+ if use doc; then
+ VARTEXFONTS=${T}/fonts doxygen Doxyfile || die
+ fi
+}
+src_install() {
+ default
+ use doc && dohtml -r html
+}