summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-18 18:17:38 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-18 18:17:38 +0000
commitb251a1f588723f577c9c07e1970ef41abdcdfd7b (patch)
tree4bd149e0c0197176f7285835dff1cff9cd04c0d9 /sci-biology/shrimp
parentPatch to fix git/curl over http/https with auth, bug #438718 (diff)
downloadgentoo-2-b251a1f588723f577c9c07e1970ef41abdcdfd7b.tar.gz
gentoo-2-b251a1f588723f577c9c07e1970ef41abdcdfd7b.tar.bz2
gentoo-2-b251a1f588723f577c9c07e1970ef41abdcdfd7b.zip
sci-biology/shrimp: Vesion Bump
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-biology/shrimp')
-rw-r--r--sci-biology/shrimp/ChangeLog7
-rw-r--r--sci-biology/shrimp/shrimp-2.2.3.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sci-biology/shrimp/ChangeLog b/sci-biology/shrimp/ChangeLog
index 4f57d4aba634..a3af6b4ff9ef 100644
--- a/sci-biology/shrimp/ChangeLog
+++ b/sci-biology/shrimp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/shrimp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/ChangeLog,v 1.15 2012/10/18 18:00:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/ChangeLog,v 1.16 2012/10/18 18:17:38 jlec Exp $
+
+*shrimp-2.2.3 (18 Oct 2012)
+
+ 18 Oct 2012; Justin Lecher <jlec@gentoo.org> +shrimp-2.2.3.ebuild:
+ Vesion Bump
18 Oct 2012; Justin Lecher <jlec@gentoo.org> -shrimp-1.3.1.ebuild,
shrimp-2.0.1.ebuild, shrimp-2.1.0.ebuild:
diff --git a/sci-biology/shrimp/shrimp-2.2.3.ebuild b/sci-biology/shrimp/shrimp-2.2.3.ebuild
new file mode 100644
index 000000000000..ce8cbe51b610
--- /dev/null
+++ b/sci-biology/shrimp/shrimp-2.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/shrimp/shrimp-2.2.3.ebuild,v 1.1 2012/10/18 18:17:38 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND=2
+
+inherit flag-o-matic python toolchain-funcs
+
+MY_PV=${PV//./_}
+
+DESCRIPTION="SHort Read Mapping Package"
+HOMEPAGE="http://compbio.cs.toronto.edu/shrimp/"
+SRC_URI="http://compbio.cs.toronto.edu/shrimp/releases/SHRiMP_${MY_PV}.src.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="custom-cflags"
+
+S=${WORKDIR}/SHRiMP_${MY_PV}
+
+pkg_setup() {
+ if [[ ${CC} == *gcc* ]] && ! tc-has-openmp; then
+ elog "Please set CC to an OPENMP capable compiler (e.g. gcc[openmp] or icc"
+ die "C compiler lacks OPENMP support"
+ fi
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -e '1 a #include <stdint.h>' -i common/dag_glue.cpp || die
+ # respect LDFLAGS wrt 331823
+ sed -i -e "s/LDFLAGS/LIBS/" -e "s/\$(LD)/& \$(LDFLAGS)/" \
+ -e 's/-static//' Makefile || die
+ python_convert_shebangs -r -- 2 utils
+}
+
+src_compile() {
+ append-flags -fopenmp
+ if ! use custom-cflags; then
+ append-flags -O3
+ replace-flags -O2 -O3
+ fi
+ tc-export CXX
+ emake CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ local i
+ dobin bin/* utils/split-contigs utils/temp-sink
+ dodoc HISTORY README TODO SPLITTING_AND_MERGING SCORES_AND_PROBABILITES
+
+ pushd utils > /dev/null
+ for i in *py; do
+ newbin ${i} ${i%.py}
+ done
+
+ rm *.py *.o *.c split-contigs temp-sink || die
+ insinto /usr/share/${PN}
+ doins -r *
+}