summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 06:04:55 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 06:04:55 +0000
commit50371f1e6cca66f657979597678febc6066d919d (patch)
tree7bb48ee90cb1134160336a10c91e33fcb1672806 /sci-chemistry/gabedit
parentVersion bump. (diff)
downloadgentoo-2-50371f1e6cca66f657979597678febc6066d919d.tar.gz
gentoo-2-50371f1e6cca66f657979597678febc6066d919d.tar.bz2
gentoo-2-50371f1e6cca66f657979597678febc6066d919d.zip
Tweaking on pango deps
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gabedit')
-rw-r--r--sci-chemistry/gabedit/ChangeLog6
-rw-r--r--sci-chemistry/gabedit/files/CONFIG.Gentoo4
-rw-r--r--sci-chemistry/gabedit/gabedit-2.3.6.ebuild5
-rw-r--r--sci-chemistry/gabedit/gabedit-2.3.7.ebuild5
-rw-r--r--sci-chemistry/gabedit/gabedit-2.3.8.ebuild7
5 files changed, 17 insertions, 10 deletions
diff --git a/sci-chemistry/gabedit/ChangeLog b/sci-chemistry/gabedit/ChangeLog
index 4569cb539403..8a6d0ada25b8 100644
--- a/sci-chemistry/gabedit/ChangeLog
+++ b/sci-chemistry/gabedit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/gabedit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.10 2011/06/20 17:43:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.11 2011/06/21 06:04:55 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> gabedit-2.3.6.ebuild,
+ gabedit-2.3.7.ebuild, gabedit-2.3.8.ebuild, files/CONFIG.Gentoo:
+ Tweaking on pango deps
*gabedit-2.3.8 (20 Jun 2011)
diff --git a/sci-chemistry/gabedit/files/CONFIG.Gentoo b/sci-chemistry/gabedit/files/CONFIG.Gentoo
index 243a51551c32..4f0e4763564a 100644
--- a/sci-chemistry/gabedit/files/CONFIG.Gentoo
+++ b/sci-chemistry/gabedit/files/CONFIG.Gentoo
@@ -1,5 +1,5 @@
-GTKLIB = `pkg-config --libs gtk+-2.0 pangox gtkglext-1.0`
-GTKCFLAGS = `pkg-config --cflags gtk+-2.0 pangox gtkglext-1.0`
+GTKLIB = `pkg-config --libs gtk+-2.0 gtkglext-1.0`
+GTKCFLAGS = `pkg-config --cflags gtk+-2.0 gtkglext-1.0`
OGLLIB = `pkg-config --libs glu`
OGLCFLAGS = `pkg-config --cflags glu`
X11LIB = `pkg-config --libs x11`
diff --git a/sci-chemistry/gabedit/gabedit-2.3.6.ebuild b/sci-chemistry/gabedit/gabedit-2.3.6.ebuild
index 22d4590a3f35..c6e78092faa1 100644
--- a/sci-chemistry/gabedit/gabedit-2.3.6.ebuild
+++ b/sci-chemistry/gabedit/gabedit-2.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.6.ebuild,v 1.4 2011/06/20 17:43:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.6.ebuild,v 1.5 2011/06/21 06:04:55 jlec Exp $
EAPI=2
@@ -26,7 +26,7 @@ RDEPEND="
x11-libs/gtk+:2
x11-libs/gtkglext
x11-libs/gl2ps
- x11-libs/pango[X]
+ x11-libs/pango
virtual/opengl
virtual/glu"
DEPEND="${RDEPEND}
@@ -42,6 +42,7 @@ src_prepare() {
sed -i "/rmdir tmp/d" "${S}"/Makefile
sed -e "/GTK_DISABLE_DEPRECATED/s:define:undef:g" \
-i "${S}/Config.h" || die
+ sed -e 's:-g::g' -i Makefile || die
cp "${FILESDIR}"/CONFIG.Gentoo "${S}"/CONFIG
if use openmp && tc-has-openmp; then
diff --git a/sci-chemistry/gabedit/gabedit-2.3.7.ebuild b/sci-chemistry/gabedit/gabedit-2.3.7.ebuild
index a5556a1e7560..07b617c0a2fa 100644
--- a/sci-chemistry/gabedit/gabedit-2.3.7.ebuild
+++ b/sci-chemistry/gabedit/gabedit-2.3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.7.ebuild,v 1.2 2011/06/20 17:43:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.7.ebuild,v 1.3 2011/06/21 06:04:55 jlec Exp $
EAPI=2
@@ -26,7 +26,7 @@ RDEPEND="
x11-libs/gtk+:2
x11-libs/gtkglext
x11-libs/gl2ps
- x11-libs/pango[X]
+ x11-libs/pango
virtual/opengl
virtual/glu"
DEPEND="${RDEPEND}
@@ -39,6 +39,7 @@ src_prepare() {
sed -i "/rmdir tmp/d" "${S}"/Makefile
sed -e "/GTK_DISABLE_DEPRECATED/s:define:undef:g" \
-i "${S}/Config.h" || die
+ sed -e 's:-g::g' -i Makefile || die
cp "${FILESDIR}"/CONFIG.Gentoo "${S}"/CONFIG
if use openmp && tc-has-openmp; then
diff --git a/sci-chemistry/gabedit/gabedit-2.3.8.ebuild b/sci-chemistry/gabedit/gabedit-2.3.8.ebuild
index 6f4d2ffc4a0b..cb3cedd76029 100644
--- a/sci-chemistry/gabedit/gabedit-2.3.8.ebuild
+++ b/sci-chemistry/gabedit/gabedit-2.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.8.ebuild,v 1.1 2011/06/20 17:43:54 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.8.ebuild,v 1.2 2011/06/21 06:04:55 jlec Exp $
EAPI=4
@@ -26,7 +26,7 @@ RDEPEND="
x11-libs/gtk+:2
x11-libs/gtkglext
x11-libs/gl2ps
- x11-libs/pango[X]
+ x11-libs/pango
virtual/opengl
virtual/glu"
DEPEND="${RDEPEND}
@@ -40,11 +40,12 @@ src_prepare() {
sed \
-e "/GTK_DISABLE_DEPRECATED/s:define:undef:g" \
-i "${S}/Config.h" || die
+ sed -e 's:-g::g' -i Makefile || die
cp "${FILESDIR}"/CONFIG.Gentoo "${S}"/CONFIG
if use openmp && tc-has-openmp; then
cat <<- EOF >> "${S}/CONFIG"
- OMPLIB=-L/usr/$(get_libdir) -lgomp
+ OMPLIB=-fopenmp
OMPCFLAGS=-DENABLE_OMP -fopenmp
EOF
fi