summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-10-14 00:44:11 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-10-14 00:44:11 +0000
commitd93fde1ef60bf3c1a4a5f598c5272ef5a5766cfa (patch)
tree81cc15b804a9b3bf24bec7e2f9f2f90d8ec8ad4c /sci-chemistry/gromacs
parentVersion bump #109171 by Christoph Gysin. (diff)
downloadgentoo-2-d93fde1ef60bf3c1a4a5f598c5272ef5a5766cfa.tar.gz
gentoo-2-d93fde1ef60bf3c1a4a5f598c5272ef5a5766cfa.tar.bz2
gentoo-2-d93fde1ef60bf3c1a4a5f598c5272ef5a5766cfa.zip
(#109184) Bump. Main change in ebuild is adding a check for fftw built w/ mpi if trying to build w/ mpi. One of the more interesting upstream changes is the addition of x86-64 and ia64 assembly.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'sci-chemistry/gromacs')
-rw-r--r--sci-chemistry/gromacs/ChangeLog9
-rw-r--r--sci-chemistry/gromacs/files/digest-gromacs-3.31
-rw-r--r--sci-chemistry/gromacs/gromacs-3.3.ebuild73
3 files changed, 82 insertions, 1 deletions
diff --git a/sci-chemistry/gromacs/ChangeLog b/sci-chemistry/gromacs/ChangeLog
index d2c5eb0dc8d1..9aebaf3c4a3d 100644
--- a/sci-chemistry/gromacs/ChangeLog
+++ b/sci-chemistry/gromacs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-chemistry/gromacs
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.5 2005/08/05 15:55:41 omkhar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/ChangeLog,v 1.6 2005/10/14 00:44:11 spyderous Exp $
+
+*gromacs-3.3 (14 Oct 2005)
+
+ 14 Oct 2005; Donnie Berkholz <spyderous@gentoo.org>; +gromacs-3.3.ebuild:
+ (#109184) Bump. Main change in ebuild is adding a check for fftw built w/
+ mpi if trying to build w/ mpi. One of the more interesting upstream changes
+ is the addition of x86-64 and ia64 assembly.
05 Aug 2005; <omkhar@gentoo.org> +files/gromacs-ppc64-altivec.patch,
gromacs-3.2.1-r1.ebuild:
diff --git a/sci-chemistry/gromacs/files/digest-gromacs-3.3 b/sci-chemistry/gromacs/files/digest-gromacs-3.3
new file mode 100644
index 000000000000..757b2815589c
--- /dev/null
+++ b/sci-chemistry/gromacs/files/digest-gromacs-3.3
@@ -0,0 +1 @@
+MD5 99ea6f25a89f1511f51c350a66a2fdc4 gromacs-3.3.tar.gz 5906342
diff --git a/sci-chemistry/gromacs/gromacs-3.3.ebuild b/sci-chemistry/gromacs/gromacs-3.3.ebuild
new file mode 100644
index 000000000000..98139b6e71b0
--- /dev/null
+++ b/sci-chemistry/gromacs/gromacs-3.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gromacs/gromacs-3.3.ebuild,v 1.1 2005/10/14 00:44:11 spyderous Exp $
+
+inherit eutils
+
+IUSE="altivec mpi xml2"
+
+DESCRIPTION="The ultimate molecular dynamics simulation package"
+SRC_URI="ftp://ftp.gromacs.org/pub/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gromacs.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc64"
+
+#mpi is a local USE flag now
+#May become official when situation with mpich is cleared (now the only mpi implementation awailable is lam-mpi)
+DEPEND="=sci-libs/fftw-2.1*
+ mpi? ( >=sys-cluster/lam-mpi-6.5.6 )
+ >=sys-devel/binutils-2.10.91.0.2
+ app-shells/tcsh
+ xml2? ( dev-libs/libxml2 )"
+
+pkg_setup() {
+ # !!!Please note!!!
+ # for troublesome work gromacs should be compiled with the same mpi setting
+ # as fftw.
+ if use mpi; then
+ if ! built_with_use =sci-libs/fftw-2.1* mpi; then
+ die "=sci-libs/fftw-2.1* must be built with USE=mpi."
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ if use ppc64 && use altivec ; then
+ epatch ${FILESDIR}/${PN}-ppc64-altivec.patch
+ fi
+}
+
+src_compile() {
+ # static should work but something's broken.
+ # gcc spec file may be screwed up.
+ # Static linking should try -lgcc instead of -lgcc_s.
+ # For more info:
+ # http://lists.debian.org/debian-gcc/2002/debian-gcc-200201/msg00150.html
+ econf \
+ --enable-fortran \
+ --datadir=/usr/share/${P} \
+ --bindir=/usr/bin \
+ --libdir=/usr/lib \
+ $(use_with xml2 xml) \
+ $(use_enable mpi) \
+ $(use_enable altivec ppc-altivec) \
+ $(use_enable alpha axp-asm) || die "configure failed"
+
+# $(use_enable static all-static) \
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ # Install documentation.
+ dodoc AUTHORS COPYING INSTALL README
+
+ #move html docs under /usr/share/doc
+ #and leave examples and templates under /usr/gromacs...
+ mv ${D}/usr/share/${P}/html ${D}/usr/share/doc/${PF}
+}