summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-10-19 09:52:00 +0000
committerJustin Lecher <jlec@gentoo.org>2012-10-19 09:52:00 +0000
commitd219b56ffa8bfbdbc0b1fe4e66fd196886b46a76 (patch)
treeada9afb3b2927636899bc7f6f30e6e300265a8bd /sci-chemistry/makecif
parentsci-chemistry/gromacs: Remove virtual/fortran and always call fortran-2_pkg_s... (diff)
downloadgentoo-2-d219b56ffa8bfbdbc0b1fe4e66fd196886b46a76.tar.gz
gentoo-2-d219b56ffa8bfbdbc0b1fe4e66fd196886b46a76.tar.bz2
gentoo-2-d219b56ffa8bfbdbc0b1fe4e66fd196886b46a76.zip
sci-chemistry/makecif: Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the updated fortran-2.eclass
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-chemistry/makecif')
-rw-r--r--sci-chemistry/makecif/ChangeLog9
-rw-r--r--sci-chemistry/makecif/makecif-5.6.6-r1.ebuild9
-rw-r--r--sci-chemistry/makecif/makecif-5.6.6.ebuild18
3 files changed, 19 insertions, 17 deletions
diff --git a/sci-chemistry/makecif/ChangeLog b/sci-chemistry/makecif/ChangeLog
index 66541a848cb6..0a0e9fdd85a0 100644
--- a/sci-chemistry/makecif/ChangeLog
+++ b/sci-chemistry/makecif/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/makecif
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/ChangeLog,v 1.11 2011/11/21 15:29:39 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/ChangeLog,v 1.12 2012/10/19 09:52:00 jlec Exp $
+
+ 19 Oct 2012; Justin Lecher <jlec@gentoo.org> makecif-5.6.6.ebuild,
+ makecif-5.6.6-r1.ebuild:
+ Remove virtual/fortran and always call fortran-2_pkg_setup as intend by the
+ updated fortran-2.eclass
21 Nov 2011; Justin Lecher <jlec@gentoo.org> makecif-5.6.6-r1.ebuild:
keyworded for ~x86-macos ~x64-macos, tested by Johan Hattne #390123
diff --git a/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild b/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild
index a8f638a0b433..09a3ae28e232 100644
--- a/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild
+++ b/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild,v 1.2 2011/11/21 15:29:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6-r1.ebuild,v 1.3 2012/10/19 09:52:00 jlec Exp $
EAPI=4
@@ -17,10 +17,9 @@ IUSE=""
S="${WORKDIR}"/${PN}
-DEPEND="
+DEPEND=""
+RDEPEND="
!>=sci-chemistry/refmac-5.6
- virtual/fortran"
-RDEPEND="${DEPEND}
sci-libs/monomer-db"
src_prepare() {
diff --git a/sci-chemistry/makecif/makecif-5.6.6.ebuild b/sci-chemistry/makecif/makecif-5.6.6.ebuild
index 2ac244edf3be..0bcb9e1d97e3 100644
--- a/sci-chemistry/makecif/makecif-5.6.6.ebuild
+++ b/sci-chemistry/makecif/makecif-5.6.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6.ebuild,v 1.10 2011/06/29 11:51:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/makecif/makecif-5.6.6.ebuild,v 1.11 2012/10/19 09:52:00 jlec Exp $
-EAPI=3
+EAPI=4
inherit eutils fortran-2 toolchain-funcs
@@ -17,10 +17,9 @@ IUSE=""
S="${WORKDIR}"/${PN}
-DEPEND="
+DEPEND=""
+RDEPEND="
!>=sci-chemistry/refmac-5.6
- virtual/fortran"
-RDEPEND="${DEPEND}
sci-libs/monomer-db"
src_prepare() {
@@ -31,11 +30,10 @@ src_compile() {
cd src && emake clean
emake \
BLANC_FORT="$(tc-getFC) ${FFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- || die
+ LDFLAGS="${LDFLAGS}"
}
src_install() {
- dobin bin/* || die
- dodoc readme || die
+ dobin bin/*
+ dodoc readme
}