summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-04 15:21:19 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-04 15:21:19 +0000
commit262f25aad30460bd589e4f40ae945aa503f8b289 (patch)
tree440020464d9b9cb058ec5627ccfc11587672c0f5 /sci-chemistry/molrep
parentfixed bug #375969#c22 (diff)
downloadgentoo-2-262f25aad30460bd589e4f40ae945aa503f8b289.tar.gz
gentoo-2-262f25aad30460bd589e4f40ae945aa503f8b289.tar.bz2
gentoo-2-262f25aad30460bd589e4f40ae945aa503f8b289.zip
Fix for Molrep: input fixed model mode failure
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/molrep')
-rw-r--r--sci-chemistry/molrep/ChangeLog8
-rw-r--r--sci-chemistry/molrep/files/11.0.03-EOR.patch16
-rw-r--r--sci-chemistry/molrep/molrep-11.0.03-r1.ebuild60
3 files changed, 83 insertions, 1 deletions
diff --git a/sci-chemistry/molrep/ChangeLog b/sci-chemistry/molrep/ChangeLog
index 59cc4096e09b..56390e985234 100644
--- a/sci-chemistry/molrep/ChangeLog
+++ b/sci-chemistry/molrep/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/molrep
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.19 2011/09/07 16:40:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/ChangeLog,v 1.20 2011/10/04 15:21:19 jlec Exp $
+
+*molrep-11.0.03-r1 (04 Oct 2011)
+
+ 04 Oct 2011; Justin Lecher <jlec@gentoo.org> +files/11.0.03-EOR.patch,
+ +molrep-11.0.03-r1.ebuild:
+ Fix for Molrep: input fixed model mode failure
*molrep-11.0.03 (07 Sep 2011)
diff --git a/sci-chemistry/molrep/files/11.0.03-EOR.patch b/sci-chemistry/molrep/files/11.0.03-EOR.patch
new file mode 100644
index 000000000000..430629e8dcc1
--- /dev/null
+++ b/sci-chemistry/molrep/files/11.0.03-EOR.patch
@@ -0,0 +1,16 @@
+ src/molrep.f | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/molrep.f b/src/molrep.f
+index eac0cfc..94f74c6 100755
+--- a/src/molrep.f
++++ b/src/molrep.f
+@@ -1257,7 +1257,7 @@ C CHECK_DENS_FILE( 2 )
+ LEN1 = 1
+ IF(LEN.GT.60) LEN1 = LEN - 59
+ WRITE(LINE,'(''Input MODEL_2(fixed)_file:'',A)')
+- * NAME2(LEN11:LEN)
++ * NAME2(LEN1:LEN)
+ CALL MSGDOC(MDoc,LINE)
+
+ ENDIF
diff --git a/sci-chemistry/molrep/molrep-11.0.03-r1.ebuild b/sci-chemistry/molrep/molrep-11.0.03-r1.ebuild
new file mode 100644
index 000000000000..57a2b3bc4513
--- /dev/null
+++ b/sci-chemistry/molrep/molrep-11.0.03-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/molrep/molrep-11.0.03-r1.ebuild,v 1.1 2011/10/04 15:21:19 jlec Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="molecular replacement program"
+HOMEPAGE="http://www.ysbl.york.ac.uk/~alexei/molrep.html"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="ccp4"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ virtual/fortran
+
+ >=sci-libs/ccp4-libs-6.1.3
+ sci-libs/mmdb
+ virtual/lapack"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/11.0.00-respect-FLAGS.patch \
+ "${FILESDIR}"/11.0.00-test.patch \
+ "${FILESDIR}"/${PV}-EOR.patch
+ [[ $(tc-getFC) =~ gfortran ]] && append-fflags -fno-second-underscore
+}
+
+src_compile() {
+ cd "${S}"/src
+ emake clean
+ emake \
+ MR_FORT="$(tc-getFC) ${FFLAGS}" \
+ FFLAGS="${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ MR_LIBRARY="-L${EPREFIX}/usr/$(get_libdir) -lccp4f -lccp4c $(pkg-config --libs mmdb lapack) -lccif -lstdc++ -lm"
+}
+
+src_test() {
+ export MR_TEST="${S}/bin/"
+ cd "${S}"/molrep_check/work
+ mkdir out scr
+ cp ../*.bat .
+ bash em.bat || die
+ bash mr.bat || die
+}
+
+src_install() {
+ exeinto /usr/libexec/ccp4/bin/
+ doexe bin/${PN}
+ dosym ../libexec/ccp4/bin/${PN} /usr/bin/${PN}
+ dodoc readme doc/${PN}.rtf
+}