summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-20 15:29:21 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-20 15:29:21 +0000
commit663ab2ff1e2f854a110b1c24d9d416bda55b570e (patch)
treef321aa9d2a0016e1fac2e6ccb8f3d0fa83f354f8 /sci-chemistry
parentFix tcl/tk slotting;drop old (diff)
downloadgentoo-2-663ab2ff1e2f854a110b1c24d9d416bda55b570e.tar.gz
gentoo-2-663ab2ff1e2f854a110b1c24d9d416bda55b570e.tar.bz2
gentoo-2-663ab2ff1e2f854a110b1c24d9d416bda55b570e.zip
Fix tcl/tk slotting; drop old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/sparky/ChangeLog9
-rw-r--r--sci-chemistry/sparky/sparky-3.115-r1.ebuild10
-rw-r--r--sci-chemistry/sparky/sparky-3.115.ebuild120
3 files changed, 11 insertions, 128 deletions
diff --git a/sci-chemistry/sparky/ChangeLog b/sci-chemistry/sparky/ChangeLog
index 11c558bdf48c..c704c6fabdd9 100644
--- a/sci-chemistry/sparky/ChangeLog
+++ b/sci-chemistry/sparky/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-chemistry/sparky
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/ChangeLog,v 1.20 2013/11/11 18:12:11 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/ChangeLog,v 1.21 2015/03/20 15:29:21 jlec Exp $
+
+ 20 Mar 2015; Justin Lecher <jlec@gentoo.org> -sparky-3.115.ebuild,
+ sparky-3.115-r1.ebuild:
+ Fix tcl/tk slotting; drop old
11 Nov 2013; Justin Lecher <jlec@gentoo.org> sparky-3.115-r1.ebuild:
It also works with python 2.7
@@ -83,4 +87,3 @@
A new graphical NMR assignment and integration program for proteins, nucleic
acids, and other polymers. Very strange build system; takes lots of hacking
and tweaking to get working. Doesn't work with python-2.4, only 2.3.
-
diff --git a/sci-chemistry/sparky/sparky-3.115-r1.ebuild b/sci-chemistry/sparky/sparky-3.115-r1.ebuild
index e313dd78f6d2..c275d9c929ff 100644
--- a/sci-chemistry/sparky/sparky-3.115-r1.ebuild
+++ b/sci-chemistry/sparky/sparky-3.115-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/sparky-3.115-r1.ebuild,v 1.3 2013/11/11 18:12:11 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/sparky-3.115-r1.ebuild,v 1.4 2015/03/20 15:29:21 jlec Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="tk"
inherit eutils flag-o-matic multilib prefix python-single-r1 toolchain-funcs
@@ -20,8 +20,8 @@ IUSE="examples"
RDEPEND="
app-shells/tcsh
- dev-lang/tcl
- dev-lang/tk"
+ dev-lang/tcl:0=
+ dev-lang/tk:0="
DEPEND="${RDEPEND}"
RESTRICT="mirror"
diff --git a/sci-chemistry/sparky/sparky-3.115.ebuild b/sci-chemistry/sparky/sparky-3.115.ebuild
deleted file mode 100644
index c20b86b161fe..000000000000
--- a/sci-chemistry/sparky/sparky-3.115.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/sparky/sparky-3.115.ebuild,v 1.4 2012/05/29 17:55:43 jlec Exp $
-
-EAPI="3"
-
-PYTHON_USE_WITH="tk"
-PYTHON_DEPEND="2"
-
-inherit eutils flag-o-matic multilib prefix python toolchain-funcs
-
-DESCRIPTION="Graphical NMR assignment and integration program for proteins, nucleic acids, and other polymers"
-HOMEPAGE="http://www.cgl.ucsf.edu/home/sparky/"
-SRC_URI="http://www.cgl.ucsf.edu/home/sparky/distrib-${PV}/${PN}-source-${PV}.tar.gz"
-
-LICENSE="sparky"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-RDEPEND="app-shells/tcsh"
-DEPEND="${RDEPEND}"
-
-RESTRICT="mirror"
-
-S="${WORKDIR}/${PN}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
- TKVER=$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)
- PYVER=$(python_get_version)
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-ldflags.patch
- epatch "${FILESDIR}"/${PV}-wrapper.patch
- epatch "${FILESDIR}"/${PV}-paths.patch
- epatch "${FILESDIR}"/${PV}-makefile.patch
-
- sed -i \
- -e "s:^\(set PYTHON =\).*:\1 ${EPREFIX}/usr/bin/python${PYVER}:g" \
- -e "s:^\(setenv SPARKY_INSTALL[[:space:]]*\).*:\1 ${EPREFIX}/usr/$(get_libdir)/${PN}:g" \
- -e "s:tcl8.4:tcl${TKVER}:g" \
- -e "s:tk8.4:tk${TKVER}:g" \
- -e "s:^\(setenv TCLTK_LIB[[:space:]]*\).*:\1 ${EPREFIX}/usr/$(get_libdir):g" \
- "${S}"/bin/sparky
- eprefixify "${S}"/bin/sparky
-}
-
-src_compile() {
- emake \
- SPARKY="${S}" \
- PYTHON_VERSION="${PYVER}" \
- PYTHON_PREFIX="${EPREFIX}/usr" \
- PYTHON_LIB="${EPREFIX}$(python_get_libdir)" \
- PYTHON_INC="${EPREFIX}$(python_get_includedir)" \
- TK_PREFIX="${EPREFIX}/usr" \
- TCLTK_VERSION="${TKVER}" \
- TKLIBS="-L${EPREFIX}/usr/$(get_libdir)/ -ltk${TKVER} -ltcl${TKVER} -lX11" \
- CXX="$(tc-getCXX)" \
- CC="$(tc-getCC)" \
- LDSHARED="-shared" \
- binaries || die "make failed"
-
- rm c++/*.o || die
-
- emake \
- SPARKY="${S}" \
- PYTHON_VERSION="${PYVER}" \
- PYTHON_PREFIX="${EPREFIX}/usr" \
- PYTHON_LIB="${EPREFIX}$(python_get_libdir)" \
- PYTHON_INC="${EPREFIX}$(python_get_includedir)" \
- TK_PREFIX="${EPREFIX}/usr" \
- TCLTK_VERSION="${TKVER}" \
- TKLIBS="-L${EPREFIX}/usr/$(get_libdir)/ -ltk${TKVER} -ltcl${TKVER} -lX11" \
- CXX="$(tc-getCXX)" \
- CC="$(tc-getCC)" \
- CXXFLAGS="${CXXFLAGS} -fPIC" \
- CFLAGS="${CFLAGS} -fPIC" \
- LDSHARED="-shared -fPIC" \
- libraries || die "make failed"
-}
-
-src_install() {
- # The symlinks are needed to avoid hacking the complete code to fix the locations
-
- dobin c++/{{bruk,matrix,peaks,pipe,vnmr}2ucsf,ucsfdata,sparky-no-python} bin/${PN} || die
-
- insinto /usr/share/${PN}/
- doins lib/{print-prolog.ps,Sparky} || die
- dosym ../../share/${PN}/print-prolog.ps /usr/$(get_libdir)/${PN}/print-prolog.ps
- dosym ../../share/${PN}/Sparky /usr/$(get_libdir)/${PN}/Sparky
-
- dohtml -r manual/* || die
- dosym ../../share/doc/${PF}/html /usr/$(get_libdir)/${PN}/manual
-
- insinto $(python_get_sitedir)/${PN}
- doins python/*.py c++/{spy.so,_tkinter.so} || die
- fperms 755 $(python_get_sitedir)/${PN}/{spy.so,_tkinter.so} || die
- dosym ../python${PYVER}/site-packages /usr/$(get_libdir)/${PN}/python
-
- if use examples; then
- insinto /usr/share/doc/${PF}/
- doins -r example || die
- dosym ../../share/doc/${PF}/example /usr/$(get_libdir)/${PN}/example
- fi
-
- dodoc README || die
- newdoc python/README README.python || die
-}
-
-pkg_postinst() {
- python_need_rebuild
- python_mod_optimize ${PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup ${PN}
-}