summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2007-11-25 14:54:46 +0000
committerDenis Dupeyron <calchan@gentoo.org>2007-11-25 14:54:46 +0000
commit0d2711e3620e36763d60f5033a4f082100a9a99a (patch)
tree2137553e1a3d1de60a7b518c5c77712036a954a3 /sci-electronics
parentstable x86, security bug 193132 (diff)
downloadgentoo-2-0d2711e3620e36763d60f5033a4f082100a9a99a.tar.gz
gentoo-2-0d2711e3620e36763d60f5033a4f082100a9a99a.tar.bz2
gentoo-2-0d2711e3620e36763d60f5033a4f082100a9a99a.zip
Version bump with guile-1.8 support, thanks to Fabio Rossi (bug #195072). Fixed linking with --as-needed instead of filtering it.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gwave/ChangeLog8
-rw-r--r--sci-electronics/gwave/files/digest-gwave-200705143
-rw-r--r--sci-electronics/gwave/gwave-20070514.ebuild45
3 files changed, 55 insertions, 1 deletions
diff --git a/sci-electronics/gwave/ChangeLog b/sci-electronics/gwave/ChangeLog
index 5a59541e8a92..1db72e8a79c4 100644
--- a/sci-electronics/gwave/ChangeLog
+++ b/sci-electronics/gwave/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-electronics/gwave
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gwave/ChangeLog,v 1.13 2007/06/22 22:30:23 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gwave/ChangeLog,v 1.14 2007/11/25 14:54:46 calchan Exp $
+
+*gwave-20070514 (25 Nov 2007)
+
+ 25 Nov 2007; Denis Dupeyron <calchan@gentoo.org> +gwave-20070514.ebuild:
+ Version bump with guile-1.8 support, thanks to Fabio Rossi (bug #195072).
+ Fixed linking with --as-needed instead of filtering it.
22 Jun 2007; Donnie Berkholz <dberkholz@gentoo.org>;
gwave-20031224.ebuild, gwave-20051222.ebuild:
diff --git a/sci-electronics/gwave/files/digest-gwave-20070514 b/sci-electronics/gwave/files/digest-gwave-20070514
new file mode 100644
index 000000000000..7315d41a31ac
--- /dev/null
+++ b/sci-electronics/gwave/files/digest-gwave-20070514
@@ -0,0 +1,3 @@
+MD5 766c8861e23d6401f03b7b31f900e8ed gwave2-20070514.tar.gz 462873
+RMD160 a7fa5572ab7bf9c640fa61af440eaffef4be2d25 gwave2-20070514.tar.gz 462873
+SHA256 ae8ec48946512103cafc84408e0b852f603abc4a65efa7bfe8252351444f7c4e gwave2-20070514.tar.gz 462873
diff --git a/sci-electronics/gwave/gwave-20070514.ebuild b/sci-electronics/gwave/gwave-20070514.ebuild
new file mode 100644
index 000000000000..f47d6702dfbb
--- /dev/null
+++ b/sci-electronics/gwave/gwave-20070514.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/gwave/gwave-20070514.ebuild,v 1.1 2007/11/25 14:54:46 calchan Exp $
+
+MY_P="${PN}2-${PV}"
+DESCRIPTION="Analog waveform viewer for SPICE-like simulations"
+LICENSE="GPL-2"
+HOMEPAGE="http://www.geda.seul.org/tools/gwave/"
+SRC_URI="http://www.geda.seul.org/dist/${MY_P}.tar.gz"
+
+KEYWORDS="~ppc ~x86"
+IUSE="gnuplot plotutils"
+SLOT="0"
+
+DEPEND="=dev-scheme/guile-1.8*
+ =x11-libs/guile-gtk-2*
+ dev-scheme/guile-gnome-platform"
+RDEPEND="${DEPEND}
+ gnuplot? ( sci-visualization/gnuplot )
+ plotutils? ( media-libs/plotutils )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix what seems to be an unintentional newline in the sources from upstream
+ sed -i -e '/readline "-l$/N;s/\n//' configure || die "sed failed"
+
+ # --as-needed fixes
+ sed -i -e 's/$(LINK) \($(.*_LDFLAGS)\) \($(.*_OBJECTS) $(.*_LDADD) $(LIBS)\)/$(LINK) \2 \1/' spicefile/Makefile.in || die "sed failed"
+ sed -i -e 's/_LDADD = @GTK_LIBS@/_LDADD = @GTK_LIBS@ -lX11/' remote/Makefile.in || die "sed failed"
+}
+
+src_compile() {
+ econf --disable-dependency-tracking || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ rm -f doc/Makefile* *.1 || die "Removing doc/Makefile failed"
+ dodoc AUTHORS NEWS README TODO || die "Installation of documentation failed"
+}