summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-01-07 02:50:56 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-01-07 02:50:56 +0000
commit58dfc9ba077a9e0f6ec9e0f9e00076c55c8e46b7 (patch)
tree24c29a73794829fbb1a4a23ef87ed9eaa7266ea4 /sci-libs/geos
parentVersion bump (diff)
downloadgentoo-2-58dfc9ba077a9e0f6ec9e0f9e00076c55c8e46b7.tar.gz
gentoo-2-58dfc9ba077a9e0f6ec9e0f9e00076c55c8e46b7.tar.bz2
gentoo-2-58dfc9ba077a9e0f6ec9e0f9e00076c55c8e46b7.zip
Version bump and removed useless .la files (bug #298887)
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/ChangeLog8
-rw-r--r--sci-libs/geos/geos-3.1.1.ebuild3
-rw-r--r--sci-libs/geos/geos-3.2.0.ebuild43
3 files changed, 52 insertions, 2 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index f35338748718..be66b47d352c 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.40 2010/01/02 18:12:19 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.41 2010/01/07 02:50:56 bicatali Exp $
+
+*geos-3.2.0 (07 Jan 2010)
+
+ 07 Jan 2010; Sébastien Fabbro <bicatali@gentoo.org> geos-3.1.1.ebuild,
+ +geos-3.2.0.ebuild:
+ Version bump and removed useless .la files (bug #298887)
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org> geos-3.1.1.ebuild:
Transfer Prefix keywords
diff --git a/sci-libs/geos/geos-3.1.1.ebuild b/sci-libs/geos/geos-3.1.1.ebuild
index 40efbbcf5a26..841892fa98b2 100644
--- a/sci-libs/geos/geos-3.1.1.ebuild
+++ b/sci-libs/geos/geos-3.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.1.1.ebuild,v 1.7 2010/01/02 18:12:19 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.1.1.ebuild,v 1.8 2010/01/07 02:50:56 bicatali Exp $
EAPI=2
inherit eutils
@@ -39,6 +39,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"usr/lib*/python*/site-packages/geos/_geos.*a || die
dodoc AUTHORS NEWS README TODO
if use doc; then
cd "${S}/doc"
diff --git a/sci-libs/geos/geos-3.2.0.ebuild b/sci-libs/geos/geos-3.2.0.ebuild
new file mode 100644
index 000000000000..2f98e49cff40
--- /dev/null
+++ b/sci-libs/geos/geos-3.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0.ebuild,v 1.1 2010/01/07 02:50:56 bicatali Exp $
+
+EAPI=2
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://geos.refractions.net"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby"
+
+RDEPEND="ruby? ( virtual/ruby )
+ python? ( virtual/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ ruby? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+src_configure() {
+ econf $(use_enable python) $(use_enable ruby)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ cd "${S}/doc"
+ emake doxygen-html || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -f "${D}"usr/lib*/python*/site-packages/geos/_geos.*a || die
+ dodoc AUTHORS NEWS README TODO
+ if use doc; then
+ cd "${S}/doc"
+ dohtml -r doxygen_docs/html/* || die
+ fi
+}