summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-05-06 17:45:16 +0000
committerFabian Groffen <grobian@gentoo.org>2012-05-06 17:45:16 +0000
commitf299d595bfb45315c6062f5958f6623d47ebf4c0 (patch)
treef6c3ad5f99711c94a677a3b65db4639ae0032b25 /sci-libs/geos
parentia64/s390/sh/sparc stable wrt #395735 (diff)
downloadgentoo-2-f299d595bfb45315c6062f5958f6623d47ebf4c0.tar.gz
gentoo-2-f299d595bfb45315c6062f5958f6623d47ebf4c0.tar.bz2
gentoo-2-f299d595bfb45315c6062f5958f6623d47ebf4c0.zip
Fix compilation on Solaris using GCC 4.6
(Portage version: 2.2.01.20430-prefix/cvs/SunOS i386)
Diffstat (limited to 'sci-libs/geos')
-rw-r--r--sci-libs/geos/ChangeLog6
-rw-r--r--sci-libs/geos/files/3.3.2-solaris-isnan.patch13
-rw-r--r--sci-libs/geos/geos-3.3.2.ebuild5
3 files changed, 21 insertions, 3 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index a4f7d18ff9d1..cb7b5c91ecd6 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.61 2012/02/20 15:27:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.62 2012/05/06 17:45:16 grobian Exp $
+
+ 06 May 2012; Fabian Groffen <grobian@gentoo.org>
+ +files/3.3.2-solaris-isnan.patch, geos-3.3.2.ebuild:
+ Fix compilation on Solaris using GCC 4.6
20 Feb 2012; Patrick Lauer <patrick@gentoo.org> geos-3.2.2.ebuild,
geos-3.3.2.ebuild:
diff --git a/sci-libs/geos/files/3.3.2-solaris-isnan.patch b/sci-libs/geos/files/3.3.2-solaris-isnan.patch
new file mode 100644
index 000000000000..04dc131e7df3
--- /dev/null
+++ b/sci-libs/geos/files/3.3.2-solaris-isnan.patch
@@ -0,0 +1,13 @@
+--- include/geos/platform.h.in
++++ include/geos/platform.h.in
+@@ -97,8 +97,9 @@
+ // It does leave a version in std.
+ # define ISNAN(x) (std::isnan(x))
+ # elif defined(__sun) || defined(__sun__)
++# define _XOPEN_SOURCE 600 // force iso/math_c99
+ # include <math.h>
+-# define ISNAN(x) (::isnan(x))
++# define ISNAN(x) (std::isnan(x))
+ # endif
+ #endif
+
diff --git a/sci-libs/geos/geos-3.3.2.ebuild b/sci-libs/geos/geos-3.3.2.ebuild
index 1dcce258128b..222a20483687 100644
--- a/sci-libs/geos/geos-3.3.2.ebuild
+++ b/sci-libs/geos/geos-3.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.3.2.ebuild,v 1.2 2012/02/20 15:27:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.3.2.ebuild,v 1.3 2012/05/06 17:45:16 grobian Exp $
EAPI=4
@@ -33,7 +33,8 @@ pkg_setup() {
src_prepare() {
epatch \
"${FILESDIR}"/3.2.0-python.patch \
- "${FILESDIR}"/3.2.0-darwin.patch
+ "${FILESDIR}"/3.2.0-darwin.patch \
+ "${FILESDIR}"/3.3.2-solaris-isnan.patch
eautoreconf
echo "#!${EPREFIX}/bin/bash" > py-compile
}