summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-16 10:54:28 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-16 10:54:28 +0000
commitc967ff6ac6412fb462b907eab14a6236d74a3207 (patch)
treef511e02f83f5cdcf7f4bcc8fa304f03f935f84e0 /sci-libs/itpp
parentStable for AMD64, wrt bug #393991 (diff)
downloadgentoo-2-c967ff6ac6412fb462b907eab14a6236d74a3207.tar.gz
gentoo-2-c967ff6ac6412fb462b907eab14a6236d74a3207.tar.bz2
gentoo-2-c967ff6ac6412fb462b907eab14a6236d74a3207.zip
Moved to autotools-utils.eclass in order to handle .a/.la correctly
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog5
-rw-r--r--sci-libs/itpp/itpp-4.2-r1.ebuild60
2 files changed, 38 insertions, 27 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 23f90871b251..956bab451dd3 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.102 2011/08/05 22:41:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.103 2011/12/16 10:54:28 jlec Exp $
+
+ 16 Dec 2011; Justin Lecher <jlec@gentoo.org> itpp-4.2-r1.ebuild:
+ Moved to autotools-utils.eclass in order to handle .a/.la correctly
05 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> itpp-4.2-r1.ebuild:
added autotools eclass
diff --git a/sci-libs/itpp/itpp-4.2-r1.ebuild b/sci-libs/itpp/itpp-4.2-r1.ebuild
index 723cb371f74d..3733c28ebcfe 100644
--- a/sci-libs/itpp/itpp-4.2-r1.ebuild
+++ b/sci-libs/itpp/itpp-4.2-r1.ebuild
@@ -1,53 +1,61 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.3 2011/08/05 22:41:52 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.4 2011/12/16 10:54:28 jlec Exp $
EAPI=4
-inherit flag-o-matic eutils autotools
+
+inherit autotools-utils flag-o-matic
DESCRIPTION="C++ library of mathematical, signal processing and communication"
-LICENSE="GPL-3"
HOMEPAGE="http://itpp.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
SLOT="0"
+LICENSE="GPL-3"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="blas debug doc fftw lapack minimal static-libs"
-RDEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3 ) )
- blas? ( virtual/blas lapack? ( virtual/lapack ) )"
+RDEPEND="
+ blas? ( virtual/blas lapack? ( virtual/lapack ) )
+ !minimal? ( fftw? ( >=sci-libs/fftw-3 ) )"
DEPEND="${RDEPEND}
blas? ( dev-util/pkgconfig )
- lapack? ( dev-util/pkgconfig )
- doc? ( app-doc/doxygen virtual/latex-base )"
+ doc? ( app-doc/doxygen virtual/latex-base )
+ lapack? ( dev-util/pkgconfig )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.7-fastica-fix-endless-loop.patch
+ "${FILESDIR}"/${PN}-4.2-fastica-correct-dim.patch
+ "${FILESDIR}"/${PN}-4.2-test-fftw.patch
+ )
src_prepare() {
- epatch "${FILESDIR}"/${PN}-4.0.7-fastica-fix-endless-loop.patch
- epatch "${FILESDIR}"/${PN}-4.2-fastica-correct-dim.patch
- epatch "${FILESDIR}"/${PN}-4.2-test-fftw.patch
+ # turn off performance critical debug code
+ use debug || append-flags -DNDEBUG
+ autotools-utils_src_prepare
eautoreconf
}
src_configure() {
- # turn off performance critical debug code
- use debug || append-flags -DNDEBUG
local blasconf="no"
use blas && blasconf="$(pkg-config --libs blas)"
local lapackconf="no"
use lapack && lapackconf="$(pkg-config --libs blas lapack)"
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --enable-shared \
- $(use_enable doc html-doc) \
- $(use_enable debug) \
- $(use_enable !minimal comm) \
- $(use_enable !minimal fixed) \
- $(use_enable !minimal optim) \
- $(use_enable !minimal protocol) \
- $(use_enable !minimal signal) \
- $(use_enable !minimal srccode) \
- $(use_enable static-libs static) \
- $(use_with fftw fft) \
- --with-blas="${blasconf}" \
+
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-shared
+ $(use_enable doc html-doc)
+ $(use_enable debug)
+ $(use_enable !minimal comm)
+ $(use_enable !minimal fixed)
+ $(use_enable !minimal optim)
+ $(use_enable !minimal protocol)
+ $(use_enable !minimal signal)
+ $(use_enable !minimal srccode)
+ $(use_with fftw fft)
+ --with-blas="${blasconf}"
--with-lapack="${lapackconf}"
+ )
+ autotools-utils_src_configure
}