summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-06-30 19:18:14 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-06-30 19:18:14 +0000
commit465c273a4beb5356fdb2509fd0fba6451825bc2d (patch)
tree42d90a782506e24f5d939f4d2a65893d75b10f1d /sci-libs/libspatialindex
parentversion bump (diff)
downloadgentoo-2-465c273a4beb5356fdb2509fd0fba6451825bc2d.tar.gz
gentoo-2-465c273a4beb5356fdb2509fd0fba6451825bc2d.tar.bz2
gentoo-2-465c273a4beb5356fdb2509fd0fba6451825bc2d.zip
version bump
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'sci-libs/libspatialindex')
-rw-r--r--sci-libs/libspatialindex/ChangeLog9
-rw-r--r--sci-libs/libspatialindex/files/libspatialindex-1.8.1-QA.patch15
-rw-r--r--sci-libs/libspatialindex/files/libspatialindex-1.8.1-pkgconfig.patch16
-rw-r--r--sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild37
4 files changed, 76 insertions, 1 deletions
diff --git a/sci-libs/libspatialindex/ChangeLog b/sci-libs/libspatialindex/ChangeLog
index 02495333363d..ee47f2543545 100644
--- a/sci-libs/libspatialindex/ChangeLog
+++ b/sci-libs/libspatialindex/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/libspatialindex
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libspatialindex/ChangeLog,v 1.4 2013/06/25 12:57:40 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libspatialindex/ChangeLog,v 1.5 2013/06/30 19:18:14 hasufell Exp $
+
+*libspatialindex-1.8.1 (30 Jun 2013)
+
+ 30 Jun 2013; Julian Ospald <hasufell@gentoo.org>
+ +libspatialindex-1.8.1.ebuild, +files/libspatialindex-1.8.1-QA.patch,
+ +files/libspatialindex-1.8.1-pkgconfig.patch:
+ version bump
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> libspatialindex-1.8.0.ebuild:
Stable for amd64, wrt bug #474422
diff --git a/sci-libs/libspatialindex/files/libspatialindex-1.8.1-QA.patch b/sci-libs/libspatialindex/files/libspatialindex-1.8.1-QA.patch
new file mode 100644
index 000000000000..446452dc9ef1
--- /dev/null
+++ b/sci-libs/libspatialindex/files/libspatialindex-1.8.1-QA.patch
@@ -0,0 +1,15 @@
+--- spatialindex-src-1.8.0/configure.ac
++++ spatialindex-src-1.8.0/configure.ac
+@@ -49,10 +49,10 @@
+ AC_ARG_ENABLE(debug, [ --enable-debug=[no/yes] turn on debugging [default=$debug_default]],, enable_debug=$debug_default)
+
+ if test "x$enable_debug" = "xyes"; then
+- CXXFLAGS="$CXXFLAGS -g -DDEBUG"
++ CXXFLAGS="$CXXFLAGS -DDEBUG"
+ AC_MSG_RESULT(checking wether debug information is enabled... yes)
+ else
+- CXXFLAGS="$CXXFLAGS -O2 -DNDEBUG"
++ CXXFLAGS="$CXXFLAGS -DNDEBUG"
+ AC_MSG_RESULT(checking wether debug information is enabled... no)
+ fi
+
diff --git a/sci-libs/libspatialindex/files/libspatialindex-1.8.1-pkgconfig.patch b/sci-libs/libspatialindex/files/libspatialindex-1.8.1-pkgconfig.patch
new file mode 100644
index 000000000000..a17aa80926b1
--- /dev/null
+++ b/sci-libs/libspatialindex/files/libspatialindex-1.8.1-pkgconfig.patch
@@ -0,0 +1,16 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Jun 30 19:10:57 UTC 2013
+Subject: remove LDFLAGS from Libs field
+
+https://github.com/libspatialindex/libspatialindex/issues/23
+
+--- spatialindex-src-1.8.1/src/libspatialindex.pc.in
++++ spatialindex-src-1.8.1/src/libspatialindex.pc.in
+@@ -7,6 +7,6 @@
+ Description: Generic C/C++ library for spatial indexing
+ Requires:
+ Version: @PACKAGE_VERSION@
+-Libs: -L@libdir@ @LDFLAGS@
++Libs: -L@libdir@
+ Cflags: -I${includedir}/spatialindex @CFLAGS@ @CPPFLAGS@
+
diff --git a/sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild b/sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild
new file mode 100644
index 000000000000..e20222ca3692
--- /dev/null
+++ b/sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libspatialindex/libspatialindex-1.8.1.ebuild,v 1.1 2013/06/30 19:18:14 hasufell Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+MY_PN="spatialindex-src"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="General framework for developing spatial indices"
+HOMEPAGE="http://libspatialindex.github.com/"
+SRC_URI="http://download.osgeo.org/libspatialindex/${MY_P}.tar.bz2"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug static-libs"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{QA,pkgconfig}.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+}