summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-22 15:11:46 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-22 15:11:46 +0000
commitea24ecad1f270f9269149c16388aeb5a86d8affa (patch)
tree1012e0f0fba19a3e7d26fb75430cf7e50255af72 /sci-libs/xkaapi
parentVersion bump (diff)
downloadgentoo-2-ea24ecad1f270f9269149c16388aeb5a86d8affa.tar.gz
gentoo-2-ea24ecad1f270f9269149c16388aeb5a86d8affa.tar.bz2
gentoo-2-ea24ecad1f270f9269149c16388aeb5a86d8affa.zip
sci-libs/xkaapi: Version BUmp
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/xkaapi')
-rw-r--r--sci-libs/xkaapi/ChangeLog8
-rw-r--r--sci-libs/xkaapi/files/xkaapi-3.0.3-flags.patch31
-rw-r--r--sci-libs/xkaapi/metadata.xml16
-rw-r--r--sci-libs/xkaapi/xkaapi-3.0.3.ebuild57
4 files changed, 103 insertions, 9 deletions
diff --git a/sci-libs/xkaapi/ChangeLog b/sci-libs/xkaapi/ChangeLog
index 06e299111752..4d29ca0a0ad9 100644
--- a/sci-libs/xkaapi/ChangeLog
+++ b/sci-libs/xkaapi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/xkaapi
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/xkaapi/ChangeLog,v 1.2 2014/07/31 23:29:18 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/xkaapi/ChangeLog,v 1.3 2014/12/22 15:11:46 jlec Exp $
+
+*xkaapi-3.0.3 (22 Dec 2014)
+
+ 22 Dec 2014; Justin Lecher <jlec@gentoo.org> +xkaapi-3.0.3.ebuild,
+ +files/xkaapi-3.0.3-flags.patch, metadata.xml:
+ Version BUmp
31 Jul 2014; Maciej Mrozowski <reavertm@gentoo.org> xkaapi-2.1.ebuild:
Remove explicit src_test override since eclass is fixed, bug 499580.
diff --git a/sci-libs/xkaapi/files/xkaapi-3.0.3-flags.patch b/sci-libs/xkaapi/files/xkaapi-3.0.3-flags.patch
new file mode 100644
index 000000000000..0fdad94cb9b9
--- /dev/null
+++ b/sci-libs/xkaapi/files/xkaapi-3.0.3-flags.patch
@@ -0,0 +1,31 @@
+ configure.ac | 11 ++++++++++-
+ 1 file changed, 10 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index c3364aa..2a734fe 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -82,6 +82,9 @@ AC_PROG_F77
+ dnl ----------------------------------------------------------------
+ dnl Disable default flag for compilation
+ dnl ----------------------------------------------------------------
++CPPFLAGS_gentoo="${CPPFLAGS}"
++CFLAGS_gentoo="${CFLAGS}"
++CXXFLAGS_gentoo="${CXXFLAGS}"
+ CPPFLAGS=""
+ CFLAGS=""
+ CXXFLAGS=""
+@@ -428,6 +431,13 @@ AS_CASE([$enable_mode],
+ AM_CXXFLAGS="$AM_CXXFLAGS -O3 -DNDEBUG"
+ clean_default_flags=yes
+ AM_CONDITIONAL([KAAPI_USE_DEBUG], [test "$enable_mode" = truc ])
++ ], [gentoo], [dnl
++ AC_MSG_NOTICE([Using gentoo compile mode])
++ AM_CPPFLAGS="$AM_CPPFLAGS ${CPPFLAGS_gentoo}"
++ AM_CFLAGS="$AM_CFLAGS -DNDEBUG ${CFLAGS_gentoo}"
++ AM_CXXFLAGS="$AM_CXXFLAGS -DNDEBUG ${CXXFLAGS_gentoo}"
++ clean_default_flags=yes
++ AM_CONDITIONAL([KAAPI_USE_DEBUG], [test "$enable_mode" = gentoo ])
+ ], [dnl
+ AC_MSG_ERROR([Unknown compilation mode '$enable_mode'. Aborting.])
+ ])
diff --git a/sci-libs/xkaapi/metadata.xml b/sci-libs/xkaapi/metadata.xml
index c635cb9c94ab..49f365fd7720 100644
--- a/sci-libs/xkaapi/metadata.xml
+++ b/sci-libs/xkaapi/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
-<use>
- <flag name="blas">Kaapi BLAS tasks for PLASMA</flag>
- <flag name="gpu">Build library for gpu threading</flag>
-</use>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="blas">Kaapi BLAS tasks for PLASMA</flag>
+ <flag name="gpu">Build library for gpu threading</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-libs/xkaapi/xkaapi-3.0.3.ebuild b/sci-libs/xkaapi/xkaapi-3.0.3.ebuild
new file mode 100644
index 000000000000..56a17b031657
--- /dev/null
+++ b/sci-libs/xkaapi/xkaapi-3.0.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/xkaapi/xkaapi-3.0.3.ebuild,v 1.1 2014/12/22 15:11:46 jlec Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2
+
+UPSTREAM_NO=34360
+
+DESCRIPTION="Kernel for Adaptative, Asynchronous Parallel and Interactive programming"
+HOMEPAGE="http://kaapi.gforge.inria.fr"
+SRC_URI="https://gforge.inria.fr/frs/download.php/${UPSTREAM_NO}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="CeCILL-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="blas cxx fortran gpu openmp static-libs"
+
+RDEPEND="
+ sys-apps/hwloc
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ )
+
+src_prepare() {
+ sed \
+ -e 's:-Werror::g' \
+ -i tests/testsuite* tests/*/*.am || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-mode=gentoo
+ --enable-api-kaapic
+ --enable-api-quark
+ --with-ccache=no
+ --enable-hwloc
+ --with-libffi="${EPREFIX}"/usr
+ --enable-target$(usex gpu gpu mt)
+ $(use_enable fortran api-kaapif)
+ $(use_enable cxx api-kaapixx)
+ $(use_enable blas kblas)
+ $(use_enable openmp libkomp)
+# $(use_with plasma "${EPREFIX}"/usr)
+ )
+ autotools-utils_src_configure
+}