summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-06 07:45:01 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-06 07:45:01 +0000
commit3e9a936bc293d41fa7e7b220b889a2492e87c632 (patch)
tree49f965c54b05005788a9359d82ec262cea6e34d3 /sci-libs
parentRemove unnecessary x11-plugins/enigmail entry. (diff)
downloadgentoo-2-3e9a936bc293d41fa7e7b220b889a2492e87c632.tar.gz
gentoo-2-3e9a936bc293d41fa7e7b220b889a2492e87c632.tar.bz2
gentoo-2-3e9a936bc293d41fa7e7b220b889a2492e87c632.zip
sci-libs/itpp: Add fix for automake-1.12, #317328; add missing eclass; don't run elibtoolize twice
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/ChangeLog7
-rw-r--r--sci-libs/itpp/files/itpp-4.2-automake-1.12.patch16
-rw-r--r--sci-libs/itpp/itpp-4.0.6.ebuild4
-rw-r--r--sci-libs/itpp/itpp-4.2-r1.ebuild10
4 files changed, 30 insertions, 7 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index c02fe6f74639..bdd4f10892c6 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.111 2012/05/04 08:22:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.112 2012/07/06 07:45:00 jlec Exp $
+
+ 06 Jul 2012; Justin Lecher <jlec@gentoo.org> itpp-4.0.6.ebuild,
+ itpp-4.2-r1.ebuild, +files/itpp-4.2-automake-1.12.patch:
+ Add fix for automake-1.12, #317328; add missing eclass; don't run elibtoolize
+ twice
04 May 2012; Jeff Horelick <jdhore@gentoo.org> itpp-4.2-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch b/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch
new file mode 100644
index 000000000000..aa8723b215a5
--- /dev/null
+++ b/sci-libs/itpp/files/itpp-4.2-automake-1.12.patch
@@ -0,0 +1,16 @@
+ configure.ac | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4f06171..84044ff 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -104,6 +104,8 @@ case $enable_explicit_deps in
+ esac
+ AC_MSG_RESULT($enable_explicit_deps)
+
++AM_PROG_AR
++
+ # Set default language to C++
+ AC_LANG([C++])
+
diff --git a/sci-libs/itpp/itpp-4.0.6.ebuild b/sci-libs/itpp/itpp-4.0.6.ebuild
index ee0ba1b01598..fb4d5b5a36ec 100644
--- a/sci-libs/itpp/itpp-4.0.6.ebuild
+++ b/sci-libs/itpp/itpp-4.0.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.6.ebuild,v 1.10 2012/04/26 15:23:43 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.6.ebuild,v 1.11 2012/07/06 07:45:01 jlec Exp $
-inherit flag-o-matic
+inherit eutils flag-o-matic
DESCRIPTION="C++ library of mathematical, signal processing and communication"
HOMEPAGE="http://itpp.sourceforge.net/"
diff --git a/sci-libs/itpp/itpp-4.2-r1.ebuild b/sci-libs/itpp/itpp-4.2-r1.ebuild
index 9209ee7f8256..041e4d32c0ed 100644
--- a/sci-libs/itpp/itpp-4.2-r1.ebuild
+++ b/sci-libs/itpp/itpp-4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.11 2012/05/04 08:22:52 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2-r1.ebuild,v 1.12 2012/07/06 07:45:00 jlec Exp $
EAPI=4
@@ -25,8 +25,9 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${PN}-4.0.7-fastica-fix-endless-loop.patch
- "${FILESDIR}"/${PN}-4.2-fastica-correct-dim.patch
- "${FILESDIR}"/${PN}-4.2-test-fftw.patch
+ "${FILESDIR}"/${P}-fastica-correct-dim.patch
+ "${FILESDIR}"/${P}-test-fftw.patch
+ "${FILESDIR}"/${P}-automake-1.12.patch
)
src_prepare() {
@@ -34,9 +35,10 @@ src_prepare() {
use debug || append-flags -DNDEBUG
sed \
-e 's:-pipe::g' \
+ -e 's:-Werror::g' \
-i configure* || die
autotools-utils_src_prepare
- eautoreconf
+ AT_NOELIBTOOLIZE=yes eautoreconf
}
src_configure() {