summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-04-05 23:39:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-04-05 23:39:34 +0000
commitea78422841b395b74be9daae1c0cc0f5186f1c1d (patch)
tree8b2e77820e5a64d9f22563b4d7460443da25e88e /sci-libs
parentRemove ree18 and ruby18 target. (diff)
downloadgentoo-2-ea78422841b395b74be9daae1c0cc0f5186f1c1d.tar.gz
gentoo-2-ea78422841b395b74be9daae1c0cc0f5186f1c1d.tar.bz2
gentoo-2-ea78422841b395b74be9daae1c0cc0f5186f1c1d.zip
Version bump
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/arprec/ChangeLog9
-rw-r--r--sci-libs/arprec/arprec-2.2.17.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/sci-libs/arprec/ChangeLog b/sci-libs/arprec/ChangeLog
index 2547756d3cb6..9dfd5502ab6c 100644
--- a/sci-libs/arprec/ChangeLog
+++ b/sci-libs/arprec/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/arprec
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/arprec/ChangeLog,v 1.17 2012/12/22 18:39:31 hwoarang Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/arprec/ChangeLog,v 1.18 2014/04/05 23:39:34 bicatali Exp $
+
+*arprec-2.2.17 (05 Apr 2014)
+
+ 05 Apr 2014; Sébastien Fabbro <bicatali@gentoo.org> +arprec-2.2.17.ebuild:
+ Version bump
22 Dec 2012; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add missing space. Bug #448182
diff --git a/sci-libs/arprec/arprec-2.2.17.ebuild b/sci-libs/arprec/arprec-2.2.17.ebuild
new file mode 100644
index 000000000000..3472996afb09
--- /dev/null
+++ b/sci-libs/arprec/arprec-2.2.17.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/arprec/arprec-2.2.17.ebuild,v 1.1 2014/04/05 23:39:34 bicatali Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD="90"
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit eutils fortran-2 autotools-utils
+
+DESCRIPTION="Arbitrary precision float arithmetics and functions"
+HOMEPAGE="http://crd.lbl.gov/~dhbailey/mpdist/"
+SRC_URI="http://crd.lbl.gov/~dhbailey/mpdist/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc fma fortran qd static-libs"
+
+DEPEND="qd? ( sci-libs/qd:0=[fortran=] )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ $(use_enable fma)
+ $(use_enable fortran)
+ $(use_enable qd)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use fortran && autotools-utils_src_compile toolkit
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use fortran; then
+ cd toolkit
+ ./mathinit || die "mathinit failed"
+ exeinto /usr/libexec/${PN}
+ doexe .libs/mathtool
+ insinto /usr/libexec/${PN}
+ doins *.dat
+ echo > mathtool.exe "#!${EROOT%/}/bin/sh"
+ echo >> mathtool.exe "cd ${EROOT%/}/usr/libexec/arprec && exec ./mathtool"
+ newbin mathtool.exe mathtool
+ newdoc README README.mathtool
+ fi
+ use doc || rm "${ED}"/usr/share/doc/${PF}/*.pdf
+}