summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-07 05:12:39 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-07 05:12:39 +0000
commitc045986699c5fbb7a8365e0eef19ce558bad0099 (patch)
tree5489aac918ae044567411a868b73b5086f38d751 /sci-mathematics/calc
parentVersion bump. Removed old. (diff)
downloadgentoo-2-c045986699c5fbb7a8365e0eef19ce558bad0099.tar.gz
gentoo-2-c045986699c5fbb7a8365e0eef19ce558bad0099.tar.bz2
gentoo-2-c045986699c5fbb7a8365e0eef19ce558bad0099.zip
Version bump
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sci-mathematics/calc')
-rw-r--r--sci-mathematics/calc/ChangeLog10
-rw-r--r--sci-mathematics/calc/calc-2.12.4.3.ebuild (renamed from sci-mathematics/calc/calc-2.12.4.0.ebuild)28
2 files changed, 28 insertions, 10 deletions
diff --git a/sci-mathematics/calc/ChangeLog b/sci-mathematics/calc/ChangeLog
index 168ea3ebcc84..ffbf825974b5 100644
--- a/sci-mathematics/calc/ChangeLog
+++ b/sci-mathematics/calc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-mathematics/calc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/ChangeLog,v 1.21 2010/06/15 15:43:48 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/ChangeLog,v 1.22 2011/03/07 05:12:39 bicatali Exp $
+
+*calc-2.12.4.3 (07 Mar 2011)
+
+ 07 Mar 2011; Sébastien Fabbro <bicatali@gentoo.org> -calc-2.12.4.0.ebuild,
+ +calc-2.12.4.3.ebuild:
+ Version bump
*calc-2.12.4.0-r1 (15 Jun 2010)
diff --git a/sci-mathematics/calc/calc-2.12.4.0.ebuild b/sci-mathematics/calc/calc-2.12.4.3.ebuild
index b41d4f719f3b..6fd76b3d3f76 100644
--- a/sci-mathematics/calc/calc-2.12.4.0.ebuild
+++ b/sci-mathematics/calc/calc-2.12.4.3.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/calc-2.12.4.0.ebuild,v 1.2 2010/01/07 17:21:15 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/calc/calc-2.12.4.3.ebuild,v 1.1 2011/03/07 05:12:39 bicatali Exp $
-EAPI=2
-inherit eutils
+EAPI="3"
+
+inherit eutils multilib toolchain-funcs
DESCRIPTION="An arbitrary precision C-like arithmetic system"
HOMEPAGE="http://www.isthe.com/chongo/tech/comp/calc/"
@@ -11,23 +12,34 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
SLOT="0"
LICENSE="LGPL-2"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
IUSE=""
-DEPEND=">=sys-libs/ncurses-5.2
+DEPEND="
+ >=sys-libs/ncurses-5.2
>=sys-libs/readline-4.2"
RDEPEND="${DEPEND}"
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.12.4.0-prefix.patch
+ epatch "${FILESDIR}"/2.12.4.0-ldflags.patch
+ ln -sf libcustcalc.so.${PV} custom/libcustcalc.so
+}
+
src_compile() {
# parallel compilation hard to fix. better to leave upstream.
emake -j1 \
+ CC=$(tc-getCC) \
DEBUG="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
CALCPAGER="${PAGER}" \
USE_READLINE="-DUSE_READLINE" \
- READLINE_LIB="-lreadline -lhistory -lncurses" \
+ READLINE_LIB="-lreadline -lhistory -lncurses -L${S}/custom -lcustcalc" \
all || die "emake failed"
+}
+src_test() {
if echo "${LD_PRELOAD}" | grep -q "sandbox"; then
ewarn "Can't run check when running in sandbox - see bug #59676"
else
@@ -36,6 +48,6 @@ src_compile() {
}
src_install() {
- emake T="${D}" LIBDIR="/usr/$(get_libdir)" install || die "emake install failed"
+ emake T="${D}" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install || die "emake install failed"
dodoc BUGS CHANGES LIBRARY README
}