summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-02-20 05:39:59 +0000
committerMark Wright <gienah@gentoo.org>2014-02-20 05:39:59 +0000
commit41191fe6bff5670f09b74bbcf899726846d99d11 (patch)
tree6a60794d5f604e6e3347149471c46069aa6f5855 /sci-mathematics/octave
parentVarious bugfixes. (diff)
downloadgentoo-2-41191fe6bff5670f09b74bbcf899726846d99d11.tar.gz
gentoo-2-41191fe6bff5670f09b74bbcf899726846d99d11.tar.bz2
gentoo-2-41191fe6bff5670f09b74bbcf899726846d99d11.zip
Fix bug 501756 - sci-mathematics/octave-3.8.0 LC_ALL=et_EE - octave.cc:485:56: error: Fallow_noninteger_range_as_index was not declared in this scope. Thanks to Priit Laes for reporting and debugging.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sci-mathematics/octave')
-rw-r--r--sci-mathematics/octave/ChangeLog7
-rw-r--r--sci-mathematics/octave/octave-3.8.0.ebuild10
2 files changed, 14 insertions, 3 deletions
diff --git a/sci-mathematics/octave/ChangeLog b/sci-mathematics/octave/ChangeLog
index 37e082ff3aa1..ced59a472e32 100644
--- a/sci-mathematics/octave/ChangeLog
+++ b/sci-mathematics/octave/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/octave
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.152 2014/02/20 03:05:52 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/ChangeLog,v 1.153 2014/02/20 05:39:59 gienah Exp $
+
+ 20 Feb 2014; Mark Wright <gienah@gentoo.org> octave-3.8.0.ebuild:
+ Fix bug 501756 - sci-mathematics/octave-3.8.0 LC_ALL=et_EE - octave.cc:485:56:
+ error: Fallow_noninteger_range_as_index was not declared in this scope. Thanks
+ to Priit Laes for reporting and debugging.
20 Feb 2014; Mark Wright <gienah@gentoo.org>
files/octave-3.8.0-imagemagick.patch:
diff --git a/sci-mathematics/octave/octave-3.8.0.ebuild b/sci-mathematics/octave/octave-3.8.0.ebuild
index 560fffc9ab86..6443702f69df 100644
--- a/sci-mathematics/octave/octave-3.8.0.ebuild
+++ b/sci-mathematics/octave/octave-3.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.8.0.ebuild,v 1.4 2014/02/20 01:57:16 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/octave/octave-3.8.0.ebuild,v 1.5 2014/02/20 05:39:59 gienah Exp $
EAPI=5
@@ -82,7 +82,7 @@ PATCHES=(
pkg_pretend() {
if use qrupdate || use sparse; then
- local blaslib=$(pkg-config --libs-only-l "blas" | sed -e 's@-l\([^ \t]*\)@lib\1@' | cut -d' ' -f 1)
+ local blaslib=$(pkg-config --libs-only-l blas | sed -e 's@-l\([^ \t]*\)@lib\1@' | cut -d' ' -f 1)
einfo "Checking dependencies are built with the same blas lib = ${blaslib}"
local usr_lib="${ROOT}usr/$(get_libdir)"
local libs=( )
@@ -136,6 +136,12 @@ src_prepare() {
ewarn "with OpenGL graphics requires the gl2ps - but at the time of writing x11-libs/gl2ps"
ewarn "does not have the hppa keyword"
fi
+ # Fix bug 501756 - sci-mathematics/octave-3.8.0 LC_ALL=et_EE - octave.cc:485:56:
+ # error: 'Fallow_noninteger_range_as_index' was not declared in this scope
+ sed -e 's@A-Za-z0-9@[:alnum:]@g' \
+ -e 's@A-Za-z@[:alpha:]@g' \
+ -i "${S}/libinterp/mkbuiltins" \
+ || die "Could not patch ${S}/libinterp/mkbuiltins for some non-English nocaled"
autotools-utils_src_prepare
}