summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2015-07-05 20:43:27 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2015-07-05 20:43:27 +0000
commitc1b14e5debcf3f2e3383b7883b00ea7b70b06066 (patch)
tree9a57259d10901cf8d33573eac51a3e34a64f2ee3 /sci-mathematics
parentarm stable wrt bug #552618 (diff)
downloadgentoo-2-c1b14e5debcf3f2e3383b7883b00ea7b70b06066.tar.gz
gentoo-2-c1b14e5debcf3f2e3383b7883b00ea7b70b06066.tar.bz2
gentoo-2-c1b14e5debcf3f2e3383b7883b00ea7b70b06066.zip
version bump: close bug 553942, thanks to OGINO Masanori
(Portage version: 2.2.18/cvs/Linux i686, signed Manifest commit with key B2EFA1D4)
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/ChangeLog7
-rw-r--r--sci-mathematics/coq/coq-8.4_p6.ebuild103
2 files changed, 109 insertions, 1 deletions
diff --git a/sci-mathematics/coq/ChangeLog b/sci-mathematics/coq/ChangeLog
index 85ccaafe0c73..278e67509e83 100644
--- a/sci-mathematics/coq/ChangeLog
+++ b/sci-mathematics/coq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-mathematics/coq
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.87 2015/06/27 09:48:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/ChangeLog,v 1.88 2015/07/05 20:43:27 jauhien Exp $
+
+*coq-8.4_p6 (05 Jul 2015)
+
+ 05 Jul 2015; Jauhien Piatlicki <jauhien@gentoo.org> +coq-8.4_p6.ebuild:
+ version bump: close bug 553942, thanks to OGINO Masanori
27 Jun 2015; Agostino Sarubbo <ago@gentoo.org> coq-8.4_p5.ebuild:
Stable for amd64, wrt bug #553322
diff --git a/sci-mathematics/coq/coq-8.4_p6.ebuild b/sci-mathematics/coq/coq-8.4_p6.ebuild
new file mode 100644
index 000000000000..d29bd46f5261
--- /dev/null
+++ b/sci-mathematics/coq/coq-8.4_p6.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/coq/coq-8.4_p6.ebuild,v 1.1 2015/07/05 20:43:27 jauhien Exp $
+
+EAPI="5"
+
+inherit eutils multilib
+
+MY_PV=${PV/_p/pl}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="http://${PN}.inria.fr/distrib/V${MY_PV}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk debug +ocamlopt doc camlp5"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.11.2:=[ocamlopt?]
+ camlp5? ( >=dev-ml/camlp5-6.02.3:=[ocamlopt?] )
+ !camlp5? ( || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 ) )
+ gtk? ( >=dev-ml/lablgtk-2.10.1:=[ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? (
+ media-libs/netpbm[png,zlib]
+ virtual/latex-base
+ dev-tex/hevea
+ dev-tex/xcolor
+ dev-texlive/texlive-pictures
+ dev-texlive/texlive-mathextra
+ dev-texlive/texlive-latexextra
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-8.4_p5-do-not-install-revision.patch"
+ # Fix generation of the index_urls.txt file with Gentoo dev-tex/hevea versions.
+ # http://lists.gforge.inria.fr/pipermail/coq-commits/2014-October/013582.html
+ epatch "${FILESDIR}/${PN}-8.4_p5-hevea.patch"
+ epatch "${FILESDIR}/${PN}-8.4_p5-no-clean-before-test.patch"
+}
+
+src_configure() {
+ ocaml_lib=$(ocamlc -where)
+ local myconf=(
+ --prefix /usr
+ --bindir /usr/bin
+ --libdir /usr/$(get_libdir)/coq
+ --mandir /usr/share/man
+ --emacslib /usr/share/emacs/site-lisp
+ --coqdocdir /usr/$(get_libdir)/coq/coqdoc
+ --docdir /usr/share/doc/${PF}
+ --configdir /etc/xdg/${PN}
+ --lablgtkdir ${ocaml_lib}/lablgtk2
+ )
+
+ use debug && myconf+=( --debug )
+ use doc || myconf+=( --with-doc no )
+
+ if use gtk; then
+ if use ocamlopt; then
+ myconf+=( --coqide opt )
+ else
+ myconf+=( --coqide byte )
+ fi
+ else
+ myconf+=( --coqide no )
+ fi
+
+ if use ocamlopt; then
+ myconf+=( --opt )
+ else
+ myconf+=( -byte-only )
+ fi
+
+ if use camlp5; then
+ myconf+=( --camlp5dir ${ocaml_lib}/camlp5 )
+ else
+ myconf+=( --usecamlp4 )
+ fi
+
+ export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
+ ./configure ${myconf[@]} || die "configure failed"
+}
+
+src_compile() {
+ emake STRIP="true" -j1 world VERBOSE=1
+}
+
+src_test() {
+ emake STRIP="true" check VERBOSE=1
+}
+
+src_install() {
+ emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
+ dodoc README CREDITS CHANGES
+
+ use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
+}