summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-08 01:32:14 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-08 01:32:14 +0000
commita038587c857870e8da7b30171ace1bedd6a64bd3 (patch)
tree0038646e0cdbb7dd52910b2fba9878c411c8ef79 /sci-physics
parentapp-admin/con removal. Bugs 375071, 256850, 214192, 202497 (diff)
downloadgentoo-2-a038587c857870e8da7b30171ace1bedd6a64bd3.tar.gz
gentoo-2-a038587c857870e8da7b30171ace1bedd6a64bd3.tar.bz2
gentoo-2-a038587c857870e8da7b30171ace1bedd6a64bd3.zip
Version bump. Use autotools-eclass. Link with gmp when cgal is built with gmp. Merged plugins flags into one. Initial import to the main tree.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/fastjet/ChangeLog16
-rw-r--r--sci-physics/fastjet/Manifest4
-rw-r--r--sci-physics/fastjet/fastjet-3.0.1.ebuild46
-rw-r--r--sci-physics/fastjet/metadata.xml19
4 files changed, 85 insertions, 0 deletions
diff --git a/sci-physics/fastjet/ChangeLog b/sci-physics/fastjet/ChangeLog
new file mode 100644
index 000000000000..f09514ec70c8
--- /dev/null
+++ b/sci-physics/fastjet/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for sci-physics/fastjet
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/ChangeLog,v 1.1 2012/01/08 01:32:14 bicatali Exp $
+
+*fastjet-3.0.1 (08 Jan 2012)
+
+ 08 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> +fastjet-3.0.1.ebuild,
+ +metadata.xml:
+ Version bump. Use autotools-eclass. Link with gmp when cgal is built with
+ gmp. Merged plugins flags into one. Initial import to the main tree.
+
+ 30 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> fastjet-2.4.4.ebuild:
+ Remove unused eutils.eclass, shorten DESC, add missing license, sort
+ KEYWORDS, add static-libs, docs IUSE, add dependency on doxygen for [doc],
+ build only shared libs by default, install documentation
+
diff --git a/sci-physics/fastjet/Manifest b/sci-physics/fastjet/Manifest
new file mode 100644
index 000000000000..a80c9285e6b2
--- /dev/null
+++ b/sci-physics/fastjet/Manifest
@@ -0,0 +1,4 @@
+DIST fastjet-3.0.1.tar.gz 2122452 RMD160 db8da72c845e9782fb2d8b796cb4e87f83f5f68e SHA1 00c2155db3ed82db36d688d0a501b6232f23c804 SHA256 4f17c235e73a6fcbc8ee39c15a00f166b701e732033e623625f55fe93220a4ed
+EBUILD fastjet-3.0.1.ebuild 1085 RMD160 cc9ae598a1b554c3dd2f49f785a34fb1c2022b67 SHA1 51a0a03821241c93799a897736fa9adeb64ec46c SHA256 0818b5ce58d7a64cb1bbc9cc6a860c0b5d4c921da9e8f0b8e72cb47d1cd8bea0
+MISC ChangeLog 677 RMD160 141f689b076e91e6a05601dbeb29f33677720972 SHA1 ad5db3bdfe04b603794bcbc1ce285df53564ebc9 SHA256 5d20b8c149676e7e6eb6e1d551e2028efaf7d17e4409e1e4cbedff3cde59947f
+MISC metadata.xml 770 RMD160 f6ec58006506a950fe36a8a2a761d58398e2dea1 SHA1 7d03be13f80119c6bb908c03dd820bfa33409c26 SHA256 d4b7a99b53a609ac44459ff596354b014204aed5303ed8d8d8b0ad1d6e4f2f4a
diff --git a/sci-physics/fastjet/fastjet-3.0.1.ebuild b/sci-physics/fastjet/fastjet-3.0.1.ebuild
new file mode 100644
index 000000000000..fd02fa20ca9f
--- /dev/null
+++ b/sci-physics/fastjet/fastjet-3.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/fastjet/fastjet-3.0.1.ebuild,v 1.1 2012/01/08 01:32:14 bicatali Exp $
+
+EAPI=4
+inherit autotools-utils fortran-2 flag-o-matic
+
+DESCRIPTION="Fast implementation of several recombination jet algorithms"
+HOMEPAGE="http://www.fastjet.fr/"
+SRC_URI="${HOMEPAGE}/repo/${P}.tar.gz"
+
+LICENSE="GPL-2 QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgal doc examples +plugins static-libs"
+
+RDEPEND="cgal? ( sci-mathematics/cgal )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ plugins? ( virtual/fortran )"
+
+src_configure() {
+ use cgal && has_version sci-mathematics/cgal[gmp] && append-ldflags -lgmp
+ myeconfargs+=(
+ $(use_enable cgal)
+ $(use_enable plugins allplugins)
+ $(use_enable plugins allcxxplugins)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ use doc && doxygen Doxyfile
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dohtml html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ find example \
+ -name Makefile -or Makefile.in -or Makefile.am -delete
+ doins -r example/*
+ fi
+}
diff --git a/sci-physics/fastjet/metadata.xml b/sci-physics/fastjet/metadata.xml
new file mode 100644
index 000000000000..63f715fe8303
--- /dev/null
+++ b/sci-physics/fastjet/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-physics</herd>
+<longdescription lang="en">
+ The FastJet package provides a fast implementation of the
+ longitudinally invariant kt longitudinally invariant inclusive
+ Cambridge/Aachen and anti-kt jet finders and a uniform interface
+ to external jet finders (notably SISCone) via a plugin
+ mechanism. It also includes tools for calculating jet areas and
+ performing background (pileup/UE) subtraction.
+ </longdescription>
+ <use>
+ <flag name='plugins'> Build all standard and C++ plugins </flag>
+ <flag name='cgal'> Use <pkg>sci-mathematics/cgal</pkg> instead of
+ bundled algorithms</flag>
+ </use>
+</pkgmetadata>
+