summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Vermeulen <swift@gentoo.org>2011-08-28 21:13:13 +0000
committerSven Vermeulen <swift@gentoo.org>2011-08-28 21:13:13 +0000
commit9de82426bf829b103b839447bfc35ddbda198975 (patch)
tree8ed61c061b2c3fd20eab63b5391adfe9ff7bb54f /sec-policy/selinux-entropyd/selinux-entropyd-2.20110726.ebuild
parentNew SELinux module packages (entropyd, ftp, ipsec, jabber, snmp) which need t... (diff)
downloadgentoo-2-9de82426bf829b103b839447bfc35ddbda198975.tar.gz
gentoo-2-9de82426bf829b103b839447bfc35ddbda198975.tar.bz2
gentoo-2-9de82426bf829b103b839447bfc35ddbda198975.zip
Pushing out SELinux policy modules based on new 20110726 release (refpolicy)
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sec-policy/selinux-entropyd/selinux-entropyd-2.20110726.ebuild')
-rw-r--r--sec-policy/selinux-entropyd/selinux-entropyd-2.20110726.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sec-policy/selinux-entropyd/selinux-entropyd-2.20110726.ebuild b/sec-policy/selinux-entropyd/selinux-entropyd-2.20110726.ebuild
new file mode 100644
index 000000000000..779448dc3a12
--- /dev/null
+++ b/sec-policy/selinux-entropyd/selinux-entropyd-2.20110726.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sec-policy/selinux-entropyd/selinux-entropyd-2.20110726.ebuild,v 1.1 2011/08/28 21:12:38 swift Exp $
+EAPI="4"
+
+IUSE=""
+MODS="entropyd"
+
+inherit selinux-policy-2
+
+DESCRIPTION="SELinux policy for various entropy daemons (audio-entropyd, haveged, ...)"
+
+KEYWORDS="~amd64 ~x86"
+RDEPEND="!<sec-policy/selinux-audio-entropyd-2.20110726
+ >=sys-apps/policycoreutils-1.30.30
+ >=sec-policy/selinux-base-policy-${PV}"
+
+pkg_postinst() {
+ einfo "The SELinux entropyd module is the replacement of audioentropyd and"
+ einfo "is made more generic for all-purpose entropy daemons, including"
+ einfo "audioentropyd and haveged."
+ einfo
+ einfo "If you are upgrading from an audioentropyd module, the installation"
+ einfo "of the new policy module might fail due to collisions. You will need"
+ einfo "to remove the current audioentropyd module first:"
+ einfo " # semodule -r audioentropy"
+ einfo
+ einfo "Then, you can install the new policy:"
+ einfo " # semodule -i /usr/share/selinux/<type>/entropyd.pp"
+ echo
+ einfo "Portage will automatically try to load the entropyd module now."
+ selinux-policy-2_pkg_postinst
+}