summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-27 00:52:33 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-27 00:52:33 +0000
commit4cadc5f7b040152373f2875268565cdd5ad64792 (patch)
tree2e1082ddcb76cc54fd99880dfbe4a1b9ba769aff /sys-apps/dmidecode
parentmedia-libs/gegl: ffmpeg fixes (bug #459312) (diff)
downloadgentoo-2-4cadc5f7b040152373f2875268565cdd5ad64792.tar.gz
gentoo-2-4cadc5f7b040152373f2875268565cdd5ad64792.tar.bz2
gentoo-2-4cadc5f7b040152373f2875268565cdd5ad64792.zip
Version bump, update to EAPI 4.
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-apps/dmidecode')
-rw-r--r--sys-apps/dmidecode/ChangeLog7
-rw-r--r--sys-apps/dmidecode/dmidecode-2.12.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sys-apps/dmidecode/ChangeLog b/sys-apps/dmidecode/ChangeLog
index 8419a83a9b33..0278f4acd22c 100644
--- a/sys-apps/dmidecode/ChangeLog
+++ b/sys-apps/dmidecode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/dmidecode
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.43 2013/01/22 17:33:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/ChangeLog,v 1.44 2013/04/27 00:52:33 radhermit Exp $
+
+*dmidecode-2.12 (27 Apr 2013)
+
+ 27 Apr 2013; Tim Harder <radhermit@gentoo.org> +dmidecode-2.12.ebuild:
+ Version bump, update to EAPI 4.
22 Jan 2013; Agostino Sarubbo <ago@gentoo.org> dmidecode-2.11.ebuild:
Stable for x86, wrt bug #373237
diff --git a/sys-apps/dmidecode/dmidecode-2.12.ebuild b/sys-apps/dmidecode/dmidecode-2.12.ebuild
new file mode 100644
index 000000000000..480a6b2f0d7e
--- /dev/null
+++ b/sys-apps/dmidecode/dmidecode-2.12.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dmidecode/dmidecode-2.12.ebuild,v 1.1 2013/04/27 00:52:33 radhermit Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="DMI (Desktop Management Interface) table related utilities"
+HOMEPAGE="http://www.nongnu.org/dmidecode/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-solaris"
+IUSE="selinux"
+
+DEPEND="selinux? ( sec-policy/selinux-dmidecode )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i \
+ -e "/^prefix/s:/usr/local:${EPREFIX}/usr:" \
+ -e "/^docdir/s:dmidecode:${PF}:" \
+ -e '/^PROGRAMS !=/d' \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS} ${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)"
+}
+
+pkg_postinst() {
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ einfo "dmidecode needs root privileges to read /dev/xsvc"
+ einfo "To make dmidecode useful, either run as root, or chown and setuid the binary."
+ einfo "Note that /usr/sbin/ptrconf and /usr/sbin/ptrdiag give similar"
+ einfo "information without requiring root privileges."
+ fi
+}