summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-01-27 12:36:12 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-01-27 12:36:12 +0000
commita14163e73e59bf03b9fefd757955c3347beb9196 (patch)
treea9bc73b6e69ff569276c8358b59397d6e1f20d13 /sys-apps/file
parentRemove old. (diff)
downloadgentoo-2-a14163e73e59bf03b9fefd757955c3347beb9196.tar.gz
gentoo-2-a14163e73e59bf03b9fefd757955c3347beb9196.tar.bz2
gentoo-2-a14163e73e59bf03b9fefd757955c3347beb9196.zip
Removed vulnerable versions
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/ChangeLog7
-rw-r--r--sys-apps/file/file-5.17.ebuild95
-rw-r--r--sys-apps/file/file-5.19.ebuild105
-rw-r--r--sys-apps/file/file-5.20-r1.ebuild107
-rw-r--r--sys-apps/file/file-5.21.ebuild105
-rw-r--r--sys-apps/file/files/file-5.20-elf-note.patch37
6 files changed, 6 insertions, 450 deletions
diff --git a/sys-apps/file/ChangeLog b/sys-apps/file/ChangeLog
index 662467ba4ba4..6f7d4a9f612e 100644
--- a/sys-apps/file/ChangeLog
+++ b/sys-apps/file/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/file
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.307 2015/01/25 11:21:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/ChangeLog,v 1.308 2015/01/27 12:36:12 polynomial-c Exp $
+
+ 27 Jan 2015; Lars Wendler <polynomial-c@gentoo.org> -file-5.17.ebuild,
+ -file-5.19.ebuild, -file-5.20-r1.ebuild, -file-5.21.ebuild,
+ -files/file-5.20-elf-note.patch:
+ Removed vulnerable versions.
25 Jan 2015; Agostino Sarubbo <ago@gentoo.org> file-5.22.ebuild:
Stable for alpha, wrt bug #532768
diff --git a/sys-apps/file/file-5.17.ebuild b/sys-apps/file/file-5.17.ebuild
deleted file mode 100644
index 123ff92f0bf6..000000000000
--- a/sys-apps/file/file-5.17.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.17.ebuild,v 1.12 2014/07/06 23:25:06 kumba Exp $
-
-EAPI="4"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
-DISTUTILS_OPTIONAL=1
-
-inherit eutils distutils-r1 libtool toolchain-funcs
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/glensc/file.git"
- inherit autotools git-r3
-else
- SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
- ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="identify a file's format by scanning binary data for patterns"
-HOMEPAGE="http://www.darwinsys.com/file/"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="python static-libs zlib"
-
-DEPEND="python? ( ${PYTHON_DEPS} )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}
- python? ( !dev-python/python-magic )"
-
-src_prepare() {
- [[ ${PV} == "9999" ]] && eautoreconf
- elibtoolize
-
- # don't let python README kill main README #60043
- mv python/README{,.python}
-}
-
-wd() { echo "${WORKDIR}"/build-${CHOST}; }
-
-do_configure() {
- ECONF_SOURCE=${S}
-
- mkdir "$(wd)"
- pushd "$(wd)" >/dev/null
-
- econf "$@"
-
- popd >/dev/null
-}
-
-src_configure() {
- # when cross-compiling, we need to build up our own file
- # because people often don't keep matching host/target
- # file versions #362941
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- tc-export_build_env BUILD_C{C,XX}
- ac_cv_header_zlib_h=no \
- ac_cv_lib_z_gzopen=no \
- CHOST=${CBUILD} \
- CFLAGS=${BUILD_CFLAGS} \
- CXXFLAGS=${BUILD_CXXFLAGS} \
- CPPFLAGS=${BUILD_CPPFLAGS} \
- LDFLAGS="${BUILD_LDFLAGS} -static" \
- CC=${BUILD_CC} \
- CXX=${BUILD_CXX} \
- do_configure --disable-shared
- fi
-
- export ac_cv_header_zlib_h=$(usex zlib) ac_cv_lib_z_gzopen=$(usex zlib)
- do_configure $(use_enable static-libs static)
-}
-
-do_make() {
- emake -C "$(wd)" "$@"
-}
-
-src_compile() {
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- CHOST=${CBUILD} do_make -C src file
- PATH=$(CHOST=${CBUILD} wd)/src:${PATH}
- fi
- do_make
-
- use python && cd python && distutils-r1_src_compile
-}
-
-src_install() {
- do_make DESTDIR="${D}" install
- dodoc ChangeLog MAINT README
-
- use python && cd python && distutils-r1_src_install
- prune_libtool_files
-}
diff --git a/sys-apps/file/file-5.19.ebuild b/sys-apps/file/file-5.19.ebuild
deleted file mode 100644
index 76d3636c888d..000000000000
--- a/sys-apps/file/file-5.19.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.19.ebuild,v 1.10 2014/11/23 12:52:37 zlogene Exp $
-
-EAPI="4"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy2_0 )
-DISTUTILS_OPTIONAL=1
-
-inherit eutils distutils-r1 libtool toolchain-funcs multilib-minimal
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/glensc/file.git"
- inherit autotools git-r3
-else
- SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
- ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh ~sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="identify a file's format by scanning binary data for patterns"
-HOMEPAGE="http://www.darwinsys.com/file/"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="python static-libs zlib"
-
-DEPEND="python? ( ${PYTHON_DEPS} )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20131008-r21
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
-RDEPEND="${DEPEND}
- python? ( !dev-python/python-magic )"
-
-src_prepare() {
- [[ ${PV} == "9999" ]] && eautoreconf
- elibtoolize
-
- # don't let python README kill main README #60043
- mv python/README{,.python}
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- ac_cv_header_zlib_h=$(usex zlib) \
- ac_cv_lib_z_gzopen=$(usex zlib)
- econf \
- $(use_enable static-libs static)
-}
-
-src_configure() {
- # when cross-compiling, we need to build up our own file
- # because people often don't keep matching host/target
- # file versions #362941
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- mkdir -p "${WORKDIR}"/build
- cd "${WORKDIR}"/build
- tc-export_build_env BUILD_C{C,XX}
- ECONF_SOURCE=${S} \
- ac_cv_header_zlib_h=no \
- ac_cv_lib_z_gzopen=no \
- CHOST=${CBUILD} \
- CFLAGS=${BUILD_CFLAGS} \
- CXXFLAGS=${BUILD_CXXFLAGS} \
- CPPFLAGS=${BUILD_CPPFLAGS} \
- LDFLAGS="${BUILD_LDFLAGS} -static" \
- CC=${BUILD_CC} \
- CXX=${BUILD_CXX} \
- econf --disable-shared
- fi
-
- multilib-minimal_src_configure
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi ; then
- emake
- else
- emake -C src libmagic.la
- fi
-}
-
-src_compile() {
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- emake -C "${WORKDIR}"/build/src file
- PATH="${WORKDIR}/build/src:${PATH}"
- fi
- multilib-minimal_src_compile
-
- use python && cd python && distutils-r1_src_compile
-}
-
-multilib_src_install() {
- if multilib_is_native_abi ; then
- default
- else
- emake -C src install-{includeHEADERS,libLTLIBRARIES} DESTDIR="${D}"
- fi
-}
-
-multilib_src_install_all() {
- dodoc ChangeLog MAINT README
-
- use python && cd python && distutils-r1_src_install
- prune_libtool_files
-}
diff --git a/sys-apps/file/file-5.20-r1.ebuild b/sys-apps/file/file-5.20-r1.ebuild
deleted file mode 100644
index 71809400950f..000000000000
--- a/sys-apps/file/file-5.20-r1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.20-r1.ebuild,v 1.1 2014/10/24 17:24:09 vapier Exp $
-
-EAPI="4"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy2_0 )
-DISTUTILS_OPTIONAL=1
-
-inherit eutils distutils-r1 libtool toolchain-funcs multilib-minimal
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/glensc/file.git"
- inherit autotools git-r3
-else
- SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
- ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="identify a file's format by scanning binary data for patterns"
-HOMEPAGE="http://www.darwinsys.com/file/"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="python static-libs zlib"
-
-DEPEND="python? ( ${PYTHON_DEPS} )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20131008-r21
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
-RDEPEND="${DEPEND}
- python? ( !dev-python/python-magic )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-elf-note.patch #526544
-
- [[ ${PV} == "9999" ]] && eautoreconf
- elibtoolize
-
- # don't let python README kill main README #60043
- mv python/README{,.python}
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- ac_cv_header_zlib_h=$(usex zlib) \
- ac_cv_lib_z_gzopen=$(usex zlib)
- econf \
- $(use_enable static-libs static)
-}
-
-src_configure() {
- # when cross-compiling, we need to build up our own file
- # because people often don't keep matching host/target
- # file versions #362941
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- mkdir -p "${WORKDIR}"/build
- cd "${WORKDIR}"/build
- tc-export_build_env BUILD_C{C,XX}
- ECONF_SOURCE=${S} \
- ac_cv_header_zlib_h=no \
- ac_cv_lib_z_gzopen=no \
- CHOST=${CBUILD} \
- CFLAGS=${BUILD_CFLAGS} \
- CXXFLAGS=${BUILD_CXXFLAGS} \
- CPPFLAGS=${BUILD_CPPFLAGS} \
- LDFLAGS="${BUILD_LDFLAGS} -static" \
- CC=${BUILD_CC} \
- CXX=${BUILD_CXX} \
- econf --disable-shared
- fi
-
- multilib-minimal_src_configure
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi ; then
- emake
- else
- emake -C src libmagic.la
- fi
-}
-
-src_compile() {
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- emake -C "${WORKDIR}"/build/src file
- PATH="${WORKDIR}/build/src:${PATH}"
- fi
- multilib-minimal_src_compile
-
- use python && cd python && distutils-r1_src_compile
-}
-
-multilib_src_install() {
- if multilib_is_native_abi ; then
- default
- else
- emake -C src install-{includeHEADERS,libLTLIBRARIES} DESTDIR="${D}"
- fi
-}
-
-multilib_src_install_all() {
- dodoc ChangeLog MAINT README
-
- use python && cd python && distutils-r1_src_install
- prune_libtool_files
-}
diff --git a/sys-apps/file/file-5.21.ebuild b/sys-apps/file/file-5.21.ebuild
deleted file mode 100644
index ae18c0bd1465..000000000000
--- a/sys-apps/file/file-5.21.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-5.21.ebuild,v 1.10 2014/12/26 09:18:18 ago Exp $
-
-EAPI="4"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} pypy2_0 )
-DISTUTILS_OPTIONAL=1
-
-inherit eutils distutils-r1 libtool toolchain-funcs multilib-minimal
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://github.com/glensc/file.git"
- inherit autotools git-r3
-else
- SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
- ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
- KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="identify a file's format by scanning binary data for patterns"
-HOMEPAGE="http://www.darwinsys.com/file/"
-
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="python static-libs zlib"
-
-DEPEND="python? ( ${PYTHON_DEPS} )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20131008-r21
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
-RDEPEND="${DEPEND}
- python? ( !dev-python/python-magic )"
-
-src_prepare() {
- [[ ${PV} == "9999" ]] && eautoreconf
- elibtoolize
-
- # don't let python README kill main README #60043
- mv python/README{,.python}
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- ac_cv_header_zlib_h=$(usex zlib) \
- ac_cv_lib_z_gzopen=$(usex zlib)
- econf \
- $(use_enable static-libs static)
-}
-
-src_configure() {
- # when cross-compiling, we need to build up our own file
- # because people often don't keep matching host/target
- # file versions #362941
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- mkdir -p "${WORKDIR}"/build
- cd "${WORKDIR}"/build
- tc-export_build_env BUILD_C{C,XX}
- ECONF_SOURCE=${S} \
- ac_cv_header_zlib_h=no \
- ac_cv_lib_z_gzopen=no \
- CHOST=${CBUILD} \
- CFLAGS=${BUILD_CFLAGS} \
- CXXFLAGS=${BUILD_CXXFLAGS} \
- CPPFLAGS=${BUILD_CPPFLAGS} \
- LDFLAGS="${BUILD_LDFLAGS} -static" \
- CC=${BUILD_CC} \
- CXX=${BUILD_CXX} \
- econf --disable-shared
- fi
-
- multilib-minimal_src_configure
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi ; then
- emake
- else
- emake -C src libmagic.la
- fi
-}
-
-src_compile() {
- if tc-is-cross-compiler && ! ROOT=/ has_version ~${CATEGORY}/${P} ; then
- emake -C "${WORKDIR}"/build/src file
- PATH="${WORKDIR}/build/src:${PATH}"
- fi
- multilib-minimal_src_compile
-
- use python && cd python && distutils-r1_src_compile
-}
-
-multilib_src_install() {
- if multilib_is_native_abi ; then
- default
- else
- emake -C src install-{includeHEADERS,libLTLIBRARIES} DESTDIR="${D}"
- fi
-}
-
-multilib_src_install_all() {
- dodoc ChangeLog MAINT README
-
- use python && cd python && distutils-r1_src_install
- prune_libtool_files
-}
diff --git a/sys-apps/file/files/file-5.20-elf-note.patch b/sys-apps/file/files/file-5.20-elf-note.patch
deleted file mode 100644
index 994dd73943d5..000000000000
--- a/sys-apps/file/files/file-5.20-elf-note.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-https://bugs.gentoo.org/526544
-
-From 39c7ac1106be844a5296d3eb5971946cc09ffda0 Mon Sep 17 00:00:00 2001
-From: Christos Zoulas <christos@zoulas.com>
-Date: Fri, 17 Oct 2014 15:49:00 +0000
-Subject: [PATCH] Fix note bounds reading, Francisco Alonso / Red Hat
-
----
- ChangeLog | 4 ++++
- src/readelf.c | 9 ++++++++-
- 2 files changed, 12 insertions(+), 1 deletion(-)
-
-2014-10-17 11:48 Christos Zoulas <christos@zoulas.com>
-
- * fix bounds in note reading (Francisco Alonso / Red Hat)
-
-diff --git a/src/readelf.c b/src/readelf.c
-index 08f81f5..9ebdebd 100644
---- a/src/readelf.c
-+++ b/src/readelf.c
-@@ -477,6 +477,13 @@ donote(struct magic_set *ms, void *vbuf, size_t offset, size_t size,
- uint32_t namesz, descsz;
- unsigned char *nbuf = CAST(unsigned char *, vbuf);
-
-+ if (xnh_sizeof + offset > size) {
-+ /*
-+ * We're out of note headers.
-+ */
-+ return xnh_sizeof + offset;
-+ }
-+
- (void)memcpy(xnh_addr, &nbuf[offset], xnh_sizeof);
- offset += xnh_sizeof;
-
---
-2.1.2
-