summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 19:03:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 19:03:02 +0000
commit9e03b1c62a435c9bcbcc3ff76d652fe963a306a0 (patch)
treea7ce5ac75234e84c8fe06a64ee53e023d02f55c6 /sys-apps/findutils
parentremove 2.1_pre8 (diff)
downloadgentoo-2-9e03b1c62a435c9bcbcc3ff76d652fe963a306a0.tar.gz
gentoo-2-9e03b1c62a435c9bcbcc3ff76d652fe963a306a0.tar.bz2
gentoo-2-9e03b1c62a435c9bcbcc3ff76d652fe963a306a0.zip
Add workaround for the glibc 'fix' that breaks Gentoo/FreeBSD, keyword also 4.3 version. Add workaround for NetBSD systems. Bug #123253.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/ChangeLog8
-rw-r--r--sys-apps/findutils/files/findutils-4.3.0-nbsd.patch21
-rw-r--r--sys-apps/findutils/files/gnulib-openat-mode_t.patch21
-rw-r--r--sys-apps/findutils/findutils-4.2.27.ebuild13
-rw-r--r--sys-apps/findutils/findutils-4.3.0.ebuild24
5 files changed, 75 insertions, 12 deletions
diff --git a/sys-apps/findutils/ChangeLog b/sys-apps/findutils/ChangeLog
index 69e22d8ac0ba..cdc418fec248 100644
--- a/sys-apps/findutils/ChangeLog
+++ b/sys-apps/findutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/findutils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.69 2006/04/07 19:58:38 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/ChangeLog,v 1.70 2006/04/18 19:03:02 flameeyes Exp $
+
+ 18 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/findutils-4.3.0-nbsd.patch, +files/gnulib-openat-mode_t.patch,
+ findutils-4.2.27.ebuild, findutils-4.3.0.ebuild:
+ Add workaround for the glibc 'fix' that breaks Gentoo/FreeBSD, keyword also
+ 4.3 version. Add workaround for NetBSD systems. Bug #123253.
07 Apr 2006; Bryan Østergaard <kloeri@gentoo.org metadata.xml:
Remove ciaranm from metadata.xml.
diff --git a/sys-apps/findutils/files/findutils-4.3.0-nbsd.patch b/sys-apps/findutils/files/findutils-4.3.0-nbsd.patch
new file mode 100644
index 000000000000..58f5b1b01660
--- /dev/null
+++ b/sys-apps/findutils/files/findutils-4.3.0-nbsd.patch
@@ -0,0 +1,21 @@
+--- findutils-4.3.0.orig/gnulib/lib/mountlist.c 2005-12-12 06:23:41.000000000 -0200
++++ findutils-4.3.0/gnulib/lib/mountlist.c 2006-02-18 07:26:20.000000000 -0200
+@@ -257,6 +257,7 @@
+ # endif /* ! HAVE_F_FSTYPENAME_IN_STATFS */
+
+ /* __NetBSD__ || BSD_NET2 || __OpenBSD__ */
++#define statfs statvfs
+ static char *
+ fsp_to_string (const struct statfs *fsp)
+ {
+--- findutils-4.3.0.orig/gnulib/m4/fstypename.m4 2005-12-12 06:23:42.000000000 -0200
++++ findutils-4.3.0/gnulib/m4/fstypename.m4 2006-02-18 07:07:28.000000000 -0200
+@@ -22,7 +22,7 @@
+ #include <sys/types.h>
+ #include <sys/mount.h>
+ ],
+- [struct statfs s; int i = sizeof s.f_fstypename;],
++ [struct statvfs s; int i = sizeof s.f_fstypename;],
+ fu_cv_sys_f_fstypename_in_statfs=yes,
+ fu_cv_sys_f_fstypename_in_statfs=no
+ )
diff --git a/sys-apps/findutils/files/gnulib-openat-mode_t.patch b/sys-apps/findutils/files/gnulib-openat-mode_t.patch
new file mode 100644
index 000000000000..acd285f0ce22
--- /dev/null
+++ b/sys-apps/findutils/files/gnulib-openat-mode_t.patch
@@ -0,0 +1,21 @@
+Index: sources/gnulib/lib/openat.c
+===================================================================
+--- sources.orig/gnulib/lib/openat.c
++++ sources/gnulib/lib/openat.c
+@@ -55,9 +55,13 @@ rpl_openat (int fd, char const *filename
+ va_list arg;
+ va_start (arg, flags);
+
+- /* Assume that mode_t is passed compatibly with mode_t's type
+- after argument promotion. */
+- mode = va_arg (arg, mode_t);
++ /* If mode_t is narrower than int, use the promoted type (int),
++ not mode_t. Use sizeof to guess whether mode_t is nerrower;
++ we don't know of any practical counterexamples. */
++ if (sizeof (mode_t) < sizeof (int))
++ mode = va_arg (arg, int);
++ else
++ mode = va_arg (arg, mode_t);
+
+ va_end (arg);
+ }
diff --git a/sys-apps/findutils/findutils-4.2.27.ebuild b/sys-apps/findutils/findutils-4.2.27.ebuild
index d94684f8c6c5..aafe97ca3d21 100644
--- a/sys-apps/findutils/findutils-4.2.27.ebuild
+++ b/sys-apps/findutils/findutils-4.2.27.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.2.27.ebuild,v 1.3 2006/04/11 04:45:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.2.27.ebuild,v 1.4 2006/04/18 19:03:02 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -31,16 +31,21 @@ src_unpack() {
# Patches for selinux
use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
- # Use the system-provided regex.h, bug #114747
- echo "#include_next <regex.h>" > gnulib/lib/regex.h
+ if [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]]; then
+ # Use the system-provided regex.h, bug #114747
+ echo "#include_next <regex.h>" > gnulib/lib/regex.h
+ fi
}
src_compile() {
use static && append-ldflags -static
- local myconf="--without-included-regex"
+ local myconf
use userland_GNU || myconf=" --program-prefix=g"
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] && \
+ myconf="${myconf} --without-included-regex"
+
econf $(use_enable nls) ${myconf} || die "configure failed"
emake libexecdir=/usr/lib/find AR="$(tc-getAR)" || die "make failed"
}
diff --git a/sys-apps/findutils/findutils-4.3.0.ebuild b/sys-apps/findutils/findutils-4.3.0.ebuild
index c7ff6b67faf4..4aabf4685269 100644
--- a/sys-apps/findutils/findutils-4.3.0.ebuild
+++ b/sys-apps/findutils/findutils-4.3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.0.ebuild,v 1.4 2005/12/24 04:53:22 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/findutils/findutils-4.3.0.ebuild,v 1.5 2006/04/18 19:03:02 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -13,10 +13,11 @@ SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="nls build selinux static"
-RDEPEND="selinux? ( sys-libs/libselinux )"
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
@@ -31,16 +32,25 @@ src_unpack() {
# Patches for selinux
use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
- # Use the system-provided regex.h, bug #114747
- echo "#include_next <regex.h>" > gnulib/lib/regex.h
+ if [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]]; then
+ # Use the system-provided regex.h, bug #114747
+ echo "#include_next <regex.h>" > gnulib/lib/regex.h
+ fi
+
+ [[ ${ELIBC} == "NetBSD" ]] && epatch "${FILESDIR}/${P}-nbsd.patch"
+
+ epatch "${FILESDIR}/gnulib-openat-mode_t.patch"
}
src_compile() {
use static && append-ldflags -static
- local myconf="--without-included-regex"
+ local myconf
use userland_GNU || myconf=" --program-prefix=g"
+ [[ ${ELIBC} == "glibc" || ${ELIBC} == "uclibc" ]] && \
+ myconf="${myconf} --without-included-regex"
+
econf $(use_enable nls) ${myconf} || die "configure failed"
emake libexecdir=/usr/lib/find AR="$(tc-getAR)" || die "make failed"
}