summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-26 14:30:15 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-26 14:30:15 +0000
commit7d160f61ee097a47eed67c346f9cbb6b4c938790 (patch)
treeb186e2c75ab00e33e789eaea489b329e7dd7689a /sys-apps/gawk
parenttweak gawk comment (diff)
downloadgentoo-2-7d160f61ee097a47eed67c346f9cbb6b4c938790.tar.gz
gentoo-2-7d160f61ee097a47eed67c346f9cbb6b4c938790.tar.bz2
gentoo-2-7d160f61ee097a47eed67c346f9cbb6b4c938790.zip
get filefuncs module into 3.1.1
Diffstat (limited to 'sys-apps/gawk')
-rw-r--r--sys-apps/gawk/ChangeLog21
-rw-r--r--sys-apps/gawk/files/digest-gawk-3.1.1-r21
-rw-r--r--sys-apps/gawk/gawk-3.1.1-r2.ebuild106
-rw-r--r--sys-apps/gawk/gawk-3.1.2-r2.ebuild4
4 files changed, 129 insertions, 3 deletions
diff --git a/sys-apps/gawk/ChangeLog b/sys-apps/gawk/ChangeLog
index e4f4535181f6..2702636e61fa 100644
--- a/sys-apps/gawk/ChangeLog
+++ b/sys-apps/gawk/ChangeLog
@@ -1,6 +1,25 @@
# ChangeLog for sys-apps/gawk
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.16 2003/03/25 18:06:59 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/ChangeLog,v 1.17 2003/03/26 14:30:15 azarah Exp $
+
+*gawk-3.1.1-r2 (26 Mar 2003)
+
+ 26 Mar 2003; Martin Schlemmer <azarah@gentoo.org> gawk-3.1.2-r1.ebuild :
+ For some reason gawk-3.1.2 is more pain than worth. Seems this release
+ also borks the ability to specify input files as arguments:
+
+ # gawk '/devfs/ { print }' /proc/filesystems
+ #
+
+ should have been the same as:
+
+ # cat /proc/filesystems | gawk '/devfs/ { print }'
+ nodev devfs
+ nodev usbdevfs
+ #
+
+ Thus all this release does, is get the filefuncs module into 3.1.1 as well,
+ so that we can totally mask gawk-3.1.2.
*gawk-3.1.2-r2 (25 Mar 2003)
diff --git a/sys-apps/gawk/files/digest-gawk-3.1.1-r2 b/sys-apps/gawk/files/digest-gawk-3.1.1-r2
new file mode 100644
index 000000000000..d0f65dc6c181
--- /dev/null
+++ b/sys-apps/gawk/files/digest-gawk-3.1.1-r2
@@ -0,0 +1 @@
+MD5 47e3754195bf32c8b78ad632bab903cd gawk-3.1.1.tar.gz 1875134
diff --git a/sys-apps/gawk/gawk-3.1.1-r2.ebuild b/sys-apps/gawk/gawk-3.1.1-r2.ebuild
new file mode 100644
index 000000000000..125547101b86
--- /dev/null
+++ b/sys-apps/gawk/gawk-3.1.1-r2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.1-r2.ebuild,v 1.1 2003/03/26 14:30:15 azarah Exp $
+
+IUSE="nls build"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="GNU awk pattern-matching language"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gawk/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gawk/gawk.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Copy filefuncs module's source over ...
+ cp -a ${FILESDIR}/filefuncs ${WORKDIR}/ || die
+}
+
+src_compile() {
+ local myconf=""
+ use nls || myconf="${myconf} --disable-nls"
+
+ einfo "Building gawk ..."
+ ./configure --prefix=/usr \
+ --libexecdir=/usr/lib/awk \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+
+ einfo "Building filefuncs module ..."
+ cd ${WORKDIR}/filefuncs
+ make AWKINCDIR=${S} || die
+}
+
+src_install() {
+ einfo "Installing gawk ..."
+ make prefix=${D}/usr \
+ bindir=${D}/bin \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ libexecdir=${D}/usr/lib/awk \
+ install || die
+
+ einfo "Installing filefuncs module ..."
+ cd ${WORKDIR}/filefuncs
+ make DESTDIR=${D} \
+ AWKINCDIR=${S} \
+ install || die
+
+ # In some rare cases, gawk gets installed as gawk- and not gawk-${PV} ..
+ if [ -f ${D}/bin/gawk -a ! -f ${D}/bin/gawk-${PV} ]
+ then
+ mv -f ${D}/bin/gawk ${D}/bin/gawk-${PV}
+ elif [ -f ${D}/bin/gawk- -a ! -f ${D}/bin/gawk-${PV} ]
+ then
+ mv -f ${D}/bin/gawk ${D}/bin/gawk-${PV}
+ fi
+
+ rm -f ${D}/bin/{awk,gawk}
+ dosym gawk-${PV} /bin/awk
+ dosym gawk-${PV} /bin/gawk
+ #compat symlink
+ dodir /usr/bin
+ dosym ../../bin/gawk-${PV} /usr/bin/awk
+ dosym ../../bin/gawk-${PV} /usr/bin/gawk
+
+ # Install headers
+ insinto /usr/include/awk
+ for x in ${S}/*.h
+ do
+ # We do not want 'acconfig.h' in there ...
+ if [ -f "${x}" -a "${x/acconfig\.h/}" = "${x}" ]
+ then
+ doins ${x}
+ fi
+ done
+
+ if [ -z "`use build`" ]
+ then
+ cd ${S}
+ dosym gawk.1.gz /usr/share/man/man1/awk.1.gz
+ dodoc AUTHORS ChangeLog COPYING FUTURES
+ dodoc LIMITATIONS NEWS PROBLEMS POSIX.STD README
+ docinto README_d
+ dodoc README_d/*
+ docinto awklib
+ dodoc awklib/ChangeLog
+ docinto pc
+ dodoc pc/ChangeLog
+ docinto posix
+ dodoc posix/ChangeLog
+ else
+ rm -rf ${D}/usr/share
+ fi
+}
+
diff --git a/sys-apps/gawk/gawk-3.1.2-r2.ebuild b/sys-apps/gawk/gawk-3.1.2-r2.ebuild
index 2e51a30823f7..fc8fcd346445 100644
--- a/sys-apps/gawk/gawk-3.1.2-r2.ebuild
+++ b/sys-apps/gawk/gawk-3.1.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.2-r2.ebuild,v 1.1 2003/03/25 18:06:59 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.2-r2.ebuild,v 1.2 2003/03/26 14:30:15 azarah Exp $
IUSE="nls build"
@@ -79,7 +79,7 @@ src_install() {
for x in ${S}/*.h
do
# We do not want 'acconfig.h' in there ...
- if [ -f "${x}" -a "${x}" != "acconfig.h" ]
+ if [ -f "${x}" -a "${x/acconfig\.h/}" = "${x}" ]
then
doins ${x}
fi