summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-10 17:20:59 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-10 17:20:59 +0000
commit8ccefffe6f57c9fbe828b9bd9792dd8d417659fb (patch)
tree33709693310a447b7f4179ef996cb4d13c54d290 /sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild
parentapp-arch/p7zip: Add support for x32, #506602, patch by Luke-Jr (diff)
downloadgentoo-2-8ccefffe6f57c9fbe828b9bd9792dd8d417659fb.tar.gz
gentoo-2-8ccefffe6f57c9fbe828b9bd9792dd8d417659fb.tar.bz2
gentoo-2-8ccefffe6f57c9fbe828b9bd9792dd8d417659fb.zip
sys-apps/gentoo-functions: Respect CC
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild')
-rw-r--r--sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild b/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild
index 4c8a4add45a3..2ef48f77e9ab 100644
--- a/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild
+++ b/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild
@@ -1,17 +1,19 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild,v 1.1 2014/05/08 06:28:20 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/gentoo-functions/gentoo-functions-0.4.ebuild,v 1.2 2014/05/10 17:20:59 jlec Exp $
EAPI=5
if [[ ${PV} = 9999* ]]; then
- inherit git-r3
+ vcs=git-r3
EGIT_REPO_URI="git://github.com/gentoo/${PN}.git"
else
SRC_URI="http://dev.gentoo.org/~williamh/dist/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
fi
+inherit ${vcs} toolchain-funcs
+
DESCRIPTION="base functions required by all gentoo systems"
HOMEPAGE="http://www.gentoo.org"
@@ -19,5 +21,6 @@ LICENSE="GPL-2"
SLOT="0"
IUSE=""
-DEPEND=""
-RDEPEND=""
+src_prepare() {
+ tc-export CC
+}