summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-12-31 23:47:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-12-31 23:47:55 +0000
commit420ef5ef2ea4a3f31ca150bd4e690098c00767c8 (patch)
tree12f620ab81157bbf710054146dbbcb982e6ef60f /sys-apps/grep
parentdrip, for video conversion to divx (diff)
downloadgentoo-2-420ef5ef2ea4a3f31ca150bd4e690098c00767c8.tar.gz
gentoo-2-420ef5ef2ea4a3f31ca150bd4e690098c00767c8.tar.bz2
gentoo-2-420ef5ef2ea4a3f31ca150bd4e690098c00767c8.zip
header and form updates
Diffstat (limited to 'sys-apps/grep')
-rw-r--r--sys-apps/grep/grep-2.4.2-r5.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/sys-apps/grep/grep-2.4.2-r5.ebuild b/sys-apps/grep/grep-2.4.2-r5.ebuild
index 178df754ca4f..14d9063ae311 100644
--- a/sys-apps/grep/grep-2.4.2-r5.ebuild
+++ b/sys-apps/grep/grep-2.4.2-r5.ebuild
@@ -1,26 +1,34 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.4.2-r5.ebuild,v 1.1 2001/12/17 21:32:00 azarah Exp $
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/grep/grep-2.4.2-r5.ebuild,v 1.2 2001/12/31 23:47:55 azarah Exp $
S=${WORKDIR}/${P}
DESCRIPTION="GNU regular expression matcher"
SRC_URI="ftp://prep.ai.mit.edu/gnu/grep/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/grep/grep.html"
+
DEPEND="virtual/glibc nls? ( sys-devel/gettext )"
RDEPEND="virtual/glibc"
src_compile() {
local myconf
[ -z "`use nls`" ] && myconf="--disable-nls"
- ./configure --prefix=/usr --bindir=/bin --mandir=/usr/share/man \
- --infodir=/usr/share/info --host=${CHOST} ${myconf} || die
+ ./configure --prefix=/usr \
+ --bindir=/bin \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
emake || die
}
src_install() {
- make prefix=${D}/usr bindir=${D}/bin mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info install || die
+ make prefix=${D}/usr \
+ bindir=${D}/bin \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
if [ -z "`use build`" ]
then
dodoc AUTHORS COPYING ChangeLog NEWS README THANKS TODO