summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-02-08 18:52:01 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-02-08 18:52:01 +0000
commit87565d8ecfe6a0d07715861975290abf4966f6b0 (patch)
tree921216399bfdc8c6ff64bcdaa74898192056e485 /sys-apps/hwsetup/hwsetup-1.2.ebuild
parentRemove old. (diff)
downloadgentoo-2-87565d8ecfe6a0d07715861975290abf4966f6b0.tar.gz
gentoo-2-87565d8ecfe6a0d07715861975290abf4966f6b0.tar.bz2
gentoo-2-87565d8ecfe6a0d07715861975290abf4966f6b0.zip
Added USE=livecd to skip the message displayed by hwsetup, since it isn't necessary on a LiveCD build.
(Portage version: 2.1.4)
Diffstat (limited to 'sys-apps/hwsetup/hwsetup-1.2.ebuild')
-rw-r--r--sys-apps/hwsetup/hwsetup-1.2.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/sys-apps/hwsetup/hwsetup-1.2.ebuild b/sys-apps/hwsetup/hwsetup-1.2.ebuild
index 71e5a24d2950..ba944e056a2d 100644
--- a/sys-apps/hwsetup/hwsetup-1.2.ebuild
+++ b/sys-apps/hwsetup/hwsetup-1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2.ebuild,v 1.4 2007/08/14 21:19:53 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/hwsetup-1.2.ebuild,v 1.5 2008/02/08 18:52:01 wolf31o2 Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -13,7 +13,7 @@ SRC_URI="http://debian-knoppix.alioth.debian.org/sources/${PN}_${MY_PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ia64 -mips ppc ppc64 sparc x86"
-IUSE="zlib"
+IUSE="livecd zlib"
DEPEND="sys-libs/libkudzu
zlib? ( sys-libs/zlib )
@@ -45,8 +45,11 @@ src_install() {
}
pkg_postinst() {
- ewarn "This package is intended for usage on the Gentoo release media. If"
- ewarn "you are not building a CD, remove this package. It will not work"
- ewarn "properly on a running system, as Gentoo does not use any of the"
- ewarn "Knoppix-style detection except for CD builds."
+ if ! use livecd
+ then
+ ewarn "This package is intended for usage on the Gentoo release media. If"
+ ewarn "you are not building a CD, remove this package. It will not work"
+ ewarn "properly on a running system, as Gentoo does not use any of the"
+ ewarn "Knoppix-style detection except for CD builds."
+ fi
}