summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-07-25 19:16:07 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-07-25 19:16:07 +0000
commit2804414b96cac9eaa586000f9927a5c1411483a0 (patch)
tree5928af79e781ff74bd08feb3e14764baba62962f /sys-apps/hwsetup
parentDon't worry, be happy, unmask ALSA 1.0.12_rc1 as it fixes a few issues. (diff)
downloadgentoo-2-2804414b96cac9eaa586000f9927a5c1411483a0.tar.gz
gentoo-2-2804414b96cac9eaa586000f9927a5c1411483a0.tar.bz2
gentoo-2-2804414b96cac9eaa586000f9927a5c1411483a0.zip
Make the Gentoo patch work correctly with modular X, now that it is all stable.
(Portage version: 2.1.1_pre3-r4)
Diffstat (limited to 'sys-apps/hwsetup')
-rw-r--r--sys-apps/hwsetup/ChangeLog6
-rw-r--r--sys-apps/hwsetup/files/digest-hwsetup-1.12
-rw-r--r--sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch11
3 files changed, 17 insertions, 2 deletions
diff --git a/sys-apps/hwsetup/ChangeLog b/sys-apps/hwsetup/ChangeLog
index 6841b443f113..fbab96804582 100644
--- a/sys-apps/hwsetup/ChangeLog
+++ b/sys-apps/hwsetup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-apps/hwsetup
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.42 2006/06/22 19:06:43 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwsetup/ChangeLog,v 1.43 2006/07/25 19:16:07 wolf31o2 Exp $
+
+ 25 Jul 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ files/hwsetup-1.1-gentoo.patch:
+ Make the Gentoo patch work correctly with modular X, now that it is all stable.
22 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org> hwsetup-1.1.ebuild:
Make RDEPEND use the DEPEND variable, instead of repeating its contents.
diff --git a/sys-apps/hwsetup/files/digest-hwsetup-1.1 b/sys-apps/hwsetup/files/digest-hwsetup-1.1
index 059534c1d49b..623696daacba 100644
--- a/sys-apps/hwsetup/files/digest-hwsetup-1.1
+++ b/sys-apps/hwsetup/files/digest-hwsetup-1.1
@@ -1 +1,3 @@
MD5 da9be279ef57f697436fe37fbaa93976 hwsetup_1.1-1.tar.gz 9062
+RMD160 e0728e9d79b83e815586c6af8e70baae0ac913c4 hwsetup_1.1-1.tar.gz 9062
+SHA256 86fa767b6ceb74ce71fc6895e9db43445058025e4c0d6834a2c60159e3ea1199 hwsetup_1.1-1.tar.gz 9062
diff --git a/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch b/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch
index a91246b093ca..cff145434b78 100644
--- a/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch
+++ b/sys-apps/hwsetup/files/hwsetup-1.1-gentoo.patch
@@ -13,7 +13,7 @@ diff -urN hwsetup-1.1.orig/hwsetup.c hwsetup-1.1/hwsetup.c
-#define XPATH "/usr/X11R6/bin/"
-#define XMODPATH "/usr/X11R6/lib/modules/drivers/"
+#define XPATH "/usr/bin/"
-+#define XMODPATH "/usr/lib/modules/drivers/"
++#define XMODPATH "/usr/lib/xorg/modules/drivers/"
#define VERBOSE_PRINT 1
-#define VERBOSE_PROMPT 2
@@ -43,6 +43,15 @@ diff -urN hwsetup-1.1.orig/hwsetup.c hwsetup-1.1/hwsetup.c
if(!strncasecmp(d->driver,"Card:",5)) /* RedHat Cards-DB */
{ /* Kudzu "Cards" format */
FILE *cardsdb;
+@@ -255,7 +256,7 @@
+ char xmodule[32];
+ char fullpath[128];
+ sscanf(&buffer[7],"%31s",xmodule);
+- sprintf(fullpath,XMODPATH"%.31s_drv.o",xmodule);
++ sprintf(fullpath,XMODPATH"%.31s_drv.so",xmodule);
+ if(exists(fullpath))
+ {
+ strncpy(xi.xmodule,xmodule,sizeof(xi.xmodule));
@@ -279,9 +280,9 @@
if(*xfree3server&&!*xi.xmodule)
strncpy(xi.xserver,xfree3server,sizeof(xi.xserver));