summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-01-01 21:58:18 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-01-01 21:58:18 +0000
commit5021ce8d4327122d3864ae4807e91afedf9b9937 (patch)
treee4e01eb22d42878b3d5fa3c5c41f2f482b83ef3b /sys-apps/star
parentdoins externalized (diff)
downloadgentoo-2-5021ce8d4327122d3864ae4807e91afedf9b9937.tar.gz
gentoo-2-5021ce8d4327122d3864ae4807e91afedf9b9937.tar.bz2
gentoo-2-5021ce8d4327122d3864ae4807e91afedf9b9937.zip
world's fastest tar, and enhanced mt and rmt tools
Diffstat (limited to 'sys-apps/star')
-rw-r--r--sys-apps/star/files/digest-star-1.3_alpha81
-rw-r--r--sys-apps/star/star-1.3_alpha8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/sys-apps/star/files/digest-star-1.3_alpha8 b/sys-apps/star/files/digest-star-1.3_alpha8
new file mode 100644
index 000000000000..1e961cb5c5e7
--- /dev/null
+++ b/sys-apps/star/files/digest-star-1.3_alpha8
@@ -0,0 +1 @@
+MD5 9284110e755eeac4e94a6eb73af41b6c star-1.3a8.tar.gz
diff --git a/sys-apps/star/star-1.3_alpha8.ebuild b/sys-apps/star/star-1.3_alpha8.ebuild
new file mode 100644
index 000000000000..3ed9ae4459dc
--- /dev/null
+++ b/sys-apps/star/star-1.3_alpha8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/star/star-1.3_alpha8.ebuild,v 1.1 2001/01/01 21:58:14 drobbins Exp $
+
+A=star-1.3a8.tar.gz
+S=${WORKDIR}/star-1.3
+
+DESCRIPTION="Includes star, an enhanced (world\'s fastest) tar, as well as enhanced mt/rmt"
+SRC_URI="ftp://ftp.fokus.gmd.de/pub/unix/star/alpha/${A}"
+HOMEPAGE="http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/star.html"
+DEPEND=">=sys-libs/glibc-2.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/DEFAULTS
+ cp Defaults.linux Defaults.linux.orig
+ sed -e 's:/opt/schily:/usr:g' -e 's:bin:root:g' Defaults.linux.orig > Defaults.linux
+}
+
+src_compile() {
+ cd ${S}
+ try ./Gmake.linux
+}
+
+src_install() {
+ cd ${S}
+ try make install INS_BASE=${D}/usr
+ insinto /etc/default
+ newins ${S}/rmt/rmt.dfl rmt
+ dodoc BUILD COPYING Changelog AN-1.* README README.* PORTING TODO
+ rm ${D}/usr/man/man1/match*
+ cd ${S}/usr/bin
+ rm smt ustar
+ ln -s star ustar
+ ln -s mt smt
+}
+
+