summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-30 06:40:14 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-30 06:40:14 +0000
commite541a923d0ba6b58601c669090593a8f303925c1 (patch)
treef4e671296f1f00ef66ed527b2a3947833e8231cd /sys-apps/usbutils/usbutils-0.71-r1.ebuild
parentStable on x86; bug #112840 (diff)
downloadgentoo-2-e541a923d0ba6b58601c669090593a8f303925c1.tar.gz
gentoo-2-e541a923d0ba6b58601c669090593a8f303925c1.tar.bz2
gentoo-2-e541a923d0ba6b58601c669090593a8f303925c1.zip
Add support for newer format types in usb ids file with patch from upstream cvs #111781.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-apps/usbutils/usbutils-0.71-r1.ebuild')
-rw-r--r--sys-apps/usbutils/usbutils-0.71-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-apps/usbutils/usbutils-0.71-r1.ebuild b/sys-apps/usbutils/usbutils-0.71-r1.ebuild
new file mode 100644
index 000000000000..593d2aa39f41
--- /dev/null
+++ b/sys-apps/usbutils/usbutils-0.71-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/usbutils/usbutils-0.71-r1.ebuild,v 1.1 2005/11/30 06:40:14 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="USB enumeration utilities"
+HOMEPAGE="http://linux-usb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/linux-usb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libusb"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # put usb.ids in same place as pci.ids (/usr/share/misc)
+ sed -i \
+ -e 's:/usr/share/usb.ids:/usr/share/misc/usb.ids:' \
+ lsusb.8 || die "sed lsusb.8"
+ sed -e '/^DEST=/s:=usb.ids:=/usr/share/misc/usb.ids:' \
+ update-usbids.sh > update-usbids
+
+ epatch "${FILESDIR}"/${P}-new-video-format.patch #111781
+
+ # replace usb.ids with an updated version
+ ebegin "Updating usb.ids"
+ ./update-usbids.sh &> /dev/null
+ eend 0
+}
+
+src_compile() {
+ econf \
+ --datadir=/usr/share/misc \
+ --enable-usbmodules \
+ || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dosbin update-usbids || die "update-usbids failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}