summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-08-15 07:48:11 +0000
committerMichał Górny <mgorny@gentoo.org>2011-08-15 07:48:11 +0000
commit70245d8ffd8cfacd5dbca457a8b5d86cf4bf448d (patch)
treefd862274129e6a0288ef5210c83da93a16ad6839 /sys-apps
parentFix segfault in reformime on some arches - bug #379101 (diff)
downloadgentoo-2-70245d8ffd8cfacd5dbca457a8b5d86cf4bf448d.tar.gz
gentoo-2-70245d8ffd8cfacd5dbca457a8b5d86cf4bf448d.tar.bz2
gentoo-2-70245d8ffd8cfacd5dbca457a8b5d86cf4bf448d.zip
Backport a few ebuild changes to -29: delay kernel checks and make them non-obligatory, report optional deps, bump vala slot.
(Portage version: 2.2.0_alpha51_p3/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/systemd/ChangeLog9
-rw-r--r--sys-apps/systemd/systemd-29-r2.ebuild (renamed from sys-apps/systemd/systemd-29-r1.ebuild)32
2 files changed, 26 insertions, 15 deletions
diff --git a/sys-apps/systemd/ChangeLog b/sys-apps/systemd/ChangeLog
index 55e8c501bf83..64bf2cb06b5c 100644
--- a/sys-apps/systemd/ChangeLog
+++ b/sys-apps/systemd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/systemd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.10 2011/08/09 11:36:42 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/ChangeLog,v 1.11 2011/08/15 07:48:11 mgorny Exp $
+
+*systemd-29-r2 (15 Aug 2011)
+
+ 15 Aug 2011; Michał Górny <mgorny@gentoo.org> -systemd-29-r1.ebuild,
+ +systemd-29-r2.ebuild:
+ Backport a few ebuild changes to -29: delay kernel checks and make them
+ non-obligatory, report optional deps, bump vala slot.
*systemd-32 (09 Aug 2011)
diff --git a/sys-apps/systemd/systemd-29-r1.ebuild b/sys-apps/systemd/systemd-29-r2.ebuild
index 1e3ea1e6a969..c797c3cac5db 100644
--- a/sys-apps/systemd/systemd-29-r1.ebuild
+++ b/sys-apps/systemd/systemd-29-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-29-r1.ebuild,v 1.2 2011/06/24 20:56:01 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-29-r2.ebuild,v 1.1 2011/08/15 07:48:11 mgorny Exp $
EAPI=4
@@ -32,7 +32,7 @@ COMMON_DEPEND=">=sys-apps/dbus-1.4.10
tcpd? ( sys-apps/tcp-wrappers )"
# Vala-0.10 doesn't work with libnotify 0.7.1
-VALASLOT="0.12"
+VALASLOT="0.14"
# A little higher than upstream requires
# but I had real trouble with 2.6.37 and systemd.
MINKV="2.6.38"
@@ -41,19 +41,11 @@ MINKV="2.6.38"
# blocker on old packages to avoid collisions with above
# openrc blocker to avoid udev rules starting openrc scripts
RDEPEND="${COMMON_DEPEND}
- !!sys-apps/systemd-dbus
- !!sys-apps/systemd-udev
!<sys-apps/openrc-0.8.3"
DEPEND="${COMMON_DEPEND}
gtk? ( dev-lang/vala:${VALASLOT} )
>=sys-kernel/linux-headers-${MINKV}"
-pkg_pretend() {
- local CONFIG_CHECK="AUTOFS4_FS CGROUPS DEVTMPFS ~FANOTIFY ~IPV6"
- linux-info_pkg_setup
- kernel_is -ge ${MINKV//./ } || die "Kernel version at least ${MINKV} required"
-}
-
pkg_setup() {
enewgroup lock # used by var-lock.mount
enewgroup tty 5 # used by mount-setup for /dev/pts
@@ -104,13 +96,19 @@ src_install() {
mv ${i}.8 systemd.${i}.8 || die
done
- # Drop the .pc file to avoid automagic depends.
- # This a temporary workaround for gx86 packages.
- rm -f "${D}"/usr/share/pkgconfig/systemd.pc || die
-
keepdir /run
}
+pkg_preinst() {
+ local CONFIG_CHECK="~AUTOFS4_FS ~CGROUPS ~DEVTMPFS ~FANOTIFY ~IPV6"
+ kernel_is -ge ${MINKV//./ } || ewarn "Kernel version at least ${MINKV} required"
+ check_extra_config
+}
+
+optfeature() {
+ elog " [$(has_version ${1} && echo I || echo ' ')] ${1} (${2})"
+}
+
pkg_postinst() {
if [[ ! -L "${ROOT}"etc/mtab ]]; then
ewarn "Upstream suggests that the /etc/mtab file should be a symlink to /proc/mounts."
@@ -126,6 +124,12 @@ pkg_postinst() {
elog " $ man tmpfiles.d"
elog
+ elog "To get additional features, a number of optional runtime dependencies may"
+ elog "be installed:"
+ optfeature 'dev-python/dbus-python' 'for systemd-analyze'
+ optfeature 'dev-python/pycairo[svg]' 'for systemd-analyze plotting ability'
+ elog
+
ewarn "Please note this is a work-in-progress and many packages in Gentoo"
ewarn "do not supply systemd unit files yet. You are testing it on your own"
ewarn "responsibility. Please remember than you can pass:"