summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-11-26 12:54:33 +0000
committerAchim Gottinger <achim@gentoo.org>2000-11-26 12:54:33 +0000
commit886fe0657f7f7f276ef5bec7ab14516bd48eb5a3 (patch)
tree260c089fbffc865629c95cd2cd243933d16cac97 /sys-apps
parent*** empty log message *** (diff)
downloadgentoo-2-886fe0657f7f7f276ef5bec7ab14516bd48eb5a3.tar.gz
gentoo-2-886fe0657f7f7f276ef5bec7ab14516bd48eb5a3.tar.bz2
gentoo-2-886fe0657f7f7f276ef5bec7ab14516bd48eb5a3.zip
*** empty log message ***
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/file-3.33.ebuild29
-rw-r--r--sys-apps/file/files/digest-file-3.331
-rw-r--r--sys-apps/modutils/files/digest-modutils-2.3.211
-rw-r--r--sys-apps/modutils/modutils-2.3.21.ebuild32
-rw-r--r--sys-apps/util-linux/files/digest-util-linux-2.10q1
-rw-r--r--sys-apps/util-linux/util-linux-2.10q.ebuild40
6 files changed, 104 insertions, 0 deletions
diff --git a/sys-apps/file/file-3.33.ebuild b/sys-apps/file/file-3.33.ebuild
new file mode 100644
index 000000000000..8906286fd7eb
--- /dev/null
+++ b/sys-apps/file/file-3.33.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-3.33.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Program to identify a file's format by scanning binary data for patters"
+#unfortunately, this ftp site doesn't support passive ftp
+#maybe we can find an alternative for those behind firewalls, or mirror
+#on cvs.gentoo.org
+SRC_URI="ftp://ftp.astron.com/pub/file/${A}"
+
+src_compile() {
+ try ./configure --prefix=/usr --datadir=/etc --host=${CHOST}
+ try make
+}
+
+src_install() {
+ into /usr
+ dobin file
+ doman file.1 magic.4
+ insinto /etc
+ doins magic magic.mime
+ dodoc LEGAL.NOTICE MAINT README
+}
+
+
+
diff --git a/sys-apps/file/files/digest-file-3.33 b/sys-apps/file/files/digest-file-3.33
new file mode 100644
index 000000000000..9a0e1f33e262
--- /dev/null
+++ b/sys-apps/file/files/digest-file-3.33
@@ -0,0 +1 @@
+MD5 3b8e32ed3a79774bd92f0052fa07ca04 file-3.33.tar.gz
diff --git a/sys-apps/modutils/files/digest-modutils-2.3.21 b/sys-apps/modutils/files/digest-modutils-2.3.21
new file mode 100644
index 000000000000..bb9862096c1e
--- /dev/null
+++ b/sys-apps/modutils/files/digest-modutils-2.3.21
@@ -0,0 +1 @@
+MD5 0ceccc4f1263114f9834fb56c653338f modutils-2.3.21.tar.bz2
diff --git a/sys-apps/modutils/modutils-2.3.21.ebuild b/sys-apps/modutils/modutils-2.3.21.ebuild
new file mode 100644
index 000000000000..49c39bd6768a
--- /dev/null
+++ b/sys-apps/modutils/modutils-2.3.21.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/modutils/modutils-2.3.21.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard kernel module utilities"
+SRC_URI="http://www.kernel.org/pub/linux/utils/kernel/modutils/v2.3/${A}
+ ftp://ftp.ocs.com.au/pub/modutils/v2.3/${A}"
+
+src_compile() {
+ try ./configure --prefix=/ --host=${CHOST}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ dodir /sbin
+ dodir /usr/man/man1
+ dodir /usr/man/man8
+ dodir /usr/man/man5
+ dodir /usr/man/man2
+ try make prefix=${D} mandir=${D}/usr/man install
+ prepman
+ strip ${D}/sbin/*
+ dodoc COPYING CREDITS ChangeLog NEWS README TODO
+}
+
+
+
+
diff --git a/sys-apps/util-linux/files/digest-util-linux-2.10q b/sys-apps/util-linux/files/digest-util-linux-2.10q
new file mode 100644
index 000000000000..bdcd5068c5a5
--- /dev/null
+++ b/sys-apps/util-linux/files/digest-util-linux-2.10q
@@ -0,0 +1 @@
+MD5 d17838e34cbe2673ed6b8747b10964ce util-linux-2.10q.tar.bz2
diff --git a/sys-apps/util-linux/util-linux-2.10q.ebuild b/sys-apps/util-linux/util-linux-2.10q.ebuild
new file mode 100644
index 000000000000..41183a168f1d
--- /dev/null
+++ b/sys-apps/util-linux/util-linux-2.10q.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.10q.ebuild,v 1.1 2000/11/26 12:52:15 achim Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Various useful Linux utilities"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/util-linux/${P}.tar.bz2"
+
+src_compile() {
+ try ./configure
+ try make
+}
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}
+ patch -p1 < ${FILESDIR}/util-linux-2.10o*
+ cp MCONFIG MCONFIG.orig
+ sed -e "s/-pipe -O2 -m486 -fomit-frame-pointer/${CFLAGS}/" \
+ -e "s/HAVE_PAM=no/HAVE_PAM=yes/" \
+ -e "s/HAVE_SLN=no/HAVE_SLN=yes/" \
+ -e "s/HAVE_TSORT=no/HAVE_TSORT=yes/" \
+ -e "s/# HAVE_SLANG/HAVE_SLANG/" \
+ -e "s/# SLANGFLAGS/SLANGSFLAGS/" \
+ MCONFIG.orig > MCONFIG
+
+}
+
+src_install() {
+ cd ${S}
+ try make DESTDIR=${D} install
+ cd ${S}
+ dodoc licenses/* HISTORY
+ docinto examples
+ dodoc example.files/*
+}
+
+