summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2014-12-09 01:50:57 +0000
committerBenda XU <heroxbd@gentoo.org>2014-12-09 01:50:57 +0000
commitb4ff71e02e81ce1ba57deaeb844c3a29fcaef181 (patch)
tree3e2c6b898d62ac82d1e9a002fafd61a23f3b6d41 /sys-apps
parentbumping for release (diff)
downloadgentoo-2-b4ff71e02e81ce1ba57deaeb844c3a29fcaef181.tar.gz
gentoo-2-b4ff71e02e81ce1ba57deaeb844c3a29fcaef181.tar.bz2
gentoo-2-b4ff71e02e81ce1ba57deaeb844c3a29fcaef181.zip
Prefix support: trivial D -> ED and ROOT -> EROOT.
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/shadow/ChangeLog5
-rw-r--r--sys-apps/shadow/shadow-4.2.1.ebuild26
2 files changed, 17 insertions, 14 deletions
diff --git a/sys-apps/shadow/ChangeLog b/sys-apps/shadow/ChangeLog
index b0f026fa2340..df56068c0e8c 100644
--- a/sys-apps/shadow/ChangeLog
+++ b/sys-apps/shadow/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-apps/shadow
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.294 2014/07/13 17:52:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/ChangeLog,v 1.295 2014/12/09 01:50:57 heroxbd Exp $
+
+ 09 Dec 2014; Benda Xu <heroxbd@gentoo.org> shadow-4.2.1.ebuild:
+ Prefix support: trivial D -> ED and ROOT -> EROOT.
13 Jul 2014; Mike Frysinger <vapier@gentoo.org> files/securetty:
Allow root login via any serial device.
diff --git a/sys-apps/shadow/shadow-4.2.1.ebuild b/sys-apps/shadow/shadow-4.2.1.ebuild
index 6d596ec0e63b..3ccb577a1aae 100644
--- a/sys-apps/shadow/shadow-4.2.1.ebuild
+++ b/sys-apps/shadow/shadow-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.2.1.ebuild,v 1.1 2014/06/16 05:52:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/shadow/shadow-4.2.1.ebuild,v 1.2 2014/12/09 01:50:57 heroxbd Exp $
EAPI=4
@@ -62,8 +62,8 @@ set_login_opt() {
[[ -z ${val} ]] && comment="#"
sed -i -r \
-e "/^#?${opt}/s:.*:${comment}${opt} ${val}:" \
- "${D}"/etc/login.defs
- local res=$(grep "^${comment}${opt}" "${D}"/etc/login.defs)
+ "${ED}"/etc/login.defs
+ local res=$(grep "^${comment}${opt}" "${ED}"/etc/login.defs)
einfo ${res:-Unable to find ${opt} in /etc/login.defs}
}
@@ -75,7 +75,7 @@ src_install() {
# Currently, libshadow.a is for internal use only, so if you see
# -lshadow in a Makefile of some other package, it is safe to
# remove it.
- rm -f "${D}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
+ rm -f "${ED}"/{,usr/}$(get_libdir)/lib{misc,shadow}.{a,la}
insinto /etc
# Using a securetty with devfs device names added
@@ -93,7 +93,7 @@ src_install() {
arm) devs="ttyFB0 ttySAC0 ttySAC1 ttySAC2 ttySAC3 ttymxc0 ttymxc1 ttymxc2 ttymxc3 ttyO0 ttyO1 ttyO2";;
sh) devs="ttySC0 ttySC1";;
esac
- [[ -n ${devs} ]] && printf '%s\n' ${devs} >> "${D}"/etc/securetty
+ [[ -n ${devs} ]] && printf '%s\n' ${devs} >> "${ED}"/etc/securetty
# needed for 'useradd -D'
insinto /etc/default
@@ -101,7 +101,7 @@ src_install() {
doins "${FILESDIR}"/default/useradd
# move passwd to / to help recover broke systems #64441
- mv "${D}"/usr/bin/passwd "${D}"/bin/
+ mv "${ED}"/usr/bin/passwd "${ED}"/bin/
dosym /bin/passwd /usr/bin/passwd
cd "${S}"
@@ -152,20 +152,20 @@ src_install() {
done
sed -i -f "${FILESDIR}"/login_defs_pam.sed \
- "${D}"/etc/login.defs
+ "${ED}"/etc/login.defs
# remove manpages that pam will install for us
# and/or don't apply when using pam
- find "${D}"/usr/share/man \
+ find "${ED}"/usr/share/man \
'(' -name 'limits.5*' -o -name 'suauth.5*' ')' \
-exec rm {} +
# Remove pam.d files provided by pambase.
- rm "${D}"/etc/pam.d/{login,passwd,su} || die
+ rm "${ED}"/etc/pam.d/{login,passwd,su} || die
fi
# Remove manpages that are handled by other packages
- find "${D}"/usr/share/man \
+ find "${ED}"/usr/share/man \
'(' -name id.1 -o -name passwd.5 -o -name getspnam.3 ')' \
-exec rm {} +
@@ -177,13 +177,13 @@ src_install() {
}
pkg_preinst() {
- rm -f "${ROOT}"/etc/pam.d/system-auth.new \
- "${ROOT}/etc/login.defs.new"
+ rm -f "${EROOT}"/etc/pam.d/system-auth.new \
+ "${EROOT}/etc/login.defs.new"
}
pkg_postinst() {
# Enable shadow groups.
- if [ ! -f "${ROOT}"/etc/gshadow ] ; then
+ if [ ! -f "${EROOT}"/etc/gshadow ] ; then
if grpck -r -R "${ROOT}" 2>/dev/null ; then
grpconv -R "${ROOT}"
else