summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2013-05-07 11:29:08 +0000
committerPeter Volkov <pva@gentoo.org>2013-05-07 11:29:08 +0000
commita6d20ae27600144779de8a9b9613198a5bf61e8b (patch)
treedcaf3a564dd0a569d46b1bf4abb42cc2283c9061 /sys-auth
parentFixed automake-1.13 build failure, bug #468850 (diff)
downloadgentoo-2-a6d20ae27600144779de8a9b9613198a5bf61e8b.tar.gz
gentoo-2-a6d20ae27600144779de8a9b9613198a5bf61e8b.tar.bz2
gentoo-2-a6d20ae27600144779de8a9b9613198a5bf61e8b.zip
Backported from upstream support for 147e:2020 devices.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key F1989B07)
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/libfprint/ChangeLog8
-rw-r--r--sys-auth/libfprint/files/libfprint-0.5.0-support-147e_2020.patch48
-rw-r--r--sys-auth/libfprint/libfprint-0.5.0-r1.ebuild48
3 files changed, 103 insertions, 1 deletions
diff --git a/sys-auth/libfprint/ChangeLog b/sys-auth/libfprint/ChangeLog
index c26fa0da24bf..da136af1cd30 100644
--- a/sys-auth/libfprint/ChangeLog
+++ b/sys-auth/libfprint/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/libfprint
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.21 2013/05/07 10:59:41 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/ChangeLog,v 1.22 2013/05/07 11:29:07 pva Exp $
+
+*libfprint-0.5.0-r1 (07 May 2013)
+
+ 07 May 2013; Peter Volkov <pva@gentoo.org> +libfprint-0.5.0-r1.ebuild,
+ +files/libfprint-0.5.0-support-147e_2020.patch:
+ Backported from upstream support for 147e:2020 devices.
07 May 2013; Peter Volkov <pva@gentoo.org> libfprint-0.5.0.ebuild,
+files/libfprint-0.5.0-automake-1.13.patch:
diff --git a/sys-auth/libfprint/files/libfprint-0.5.0-support-147e_2020.patch b/sys-auth/libfprint/files/libfprint-0.5.0-support-147e_2020.patch
new file mode 100644
index 000000000000..98f72aed5a0d
--- /dev/null
+++ b/sys-auth/libfprint/files/libfprint-0.5.0-support-147e_2020.patch
@@ -0,0 +1,48 @@
+From 3b3679c900f6739f7067f8d720e15d548bb39be9 Mon Sep 17 00:00:00 2001
+From: Vasily Khoruzhick <anarsoul@gmail.com>
+Date: Sun, 13 Jan 2013 13:43:38 +0000
+Subject: upeke2: Add support for 147e:2020 ID
+
+https://bugs.freedesktop.org/show_bug.cgi?id=59320
+---
+diff --git a/libfprint/drivers/upeke2.c b/libfprint/drivers/upeke2.c
+index ed8f43d..a7db54d 100644
+--- a/libfprint/drivers/upeke2.c
++++ b/libfprint/drivers/upeke2.c
+@@ -46,6 +46,11 @@
+ #define MSG_READ_BUF_SIZE 0x40
+ #define MAX_DATA_IN_READ_BUF (MSG_READ_BUF_SIZE - 9)
+
++enum {
++ UPEKE2_2016,
++ UPEKE2_2020,
++};
++
+ struct upeke2_dev {
+ gboolean enroll_passed;
+ gboolean first_verify_iteration;
+@@ -848,8 +853,10 @@ static struct fpi_ssm *deinitsm_new(struct fp_dev *dev)
+
+ static int discover(struct libusb_device_descriptor *dsc, uint32_t *devtype)
+ {
+- /* Revision 2 is what we're interested in */
+- if (dsc->bcdDevice == 2)
++ if (dsc->idProduct == 0x2016 && dsc->bcdDevice == 2)
++ return 1;
++
++ if (dsc->idProduct == 0x2020 && dsc->bcdDevice == 1)
+ return 1;
+
+ return 0;
+@@ -1453,7 +1460,8 @@ static int verify_stop(struct fp_dev *dev, gboolean iterating)
+ }
+
+ static const struct usb_id id_table[] = {
+- { .vendor = 0x147e, .product = 0x2016 },
++ { .vendor = 0x147e, .product = 0x2016, .driver_data = UPEKE2_2016 },
++ { .vendor = 0x147e, .product = 0x2020, .driver_data = UPEKE2_2020 },
+ { 0, 0, 0, }, /* terminating entry */
+ };
+
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/sys-auth/libfprint/libfprint-0.5.0-r1.ebuild b/sys-auth/libfprint/libfprint-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..20f91893113c
--- /dev/null
+++ b/sys-auth/libfprint/libfprint-0.5.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/libfprint/libfprint-0.5.0-r1.ebuild,v 1.1 2013/05/07 11:29:08 pva Exp $
+
+EAPI=4
+
+inherit autotools eutils udev vcs-snapshot
+
+MY_PV="v_${PV//./_}"
+DESCRIPTION="library to add support for consumer fingerprint readers"
+HOMEPAGE="http://cgit.freedesktop.org/libfprint/libfprint/"
+SRC_URI="http://cgit.freedesktop.org/${PN}/${PN}/snapshot/${MY_PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="virtual/libusb:1
+ dev-libs/nss
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] x11-libs/gdk-pixbuf )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-automake-1.13.patch"
+ epatch "${FILESDIR}/${P}-support-147e_2020.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-drivers=all \
+ $(use_enable debug debug-log) \
+ $(use_enable static-libs static) \
+ -enable-udev-rules \
+ --with-udev-rules-dir=$(udev_get_udevdir)/rules.d
+ # --disable-udev-rules fails https://bugs.freedesktop.org/show_bug.cgi?id=59076
+ # $(use_enable udev udev-rules) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ prune_libtool_files
+
+ dodoc AUTHORS HACKING NEWS README THANKS TODO
+}