summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-18 12:41:14 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-18 12:41:14 +0000
commitd2e1a53f485d195c1a0ee4244858f013ca766e36 (patch)
tree59914029445dee0af6b47db683f101a36959b2f8 /sys-boot/grub
parentRevision bump: EAPI 4, base eclass, drop unneeded sed (diff)
downloadgentoo-2-d2e1a53f485d195c1a0ee4244858f013ca766e36.tar.gz
gentoo-2-d2e1a53f485d195c1a0ee4244858f013ca766e36.tar.bz2
gentoo-2-d2e1a53f485d195c1a0ee4244858f013ca766e36.zip
fixed hardcoded awk (bug #424137)
(Portage version: 2.2.0_alpha141/cvs/Linux i686, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-boot/grub')
-rw-r--r--sys-boot/grub/ChangeLog6
-rw-r--r--sys-boot/grub/files/grub-2.00-hardcoded-awk.patch15
-rw-r--r--sys-boot/grub/grub-2.00-r1.ebuild3
-rw-r--r--sys-boot/grub/grub-9999.ebuild3
4 files changed, 24 insertions, 3 deletions
diff --git a/sys-boot/grub/ChangeLog b/sys-boot/grub/ChangeLog
index ac6f72094e69..981925b1ba1c 100644
--- a/sys-boot/grub/ChangeLog
+++ b/sys-boot/grub/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-boot/grub
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.239 2012/10/16 20:42:15 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/ChangeLog,v 1.240 2012/10/18 12:41:14 ottxor Exp $
+
+ 18 Oct 2012; Christoph Junghans <ottxor@gentoo.org>
+ +files/grub-2.00-hardcoded-awk.patch, grub-2.00-r1.ebuild, grub-9999.ebuild:
+ fixed hardcoded awk (bug #424137)
*grub-2.00-r1 (16 Oct 2012)
diff --git a/sys-boot/grub/files/grub-2.00-hardcoded-awk.patch b/sys-boot/grub/files/grub-2.00-hardcoded-awk.patch
new file mode 100644
index 000000000000..8019a3c74c15
--- /dev/null
+++ b/sys-boot/grub/files/grub-2.00-hardcoded-awk.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/show_bug.cgi?id=424137
+https://savannah.gnu.org/bugs/?37558
+https://code.google.com/p/original-mawk/issues/detail?id=17
+--- grub-core/Makefile.am 2012-07-07 12:29:01 +0000
++++ grub-core/Makefile.am 2012-10-12 13:04:02 +0000
+@@ -349,7 +349,7 @@
+
+ # generate global module dependencies list
+ moddep.lst: syminfo.lst genmoddep.awk video.lst
+- cat $< | sort | awk -f $(srcdir)/genmoddep.awk > $@ || (rm -f $@; exit 1)
++ cat $< | sort | $(AWK) -f $(srcdir)/genmoddep.awk > $@ || (rm -f $@; exit 1)
+ platform_DATA += moddep.lst
+ CLEANFILES += config.log syminfo.lst moddep.lst
+
+
diff --git a/sys-boot/grub/grub-2.00-r1.ebuild b/sys-boot/grub/grub-2.00-r1.ebuild
index 6334155dfed8..9f7a6becacc6 100644
--- a/sys-boot/grub/grub-2.00-r1.ebuild
+++ b/sys-boot/grub/grub-2.00-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00-r1.ebuild,v 1.1 2012/10/16 20:42:15 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-2.00-r1.ebuild,v 1.2 2012/10/18 12:41:14 ottxor Exp $
EAPI=4
@@ -222,6 +222,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-no-gets.patch" #424703
epatch "${FILESDIR}/${P}-config-quoting.patch" #426364
epatch "${FILESDIR}/${P}-tftp-endian.patch" # 438612
+ epatch "${FILESDIR}/${P}-hardcoded-awk.patch" #424137
fi
# fix texinfo file name, bug 416035
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 75aa2cd6df6f..31ca532cb99e 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.83 2012/10/16 20:42:15 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-9999.ebuild,v 1.84 2012/10/18 12:41:14 ottxor Exp $
EAPI=4
@@ -222,6 +222,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-no-gets.patch" #424703
epatch "${FILESDIR}/${P}-config-quoting.patch" #426364
epatch "${FILESDIR}/${P}-tftp-endian.patch" # 438612
+ epatch "${FILESDIR}/${P}-hardcoded-awk.patch" #424137
fi
# fix texinfo file name, bug 416035