summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-09-06 14:47:01 +0000
committerJeroen Roovers <jer@gentoo.org>2011-09-06 14:47:01 +0000
commit3b19e310a4c4ad0ee564f2bebcbb01822b17ceb3 (patch)
tree3dae7da1b5f7729eb240faa775ec87895fc88c19 /sys-boot/unetbootin
parentDrop src_install (leave default); add dependencies for man page generation. (diff)
downloadgentoo-2-3b19e310a4c4ad0ee564f2bebcbb01822b17ceb3.tar.gz
gentoo-2-3b19e310a4c4ad0ee564f2bebcbb01822b17ceb3.tar.bz2
gentoo-2-3b19e310a4c4ad0ee564f2bebcbb01822b17ceb3.zip
Version bump.
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'sys-boot/unetbootin')
-rw-r--r--sys-boot/unetbootin/ChangeLog7
-rw-r--r--sys-boot/unetbootin/unetbootin-555.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sys-boot/unetbootin/ChangeLog b/sys-boot/unetbootin/ChangeLog
index f1eb1330155f..e824ab921f56 100644
--- a/sys-boot/unetbootin/ChangeLog
+++ b/sys-boot/unetbootin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/unetbootin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.62 2011/06/08 16:34:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/ChangeLog,v 1.63 2011/09/06 14:47:01 jer Exp $
+
+*unetbootin-555 (06 Sep 2011)
+
+ 06 Sep 2011; Jeroen Roovers <jer@gentoo.org> +unetbootin-555.ebuild:
+ Version bump.
08 Jun 2011; Jeroen Roovers <jer@gentoo.org> -unetbootin-502.ebuild:
^^^^
diff --git a/sys-boot/unetbootin/unetbootin-555.ebuild b/sys-boot/unetbootin/unetbootin-555.ebuild
new file mode 100644
index 000000000000..f8db102d6875
--- /dev/null
+++ b/sys-boot/unetbootin/unetbootin-555.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/unetbootin/unetbootin-555.ebuild,v 1.1 2011/09/06 14:47:00 jer Exp $
+
+EAPI="3"
+
+inherit qt4-r2
+
+DESCRIPTION="Universal Netboot Installer creates Live USB systems for various OS
+distributions."
+HOMEPAGE="http://unetbootin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-source-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+DEPEND="x11-libs/qt-gui"
+RDEPEND="${DEPEND}
+ sys-fs/mtools
+ sys-boot/syslinux
+ app-arch/p7zip"
+
+src_configure() {
+ lupdate ${PN}.pro || die
+ lrelease ${PN}.pro || die
+ eqmake4 ${PN}.pro || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ insinto /usr/share/applications
+ doins ${PN}.desktop || die
+ for file in ${PN}*.png; do
+ size="${file/unetbootin_}"
+ size="${size/.png}x${size/.png}"
+ insinto /usr/share/icons/hicolor/${size}
+ newins ${file} ${PN}.png
+ done
+}