summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2011-06-24 09:40:13 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2011-06-24 09:40:13 +0000
commite2bd9d63d7d838c9c8e48df66b10c08352f1bcca (patch)
tree2c2dfbb833c3d3c9e69f50596dd546d125967fbd /sys-cluster/heartbeat
parentFix bug 372641, bug 372639, bug 372517. (diff)
downloadgentoo-2-e2bd9d63d7d838c9c8e48df66b10c08352f1bcca.tar.gz
gentoo-2-e2bd9d63d7d838c9c8e48df66b10c08352f1bcca.tar.bz2
gentoo-2-e2bd9d63d7d838c9c8e48df66b10c08352f1bcca.zip
Version bump
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/heartbeat')
-rw-r--r--sys-cluster/heartbeat/ChangeLog7
-rw-r--r--sys-cluster/heartbeat/heartbeat-3.0.5.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/sys-cluster/heartbeat/ChangeLog b/sys-cluster/heartbeat/ChangeLog
index d53f53e92232..1884692e3964 100644
--- a/sys-cluster/heartbeat/ChangeLog
+++ b/sys-cluster/heartbeat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/heartbeat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/ChangeLog,v 1.94 2011/04/16 18:59:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/ChangeLog,v 1.95 2011/06/24 09:40:13 ultrabug Exp $
+
+*heartbeat-3.0.5 (24 Jun 2011)
+
+ 24 Jun 2011; Ultrabug <ultrabug@gentoo.org> +heartbeat-3.0.5.ebuild:
+ Version bump.
16 Apr 2011; Raúl Porcel <armin76@gentoo.org> heartbeat-1.2.5-r1.ebuild,
heartbeat-2.0.8.ebuild:
diff --git a/sys-cluster/heartbeat/heartbeat-3.0.5.ebuild b/sys-cluster/heartbeat/heartbeat-3.0.5.ebuild
new file mode 100644
index 000000000000..ccfb21b8c85b
--- /dev/null
+++ b/sys-cluster/heartbeat/heartbeat-3.0.5.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/heartbeat-3.0.5.ebuild,v 1.1 2011/06/24 09:40:13 ultrabug Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+inherit python autotools multilib eutils base
+
+DESCRIPTION="Heartbeat high availability cluster manager"
+HOMEPAGE="http://www.linux-ha.org/wiki/Heartbeat"
+SRC_URI="http://hg.linux-ha.org/${PN}-STABLE_3_0/archive/STABLE-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="doc snmp static-libs"
+
+RDEPEND="sys-cluster/cluster-glue
+ dev-libs/glib:2
+ virtual/ssh
+ net-libs/gnutls
+ snmp? ( net-analyzer/net-snmp ) "
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-lang/swig"
+
+PDEPEND="sys-cluster/resource-agents"
+
+S=${WORKDIR}/Heartbeat-3-0-STABLE-${PV}
+
+PATCHES=(
+ "${FILESDIR}/3.0.4-fix_configure.patch"
+ "${FILESDIR}/3.0.4-docs.patch"
+ "${FILESDIR}/3.0.4-python_tests.patch"
+)
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+
+ ewarn "If you're upgrading from heartbeat-2.x please follow:"
+ ewarn "http://www.gentoo.org/proj/en/cluster/ha-cluster/heartbeat-upgrade.xml"
+}
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+
+ cp "${FILESDIR}"/heartbeat-init "${T}" || die
+ sed -i \
+ -e "/ResourceManager/ s/lib/share/" \
+ -e "s:lib:$(get_libdir):g" \
+ "${T}"/heartbeat-init || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-fatal-warnings \
+ $(use_enable static-libs static) \
+ $(use_enable doc) \
+ --disable-tipc \
+ --enable-dopd \
+ --libdir=/usr/$(get_libdir) \
+ --localstatedir=/var \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable snmp)
+}
+
+src_install() {
+ base_src_install
+
+ newinitd "${T}/heartbeat-init" heartbeat || die
+
+ # fix collisions
+ rm -rf "${D}"/usr/include/heartbeat/{compress,ha_msg}.h
+
+ if use doc ; then
+ dodoc README doc/*.txt doc/AUTHORS || die
+ fi
+}