summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-01-10 17:29:43 +0000
committerMichał Górny <mgorny@gentoo.org>2014-01-10 17:29:43 +0000
commitb70013c3b7c827f4a5180b499fd1bf4519857adb (patch)
treec1120957c694ffa8e85dd9e968464b639c11c253 /sys-devel
parentRe-add missing runtime gcc detection patch, bug #497704. (diff)
downloadgentoo-2-b70013c3b7c827f4a5180b499fd1bf4519857adb.tar.gz
gentoo-2-b70013c3b7c827f4a5180b499fd1bf4519857adb.tar.bz2
gentoo-2-b70013c3b7c827f4a5180b499fd1bf4519857adb.zip
Restore building clang-check and clang-format, bug #497620.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-3.4.ebuild8
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild8
3 files changed, 17 insertions, 5 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index b2bab98f87ce..58778e261c59 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.170 2014/01/10 17:25:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.171 2014/01/10 17:29:43 mgorny Exp $
+
+ 10 Jan 2014; Michał Górny <mgorny@gentoo.org> llvm-3.4.ebuild,
+ llvm-9999.ebuild:
+ Restore building clang-check and clang-format, bug #497620.
10 Jan 2014; Michał Górny <mgorny@gentoo.org> llvm-3.4.ebuild:
Re-add missing runtime gcc detection patch, bug #497704.
diff --git a/sys-devel/llvm/llvm-3.4.ebuild b/sys-devel/llvm/llvm-3.4.ebuild
index fe6c64b8bfef..32b312169010 100644
--- a/sys-devel/llvm/llvm-3.4.ebuild
+++ b/sys-devel/llvm/llvm-3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.ebuild,v 1.4 2014/01/10 17:25:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.4.ebuild,v 1.5 2014/01/10 17:29:43 mgorny Exp $
EAPI=5
@@ -306,7 +306,11 @@ set_makeargs() {
use gold && tools+=( gold )
# those require clang :)
- use clang && tools+=( clang/tools/extra )
+ # we need to explicitly specify all its tools
+ # since we're passing BUILD_CLANG_ONLY
+ use clang && tools+=(
+ clang/tools/{clang-check,clang-format,extra}
+ )
fi
fi
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 93196bb28f76..99eb36acfe8f 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.76 2014/01/08 21:42:23 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.77 2014/01/10 17:29:43 mgorny Exp $
EAPI=5
@@ -298,7 +298,11 @@ set_makeargs() {
use gold && tools+=( gold )
# those require clang :)
- use clang && tools+=( clang/tools/extra )
+ # we need to explicitly specify all its tools
+ # since we're passing BUILD_CLANG_ONLY
+ use clang && tools+=(
+ clang/tools/{clang-check,clang-format,extra}
+ )
fi
fi