summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-08-02 23:00:54 +0000
committerMike Frysinger <vapier@gentoo.org>2007-08-02 23:00:54 +0000
commitcf73643b2b4200c15754b811dc944c851c7e4147 (patch)
tree76f900d75bade684e03a889dac813a3720764a38 /sys-devel
parentold (diff)
downloadgentoo-2-cf73643b2b4200c15754b811dc944c851c7e4147.tar.gz
gentoo-2-cf73643b2b4200c15754b811dc944c851c7e4147.tar.bz2
gentoo-2-cf73643b2b4200c15754b811dc944c851c7e4147.zip
Fix header install and library generation/install #183679 by Daniel Gryniewicz.
(Portage version: 2.1.3)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/sparse/ChangeLog8
-rw-r--r--sys-devel/sparse/files/digest-sparse-0.3-r13
-rw-r--r--sys-devel/sparse/files/sparse-0.3-makefile-fix.patch20
-rw-r--r--sys-devel/sparse/metadata.xml3
-rw-r--r--sys-devel/sparse/sparse-0.3-r1.ebuild32
5 files changed, 60 insertions, 6 deletions
diff --git a/sys-devel/sparse/ChangeLog b/sys-devel/sparse/ChangeLog
index 6c2cff5890c1..6fa03aa0d099 100644
--- a/sys-devel/sparse/ChangeLog
+++ b/sys-devel/sparse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/sparse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.7 2007/06/26 16:51:52 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.8 2007/08/02 23:00:54 vapier Exp $
+
+*sparse-0.3-r1 (02 Aug 2007)
+
+ 02 Aug 2007; Mike Frysinger <vapier@gentoo.org>
+ files/sparse-0.3-makefile-fix.patch, metadata.xml, +sparse-0.3-r1.ebuild:
+ Fix header install and library generation/install #183679 by Daniel Gryniewicz.
*sparse-0.3 (26 Jun 2007)
diff --git a/sys-devel/sparse/files/digest-sparse-0.3-r1 b/sys-devel/sparse/files/digest-sparse-0.3-r1
new file mode 100644
index 000000000000..ef92f6395fa2
--- /dev/null
+++ b/sys-devel/sparse/files/digest-sparse-0.3-r1
@@ -0,0 +1,3 @@
+MD5 daa548bb52f64f00498ad646e5786c0a sparse-0.3.tar.gz 177462
+RMD160 36bb7e5611f56c5b222f33a0853e8315af406704 sparse-0.3.tar.gz 177462
+SHA256 e976ea8618acaaa88992298f493cdfc70518da7fcd8ada1e942586a21471b7a6 sparse-0.3.tar.gz 177462
diff --git a/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch b/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch
index 03dafa1f5715..a89316b54f11 100644
--- a/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch
+++ b/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch
@@ -1,19 +1,20 @@
---- sparse-0.3/work/sparse-0.3/Makefile 2007-06-15 14:21:33.000000000 +0200
-+++ sparse-0.3-new/work/sparse-0.3/Makefile 2007-06-15 14:21:51.000000000 +0200
-@@ -16,9 +16,9 @@ AR=ar
+--- sparse-0.3/Makefile
++++ sparse-0.3/Makefile
+@@ -16,9 +16,9 @@
CFLAGS += -DDEBUG
DESTDIR=
-PREFIX=$(HOME)
-BINDIR=$(PREFIX)/bin
-LIBDIR=$(PREFIX)/lib
+-INCLUDEDIR=$(PREFIX)/include
+PREFIX=
+BINDIR=$(PREFIX)/usr/bin
+LIBDIR=$(PREFIX)/usr/lib
- INCLUDEDIR=$(PREFIX)/include
++INCLUDEDIR=$(PREFIX)/usr/include
PKGCONFIGDIR=$(LIBDIR)/pkgconfig
-@@ -38,7 +38,7 @@ LIB_OBJS= target.o parse.o tokenize.o pr
+@@ -38,7 +38,7 @@
LIB_FILE= libsparse.a
SLIB_FILE= libsparse.so
@@ -22,3 +23,12 @@
all: $(PROGRAMS) sparse.pc
+@@ -101,7 +101,7 @@
+ $(AR) rcs $@ $(LIB_OBJS)
+
+ $(SLIB_FILE): $(LIB_OBJS)
+- $(CC) -shared -o $@ $(LIB_OBJS)
++ $(CC) $(LDFLAGS) -Wl,-soname,$@ -shared -o $@ $(LIB_OBJS)
+
+ evaluate.o: $(LIB_H)
+ expression.o: $(LIB_H)
diff --git a/sys-devel/sparse/metadata.xml b/sys-devel/sparse/metadata.xml
index cbcf02c9b38d..2c6e8b9f1117 100644
--- a/sys-devel/sparse/metadata.xml
+++ b/sys-devel/sparse/metadata.xml
@@ -5,4 +5,7 @@
<maintainer>
<email>solar@gentoo.org</email>
</maintainer>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+</maintainer>
</pkgmetadata>
diff --git a/sys-devel/sparse/sparse-0.3-r1.ebuild b/sys-devel/sparse/sparse-0.3-r1.ebuild
new file mode 100644
index 000000000000..20013f1f306a
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.3-r1.ebuild,v 1.1 2007/08/02 23:00:54 vapier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="http://kernel.org/pub/linux/kernel/people/josh/sparse/"
+SRC_URI="http://kernel.org/pub/linux/kernel/people/josh/sparse/dist/${P}.tar.gz"
+
+LICENSE="OSL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}"/${P}-makefile-fix.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -fpic" LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" install || die "make install failed"
+ dodoc FAQ README
+}