summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-11-30 16:07:29 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-11-30 16:07:29 +0000
commite097ca1e9c543a8f4ed5c4bf750fe4977b215e45 (patch)
treee94d78ae06421354f30967b7d0d1dd1df5684594 /sys-devel
parentStable for ppc, wrt bug #442394 (diff)
downloadgentoo-2-e097ca1e9c543a8f4ed5c4bf750fe4977b215e45.tar.gz
gentoo-2-e097ca1e9c543a8f4ed5c4bf750fe4977b215e45.tar.bz2
gentoo-2-e097ca1e9c543a8f4ed5c4bf750fe4977b215e45.zip
Fix compilation with gcc 4.7, reported by José Romildo Malaquias in bug #444550
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog7
-rw-r--r--sys-devel/llvm/files/llvm-2.9-gcc4.7.patch14
-rw-r--r--sys-devel/llvm/llvm-2.9-r2.ebuild5
3 files changed, 24 insertions, 2 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 30873c1bd599..25d01841f5b4 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.94 2012/11/18 11:12:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.95 2012/11/30 16:07:29 voyageur Exp $
+
+ 30 Nov 2012; Bernard Cafarelli <voyageur@gentoo.org> llvm-2.9-r2.ebuild,
+ +files/llvm-2.9-gcc4.7.patch:
+ Fix compilation with gcc 4.7, reported by José Romildo Malaquias in bug
+ #444550
18 Nov 2012; Agostino Sarubbo <ago@gentoo.org> llvm-3.1-r2.ebuild:
Stable for x86, wrt bug #443508
diff --git a/sys-devel/llvm/files/llvm-2.9-gcc4.7.patch b/sys-devel/llvm/files/llvm-2.9-gcc4.7.patch
new file mode 100644
index 000000000000..a48ad961c9be
--- /dev/null
+++ b/sys-devel/llvm/files/llvm-2.9-gcc4.7.patch
@@ -0,0 +1,14 @@
+---
+ Intercept.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/lib/ExecutionEngine/JIT/Intercept.cpp 2012-05-17 16:11:46.956180361 +0200
++++ b/lib/ExecutionEngine/JIT/Intercept.cpp 2012-05-17 16:14:35.256184996 +0200
+@@ -52,6 +52,7 @@
+ #include <sys/stat.h>
+ #endif
+ #include <fcntl.h>
++#include <unistd.h>
+ /* stat functions are redirecting to __xstat with a version number. On x86-64
+ * linking with libc_nonshared.a and -Wl,--export-dynamic doesn't make 'stat'
+ * available as an exported symbol, so we have to add it explicitly.
diff --git a/sys-devel/llvm/llvm-2.9-r2.ebuild b/sys-devel/llvm/llvm-2.9-r2.ebuild
index a7013182152d..0d36e633cd9a 100644
--- a/sys-devel/llvm/llvm-2.9-r2.ebuild
+++ b/sys-devel/llvm/llvm-2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.9-r2.ebuild,v 1.9 2012/07/03 14:32:17 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.9-r2.ebuild,v 1.10 2012/11/30 16:07:29 voyageur Exp $
EAPI="3"
inherit eutils flag-o-matic multilib toolchain-funcs pax-utils
@@ -86,6 +86,9 @@ src_prepare() {
# Upstream commit r131062
epatch "${FILESDIR}"/${P}-Operator.h-c++0x.patch
+
+ # Additional unistd.h include for GCC 4.7
+ epatch "${FILESDIR}"/${P}-gcc4.7.patch
}
src_configure() {