summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-10-07 22:11:09 +0000
committerTim Harder <radhermit@gentoo.org>2010-10-07 22:11:09 +0000
commit800e220e1af5e0a116eddf715cf3aaa3999aefa0 (patch)
tree5fbe66dd43383e02ec396e6c1cff6284fdd3c2c2 /sys-fs/fuse
parentppc64 stable wrt #314899 (diff)
downloadgentoo-2-800e220e1af5e0a116eddf715cf3aaa3999aefa0.tar.gz
gentoo-2-800e220e1af5e0a116eddf715cf3aaa3999aefa0.tar.bz2
gentoo-2-800e220e1af5e0a116eddf715cf3aaa3999aefa0.zip
Version bump for bug #330793. Drop unnecessary src_compile and remove die from econf.
(Portage version: 2.2_rc90/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/fuse')
-rw-r--r--sys-fs/fuse/ChangeLog8
-rw-r--r--sys-fs/fuse/fuse-2.8.5.ebuild72
2 files changed, 79 insertions, 1 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 0a746f2cedf9..fd62d53afc0a 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.132 2010/05/22 11:33:54 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.133 2010/10/07 22:11:09 radhermit Exp $
+
+*fuse-2.8.5 (07 Oct 2010)
+
+ 07 Oct 2010; Tim Harder <radhermit@gentoo.org> +fuse-2.8.5.ebuild:
+ Version bump for bug #330793. Drop unnecessary src_compile and remove die
+ from econf.
22 May 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove genstef from metadata.xml (#66339)
diff --git a/sys-fs/fuse/fuse-2.8.5.ebuild b/sys-fs/fuse/fuse-2.8.5.ebuild
new file mode 100644
index 000000000000..c06283134f1a
--- /dev/null
+++ b/sys-fs/fuse/fuse-2.8.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.8.5.ebuild,v 1.1 2010/10/07 22:11:09 radhermit Exp $
+
+EAPI=2
+inherit eutils libtool linux-info
+
+MY_P=${P/_/-}
+DESCRIPTION="An interface for filesystems implemented in userspace."
+HOMEPAGE="http://fuse.sourceforge.net"
+SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kernel_linux kernel_FreeBSD"
+S=${WORKDIR}/${MY_P}
+PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
+
+pkg_setup() {
+ if use kernel_linux ; then
+ if kernel_is lt 2 6 9; then
+ die "Your kernel is too old."
+ fi
+ CONFIG_CHECK="~FUSE_FS"
+ FUSE_FS_WARNING="You need to have FUSE module built to use user-mode utils"
+ linux-info_pkg_setup
+ fi
+}
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-example
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog Filesystems README \
+ README.NFS NEWS doc/how-fuse-works \
+ doc/kernel.txt FAQ
+ docinto example
+ dodoc example/*
+
+ if use kernel_linux ; then
+ newinitd "${FILESDIR}"/fuse.init fuse
+ elif use kernel_FreeBSD ; then
+ insinto /usr/include/fuse
+ doins include/fuse_kernel.h
+ newinitd "${FILESDIR}"/fuse-fbsd.init fuse
+ else
+ die "We don't know what init code install for your kernel, please file a bug."
+ fi
+
+ rm -rf "${D}/dev"
+
+ dodir /etc
+ cat >"${D}"/etc/fuse.conf <<-EOF
+ # Set the maximum number of FUSE mounts allowed to non-root users.
+ # The default is 1000.
+ #
+ #mount_max = 1000
+
+ # Allow non-root users to specify the 'allow_other' or 'allow_root'
+ # mount options.
+ #
+ #user_allow_other
+ EOF
+}