summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-05-11 22:18:31 +0000
committerMike Gilbert <floppym@gentoo.org>2013-05-11 22:18:31 +0000
commitb1190b2aa617ac67bedef0ffe90770b805b119b5 (patch)
tree5134e7fc90f50b13b6dfc0e9ed4ebe891b31e57f /sys-fs/traydevice
parentAdd prefix support (dir offsets), bug 416217 (diff)
downloadgentoo-2-b1190b2aa617ac67bedef0ffe90770b805b119b5.tar.gz
gentoo-2-b1190b2aa617ac67bedef0ffe90770b805b119b5.tar.bz2
gentoo-2-b1190b2aa617ac67bedef0ffe90770b805b119b5.zip
Convert to distutils-r1.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'sys-fs/traydevice')
-rw-r--r--sys-fs/traydevice/ChangeLog7
-rw-r--r--sys-fs/traydevice/traydevice-1.6.2-r1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-fs/traydevice/ChangeLog b/sys-fs/traydevice/ChangeLog
index cb66d36ac4e9..4a5546d570ca 100644
--- a/sys-fs/traydevice/ChangeLog
+++ b/sys-fs/traydevice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/traydevice
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/ChangeLog,v 1.9 2013/05/11 21:44:49 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/ChangeLog,v 1.10 2013/05/11 22:18:31 floppym Exp $
+
+*traydevice-1.6.2-r1 (11 May 2013)
+
+ 11 May 2013; Mike Gilbert <floppym@gentoo.org> +traydevice-1.6.2-r1.ebuild:
+ Convert to distutils-r1.
11 May 2013; Mike Gilbert <floppym@gentoo.org> traydevice-1.6.2.ebuild:
Restrict python2.5.
diff --git a/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild b/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..a407ab873263
--- /dev/null
+++ b/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild,v 1.1 2013/05/11 22:18:31 floppym Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A little desktop application displaying systray icon for UDisks"
+HOMEPAGE="http://savannah.nongnu.org/projects/traydevice/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ sys-fs/udisks:2"
+DEPEND="app-text/docbook2X"
+
+src_compile() {
+ return 0
+}
+
+python_install() {
+ distutils-r1_python_install \
+ --prefix=/usr \
+ --install-data=/usr/share/${PN} \
+ --install-man=/usr/share/man \
+ --docbook2man=docbook2man.pl
+}