summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-09-02 10:23:03 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-09-02 10:23:03 +0000
commit26f450c7f5c73b3e2276136d2777a9a4c9f715ef (patch)
tree6074f1bdf48127cefacaf9062ec209f23f792004 /sys-fs
parentRevbump supporting php 5.6 (diff)
downloadgentoo-2-26f450c7f5c73b3e2276136d2777a9a4c9f715ef.tar.gz
gentoo-2-26f450c7f5c73b3e2276136d2777a9a4c9f715ef.tar.bz2
gentoo-2-26f450c7f5c73b3e2276136d2777a9a4c9f715ef.zip
Version bump
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsdump/ChangeLog7
-rw-r--r--sys-fs/xfsdump/xfsdump-3.1.4.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-fs/xfsdump/ChangeLog b/sys-fs/xfsdump/ChangeLog
index 4a0c072596d8..4b5ffe16b85e 100644
--- a/sys-fs/xfsdump/ChangeLog
+++ b/sys-fs/xfsdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/xfsdump
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.109 2014/01/19 10:28:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/ChangeLog,v 1.110 2014/09/02 10:23:03 polynomial-c Exp $
+
+*xfsdump-3.1.4 (02 Sep 2014)
+
+ 02 Sep 2014; Lars Wendler <polynomial-c@gentoo.org> +xfsdump-3.1.4.ebuild:
+ Version bump.
19 Jan 2014; Agostino Sarubbo <ago@gentoo.org> xfsdump-3.1.3.ebuild:
Stable for ppc64, wrt bug #495956
diff --git a/sys-fs/xfsdump/xfsdump-3.1.4.ebuild b/sys-fs/xfsdump/xfsdump-3.1.4.ebuild
new file mode 100644
index 000000000000..014076b00d11
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.1.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsdump/xfsdump-3.1.4.ebuild,v 1.1 2014/09/02 10:23:03 polynomial-c Exp $
+
+EAPI="4"
+
+inherit multilib eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/e2fsprogs
+ !<sys-fs/xfsprogs-3
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-3.0.5-prompt-overflow.patch #335115
+ epatch "${FILESDIR}"/${PN}-3.0.4-no-symlink.patch #311881
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir=/$(get_libdir) \
+ --libexecdir=/usr/$(get_libdir) \
+ --sbindir=/sbin
+}