summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-02-23 12:28:43 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-02-23 12:28:43 +0000
commitbdc15715045c9b35266b6510338b20d58263cfcd (patch)
tree5cf33b0a494025b4502654532caddec15ab9fbb4 /sys-fs
parentDevelopment branch version bump. (diff)
downloadgentoo-2-bdc15715045c9b35266b6510338b20d58263cfcd.tar.gz
gentoo-2-bdc15715045c9b35266b6510338b20d58263cfcd.tar.bz2
gentoo-2-bdc15715045c9b35266b6510338b20d58263cfcd.zip
move variables into the right place, bug 168051
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog6
-rw-r--r--sys-fs/fuse/files/digest-fuse-2.6.03
-rw-r--r--sys-fs/fuse/fuse-2.6.0.ebuild71
-rw-r--r--sys-fs/fuse/fuse-2.6.0_rc1.ebuild29
-rw-r--r--sys-fs/fuse/fuse-2.6.1.ebuild21
-rw-r--r--sys-fs/fuse/fuse-2.6.3.ebuild21
6 files changed, 44 insertions, 107 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index a4282b1d5dec..ad2b5c75844c 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.76 2007/02/21 04:22:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.77 2007/02/23 12:28:43 genstef Exp $
+
+ 23 Feb 2007; <genstef@gentoo.org> fuse-2.6.0_rc1.ebuild,
+ -fuse-2.6.0.ebuild, fuse-2.6.1.ebuild, fuse-2.6.3.ebuild:
+ move variables into the right place, bug 168051
21 Feb 2007; Joseph Jezak <josejx@gentoo.org> fuse-2.6.1.ebuild:
Marked ppc stable for bug #150978.
diff --git a/sys-fs/fuse/files/digest-fuse-2.6.0 b/sys-fs/fuse/files/digest-fuse-2.6.0
deleted file mode 100644
index 27259ddefd57..000000000000
--- a/sys-fs/fuse/files/digest-fuse-2.6.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 fa6c7b07a0be3a3e30d6cf3a6bad5817 fuse-2.6.0.tar.gz 470514
-RMD160 bf36a008d17fbb1169bfd7d077a53587df90ddb4 fuse-2.6.0.tar.gz 470514
-SHA256 782137879b964139e2dc4767114b763cb0e11ae322476404920cf767728e659e fuse-2.6.0.tar.gz 470514
diff --git a/sys-fs/fuse/fuse-2.6.0.ebuild b/sys-fs/fuse/fuse-2.6.0.ebuild
deleted file mode 100644
index 8904ac09da6c..000000000000
--- a/sys-fs/fuse/fuse-2.6.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0.ebuild,v 1.2 2006/11/24 18:01:29 genstef Exp $
-
-inherit linux-mod eutils libtool
-
-MY_P=${P/_/-}
-DESCRIPTION="An interface for filesystems implemented in userspace."
-HOMEPAGE="http://fuse.sourceforge.net"
-SRC_URI="mirror://sourceforge/fuse/${MY_P}.tar.gz"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="kernel_linux kernel_FreeBSD"
-S=${WORKDIR}/${MY_P}
-PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-
-MODULE_NAMES="fuse(fs:${S}/kernel)"
-CONFIG_CHECK="@FUSE_FS:fuse"
-BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
-BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
-FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
-We will continue, but we wont build the module this time."
-
-pkg_setup() {
- use kernel_linux && linux-mod_pkg_setup
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/fuse-fix-lazy-binding.patch
- epatch "${FILESDIR}"/fuse-2.6.0_rc3-no-mknod.patch #152032
- elibtoolize
-}
-
-src_compile() {
- econf \
- --disable-kernel-module \
- --disable-example \
- || die "econf failed for fuse userland"
- emake || die "emake failed"
-
- if use kernel_linux ; then
- cd "${S}"
- sed -i -e 's/.*depmod.*//g' kernel/Makefile.in
- convert_to_m kernel/Makefile.in
- linux-mod_src_compile
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS ChangeLog Filesystems README README-2.4 \
- README.NFS NEWS doc/how-fuse-works
- docinto example
- dodoc example/*
-
- if use kernel_linux ; then
- linux-mod_src_install
- else
- insinto /usr/include/fuse
- doins include/fuse_kernel.h
- fi
-}
-
-pkg_postinst() {
- use kernel_linux && linux-mod_pkg_postinst
-}
diff --git a/sys-fs/fuse/fuse-2.6.0_rc1.ebuild b/sys-fs/fuse/fuse-2.6.0_rc1.ebuild
index 7224093708d5..fc242398703c 100644
--- a/sys-fs/fuse/fuse-2.6.0_rc1.ebuild
+++ b/sys-fs/fuse/fuse-2.6.0_rc1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_rc1.ebuild,v 1.7 2006/11/24 18:01:29 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.0_rc1.ebuild,v 1.8 2007/02/23 12:28:43 genstef Exp $
inherit linux-mod eutils libtool
@@ -14,17 +14,22 @@ IUSE="kernel_linux kernel_FreeBSD"
S=${WORKDIR}/${MY_P}
PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-MODULE_NAMES="fuse(fs:${S}/kernel)"
-CONFIG_CHECK="@FUSE_FS:fuse"
-BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL}/fs"
-BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
-FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
-We will continue, but we wont build the module this time."
-
pkg_setup() {
- use kernel_linux && linux-mod_pkg_setup
+ if use kernel_linux ; then
+ MODULE_NAMES="fuse(fs:${S}/kernel)"
+ CONFIG_CHECK="@FUSE_FS:fuse"
+ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+ We will continue, but we wont build the module this time."
+
+ linux-mod_pkg_setup
+ kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
+ older version from viewcvs"
+
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_TARGETS="all"
+ ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
+ fi
}
src_unpack() {
diff --git a/sys-fs/fuse/fuse-2.6.1.ebuild b/sys-fs/fuse/fuse-2.6.1.ebuild
index 739250823603..3ecf0c61e9f3 100644
--- a/sys-fs/fuse/fuse-2.6.1.ebuild
+++ b/sys-fs/fuse/fuse-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.1.ebuild,v 1.8 2007/02/21 04:22:36 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.1.ebuild,v 1.9 2007/02/23 12:28:43 genstef Exp $
inherit linux-mod eutils libtool
@@ -14,20 +14,21 @@ IUSE="kernel_linux kernel_FreeBSD"
S=${WORKDIR}/${MY_P}
PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-MODULE_NAMES="fuse(fs:${S}/kernel)"
-CONFIG_CHECK="@FUSE_FS:fuse"
-BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
-BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
-FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
-We will continue, but we wont build the module this time."
-
pkg_setup() {
if use kernel_linux ; then
+ MODULE_NAMES="fuse(fs:${S}/kernel)"
+ CONFIG_CHECK="@FUSE_FS:fuse"
+ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+ We will continue, but we wont build the module this time."
+
linux-mod_pkg_setup
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
older version from viewcvs"
+
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_TARGETS="all"
+ ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
fi
}
diff --git a/sys-fs/fuse/fuse-2.6.3.ebuild b/sys-fs/fuse/fuse-2.6.3.ebuild
index 4cdcad203016..bd62b1b4896e 100644
--- a/sys-fs/fuse/fuse-2.6.3.ebuild
+++ b/sys-fs/fuse/fuse-2.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.3.ebuild,v 1.1 2007/02/07 16:47:30 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.6.3.ebuild,v 1.2 2007/02/23 12:28:43 genstef Exp $
inherit linux-mod eutils libtool
@@ -14,20 +14,21 @@ IUSE="kernel_linux kernel_FreeBSD"
S=${WORKDIR}/${MY_P}
PDEPEND="kernel_FreeBSD? ( sys-fs/fuse4bsd )"
-MODULE_NAMES="fuse(fs:${S}/kernel)"
-CONFIG_CHECK="@FUSE_FS:fuse"
-BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
- fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
-BUILD_TARGETS="all"
-ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
-FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
-We will continue, but we wont build the module this time."
-
pkg_setup() {
if use kernel_linux ; then
+ MODULE_NAMES="fuse(fs:${S}/kernel)"
+ CONFIG_CHECK="@FUSE_FS:fuse"
+ FUSE_FS_ERROR="We have detected FUSE already built into the kernel.
+ We will continue, but we wont build the module this time."
+
linux-mod_pkg_setup
kernel_is 2 4 && die "kernel 2.4 is not supported by this ebuild. Get an
older version from viewcvs"
+
+ BUILD_PARAMS="majver=${KV_MAJOR}.${KV_MINOR}
+ fusemoduledir=${ROOT}/lib/modules/${KV_FULL/\ }/fs"
+ BUILD_TARGETS="all"
+ ECONF_PARAMS="--with-kernel=${KV_DIR} --with-kernel-build=${KV_OUT_DIR}"
fi
}