summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2012-01-24 15:20:37 +0000
committerMike Pagano <mpagano@gentoo.org>2012-01-24 15:20:37 +0000
commit7485acba0a3bcc7181e59e0aea6775335ffcf421 (patch)
treeff56983fd74103ab1be117f0beaa82c3e64c6b6e /sys-kernel/gentoo-sources/gentoo-sources-3.0.17-r2.ebuild
parent[bump] dev-perl/Template-Toolkit-2.230.0 (diff)
downloadgentoo-2-7485acba0a3bcc7181e59e0aea6775335ffcf421.tar.gz
gentoo-2-7485acba0a3bcc7181e59e0aea6775335ffcf421.tar.bz2
gentoo-2-7485acba0a3bcc7181e59e0aea6775335ffcf421.zip
Replace bad copy of proc mem handling patch. Remove kernel with incorrect priviledge escalation fix.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-3.0.17-r2.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-3.0.17-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-3.0.17-r2.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-3.0.17-r2.ebuild
new file mode 100644
index 000000000000..c85bf2fdfb61
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-3.0.17-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-3.0.17-r2.ebuild,v 1.1 2012/01/24 15:20:37 mpagano Exp $
+
+EAPI="2"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="18"
+K_DEBLOB_AVAILABLE="1"
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches"
+IUSE="deblob"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}