summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-11 00:26:53 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-11 00:26:53 +0000
commit273b8c4f5d40b3a58cd326d4ded1bddbe31208b5 (patch)
tree0fab60c17057b11243d0ca4e1052bff04b1857f0 /sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
parentAdd support for storing env vars in config files in /etc/portage/crossdev. (diff)
downloadgentoo-2-273b8c4f5d40b3a58cd326d4ded1bddbe31208b5.tar.gz
gentoo-2-273b8c4f5d40b3a58cd326d4ded1bddbe31208b5.tar.bz2
gentoo-2-273b8c4f5d40b3a58cd326d4ded1bddbe31208b5.zip
fixup building with gcc-4.1 hosts and superh and some other obscure stuff
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
index 5c7111a5cd28..497b890d10de 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild,v 1.12 2006/04/09 17:12:49 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r4.ebuild,v 1.13 2006/04/11 00:26:53 vapier Exp $
ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arm bfin cris hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
+H_SUPPORTEDARCH="alpha amd64 arm bfin cris hppa ia64 m68k nios2 ppc ppc64 s390 sh sparc x86"
inherit eutils kernel-2
detect_version
-PATCHES_V='9'
+PATCHES_V='10'
SRC_URI="${KERNEL_URI} mirror://gentoo/linux-2.6.11-m68k-headers.patch.bz2
mirror://gentoo/linux-2.6.12.1-blackfin.patch.bz2
@@ -24,15 +24,16 @@ kernel-2_hook_premake() {
# cris is slightly incomplete so lets fake it enough to get headers
mkdir -p arch/cris/boot
touch arch/cris/boot/Makefile
-}
-
-src_unpack() {
- kernel-2_src_unpack
# This should always be used but it has a bunch of hunks which
# apply to include/linux/ which i'm unsure of so only use with
- # m68k for now (dont want to break other arches)
+ # specific targets for now (dont want to break other arches)
[[ $(tc-arch) == "m68k" ]] && epatch "${DISTDIR}"/linux-2.6.11-m68k-headers.patch.bz2
+ [[ $(tc-arch) == "nios2" ]] && epatch "${DISTDIR}"/linux-2.6.11-nios2-headers.patch.bz2
+}
+
+src_unpack() {
+ kernel-2_src_unpack
# Fixes ... all the mv magic is to keep sed from dumping
# ugly warnings about how it can't work on a directory.
@@ -51,6 +52,6 @@ src_unpack() {
# Apply patch for spinlick.h only with 32bit userland on ppc64.
# Will add to the main patchball when plasmaroo returns.
if use ppc && [[ ${PROFILE_ARCH} == "ppc64" ]]; then
- epatch ${FILESDIR}/2.6.11-ppc64-32ul-spinlock.patch
+ epatch "${FILESDIR}"/2.6.11-ppc64-32ul-spinlock.patch
fi
}