summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2009-04-17 12:31:29 +0000
committerMike Pagano <mpagano@gentoo.org>2009-04-17 12:31:29 +0000
commit907321c7c5f55990e05a91ee9dd4bace2647e944 (patch)
tree36b9bc539dab88302ac3b7501be6be4e79102863 /sys-kernel
parentInitial import. Closes bug #208069. (diff)
downloadgentoo-2-907321c7c5f55990e05a91ee9dd4bace2647e944.tar.gz
gentoo-2-907321c7c5f55990e05a91ee9dd4bace2647e944.tar.bz2
gentoo-2-907321c7c5f55990e05a91ee9dd4bace2647e944.zip
Version bumps
(Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/ChangeLog9
-rw-r--r--sys-kernel/git-sources/git-sources-2.6.30_rc2-r2.ebuild32
-rw-r--r--sys-kernel/git-sources/git-sources-2.6.30_rc2-r3.ebuild32
3 files changed, 72 insertions, 1 deletions
diff --git a/sys-kernel/git-sources/ChangeLog b/sys-kernel/git-sources/ChangeLog
index 7e399b939654..42d9d2ac569d 100644
--- a/sys-kernel/git-sources/ChangeLog
+++ b/sys-kernel/git-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/git-sources
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.510 2009/04/16 11:42:54 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.511 2009/04/17 12:31:29 mpagano Exp $
+
+*git-sources-2.6.30_rc2-r3 (17 Apr 2009)
+*git-sources-2.6.30_rc2-r2 (17 Apr 2009)
+
+ 17 Apr 2009; Mike Pagano <mpagano@gentoo.org>
+ +git-sources-2.6.30_rc2-r2.ebuild, +git-sources-2.6.30_rc2-r3.ebuild:
+ Version bumps
*git-sources-2.6.30_rc2-r1 (16 Apr 2009)
*git-sources-2.6.30_rc2 (16 Apr 2009)
diff --git a/sys-kernel/git-sources/git-sources-2.6.30_rc2-r2.ebuild b/sys-kernel/git-sources/git-sources-2.6.30_rc2-r2.ebuild
new file mode 100644
index 000000000000..5b8fef73d22f
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-2.6.30_rc2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-2.6.30_rc2-r2.ebuild,v 1.1 2009/04/17 12:31:29 mpagano Exp $
+
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+#SRC_URI="${KERNEL_URI} mirror://kernel/linux/kernel/v2.6/snapshots/patch-${KV_FULL}.bz2"
+SRC_URI="${KERNEL_URI}"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugme.osdl.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+pkg_postinst() {
+ postinst_sources
+}
diff --git a/sys-kernel/git-sources/git-sources-2.6.30_rc2-r3.ebuild b/sys-kernel/git-sources/git-sources-2.6.30_rc2-r3.ebuild
new file mode 100644
index 000000000000..757ccfb7090d
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-2.6.30_rc2-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-2.6.30_rc2-r3.ebuild,v 1.1 2009/04/17 12:31:29 mpagano Exp $
+
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+#SRC_URI="${KERNEL_URI} mirror://kernel/linux/kernel/v2.6/snapshots/patch-${KV_FULL}.bz2"
+SRC_URI="${KERNEL_URI}"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugme.osdl.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+pkg_postinst() {
+ postinst_sources
+}