summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-01-08 07:32:43 +0000
committerMike Frysinger <vapier@gentoo.org>2008-01-08 07:32:43 +0000
commit71b382037b9f11f285cc443c9e571cb29772c7d3 (patch)
treec87c01586f7b0a42d77f52d6549af8c6d2610dde /sys-libs/uclibc
parentAdded mambo 4.6.3 to the tree, removed insecure 4.6.2 (sec issue #204352 and (diff)
downloadgentoo-2-71b382037b9f11f285cc443c9e571cb29772c7d3.tar.gz
gentoo-2-71b382037b9f11f285cc443c9e571cb29772c7d3.tar.bz2
gentoo-2-71b382037b9f11f285cc443c9e571cb29772c7d3.zip
uclibc_endian should test target, not host #204747
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'sys-libs/uclibc')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.27-r1.ebuild4
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28-r1.ebuild4
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28-r2.ebuild4
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.1.ebuild4
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.3-r1.ebuild4
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.3-r2.ebuild4
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.3.ebuild4
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.ebuild4
8 files changed, 16 insertions, 16 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild b/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
index adfca597b836..3fe77113f49e 100644
--- a/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.28 2007/07/02 15:35:40 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.29 2008/01/08 07:32:43 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -70,7 +70,7 @@ uclibc_endian() {
# XXX: this wont work for a toolchain which is bi-endian, but we
# dont have any such thing at the moment, so not a big deal
touch "${T}"/endian.s
- $(tc-getAS) "${T}"/endian.s -o "${T}"/endian.o
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
case $(file "${T}"/endian.o) in
*" MSB "*) echo "big";;
*" LSB "*) echo "little";;
diff --git a/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild b/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild
index 2405dfde044b..549fca7eeafe 100644
--- a/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild,v 1.13 2007/07/02 15:35:40 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild,v 1.14 2008/01/08 07:32:43 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -68,7 +68,7 @@ uclibc_endian() {
# XXX: this wont work for a toolchain which is bi-endian, but we
# dont have any such thing at the moment, so not a big deal
touch "${T}"/endian.s
- $(tc-getAS) "${T}"/endian.s -o "${T}"/endian.o
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
case $(file "${T}"/endian.o) in
*" MSB "*) echo "big";;
*" LSB "*) echo "little";;
diff --git a/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild b/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild
index a288eac0e46e..666ae861b6ec 100644
--- a/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild,v 1.8 2007/07/02 15:35:40 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild,v 1.9 2008/01/08 07:32:43 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -68,7 +68,7 @@ uclibc_endian() {
# XXX: this wont work for a toolchain which is bi-endian, but we
# dont have any such thing at the moment, so not a big deal
touch "${T}"/endian.s
- $(tc-getAS) "${T}"/endian.s -o "${T}"/endian.o
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
case $(file "${T}"/endian.o) in
*" MSB "*) echo "big";;
*" LSB "*) echo "little";;
diff --git a/sys-libs/uclibc/uclibc-0.9.28.1.ebuild b/sys-libs/uclibc/uclibc-0.9.28.1.ebuild
index 965ea777dbaa..5f8415b2eccc 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.1.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.1.ebuild,v 1.6 2007/07/02 15:35:40 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.1.ebuild,v 1.7 2008/01/08 07:32:43 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -68,7 +68,7 @@ uclibc_endian() {
# XXX: this wont work for a toolchain which is bi-endian, but we
# dont have any such thing at the moment, so not a big deal
touch "${T}"/endian.s
- $(tc-getAS) "${T}"/endian.s -o "${T}"/endian.o
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
case $(file "${T}"/endian.o) in
*" MSB "*) echo "big";;
*" LSB "*) echo "little";;
diff --git a/sys-libs/uclibc/uclibc-0.9.28.3-r1.ebuild b/sys-libs/uclibc/uclibc-0.9.28.3-r1.ebuild
index 08c65c4e69dd..f6a556090472 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.3-r1.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.3-r1.ebuild,v 1.1 2007/09/21 02:49:13 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.3-r1.ebuild,v 1.2 2008/01/08 07:32:43 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -69,7 +69,7 @@ uclibc_endian() {
# XXX: this wont work for a toolchain which is bi-endian, but we
# dont have any such thing at the moment, so not a big deal
touch "${T}"/endian.s
- $(tc-getAS) "${T}"/endian.s -o "${T}"/endian.o
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
case $(file "${T}"/endian.o) in
*" MSB "*) echo "big";;
*" LSB "*) echo "little";;
diff --git a/sys-libs/uclibc/uclibc-0.9.28.3-r2.ebuild b/sys-libs/uclibc/uclibc-0.9.28.3-r2.ebuild
index 693816030c05..0cb533dc9cdf 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.3-r2.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.3-r2.ebuild,v 1.1 2008/01/01 23:28:54 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.3-r2.ebuild,v 1.2 2008/01/08 07:32:43 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -69,7 +69,7 @@ uclibc_endian() {
# XXX: this wont work for a toolchain which is bi-endian, but we
# dont have any such thing at the moment, so not a big deal
touch "${T}"/endian.s
- $(tc-getAS) "${T}"/endian.s -o "${T}"/endian.o
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
case $(file "${T}"/endian.o) in
*" MSB "*) echo "big";;
*" LSB "*) echo "little";;
diff --git a/sys-libs/uclibc/uclibc-0.9.28.3.ebuild b/sys-libs/uclibc/uclibc-0.9.28.3.ebuild
index 44c1e68abf95..a61c0a34ca92 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.3.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.3.ebuild,v 1.5 2007/07/02 15:35:40 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.3.ebuild,v 1.6 2008/01/08 07:32:43 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -69,7 +69,7 @@ uclibc_endian() {
# XXX: this wont work for a toolchain which is bi-endian, but we
# dont have any such thing at the moment, so not a big deal
touch "${T}"/endian.s
- $(tc-getAS) "${T}"/endian.s -o "${T}"/endian.o
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
case $(file "${T}"/endian.o) in
*" MSB "*) echo "big";;
*" LSB "*) echo "little";;
diff --git a/sys-libs/uclibc/uclibc-0.9.28.ebuild b/sys-libs/uclibc/uclibc-0.9.28.ebuild
index 8b49bcc277c9..85cd9ef64c53 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.33 2007/07/02 15:35:40 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.34 2008/01/08 07:32:43 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -68,7 +68,7 @@ uclibc_endian() {
# XXX: this wont work for a toolchain which is bi-endian, but we
# dont have any such thing at the moment, so not a big deal
touch "${T}"/endian.s
- $(tc-getAS) "${T}"/endian.s -o "${T}"/endian.o
+ $(tc-getAS ${CTARGET}) "${T}"/endian.s -o "${T}"/endian.o
case $(file "${T}"/endian.o) in
*" MSB "*) echo "big";;
*" LSB "*) echo "little";;