summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-13 19:01:03 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-13 19:01:03 +0000
commit29cb121aae7328ea0fb2c48172595c583889b6d0 (patch)
tree3e06b70e6ee9b4ca75b371747a8d25379919dc25 /sys-libs
parentRemoving mod_auth_kerb-5.0-cache.patch and mod_auth_kerb-5.0-axps1.patch from... (diff)
downloadgentoo-2-29cb121aae7328ea0fb2c48172595c583889b6d0.tar.gz
gentoo-2-29cb121aae7328ea0fb2c48172595c583889b6d0.tar.bz2
gentoo-2-29cb121aae7328ea0fb2c48172595c583889b6d0.zip
Move timezone update to pkg_config so people can refresh it automatically as suggested by Stefano Varesi.
(Portage version: 2.1.2_rc4-r8)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/timezone-data/ChangeLog7
-rw-r--r--sys-libs/timezone-data/timezone-data-2007a.ebuild10
2 files changed, 13 insertions, 4 deletions
diff --git a/sys-libs/timezone-data/ChangeLog b/sys-libs/timezone-data/ChangeLog
index 74693392c449..c38b5f066875 100644
--- a/sys-libs/timezone-data/ChangeLog
+++ b/sys-libs/timezone-data/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/timezone-data
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.57 2007/01/09 20:15:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/ChangeLog,v 1.58 2007/01/13 19:01:03 vapier Exp $
+
+ 13 Jan 2007; Mike Frysinger <vapier@gentoo.org>
+ timezone-data-2007a.ebuild:
+ Move timezone update to pkg_config so people can refresh it automatically as
+ suggested by Stefano Varesi.
09 Jan 2007; Mike Frysinger <vapier@gentoo.org>
files/timezone-data-2005n-makefile.patch:
diff --git a/sys-libs/timezone-data/timezone-data-2007a.ebuild b/sys-libs/timezone-data/timezone-data-2007a.ebuild
index 64f87c3d700a..985237507855 100644
--- a/sys-libs/timezone-data/timezone-data-2007a.ebuild
+++ b/sys-libs/timezone-data/timezone-data-2007a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2007a.ebuild,v 1.1 2007/01/09 00:28:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2007a.ebuild,v 1.2 2007/01/13 19:01:03 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -50,7 +50,7 @@ src_install() {
dohtml *.htm *.jpg
}
-pkg_postinst() {
+pkg_config() {
# make sure the /etc/localtime file does not get stale #127899
local tz=$(source "${ROOT}"/etc/conf.d/clock ; echo ${TIMEZONE})
if [[ -z ${tz} ]] ; then
@@ -68,6 +68,10 @@ pkg_postinst() {
tz="Factory"
fi
einfo "Updating /etc/localtime with /usr/share/zoneinfo/${tz}"
- rm -f "${ROOT}"/etc/localtime
+ [[ -L ${ROOT}/etc/localtime ]] && rm -f "${ROOT}"/etc/localtime
cp -f "${ROOT}"/usr/share/zoneinfo/"${tz}" "${ROOT}"/etc/localtime
}
+
+pkg_postinst() {
+ pkg_config
+}