summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-01-31 15:23:59 +0000
committerHanno Böck <hanno@gentoo.org>2006-01-31 15:23:59 +0000
commit3c7c08a1ef2010aed1920e0287db0c080f684bb7 (patch)
tree0c7191fd674c774323ca8bfaa717ea093bd2a3f0 /sys-libs
parentVersion bump to 2.0_rc28. This fixes up the PPC/PPC64 cdtar, fixes grp/use, ... (diff)
downloadgentoo-2-3c7c08a1ef2010aed1920e0287db0c080f684bb7.tar.gz
gentoo-2-3c7c08a1ef2010aed1920e0287db0c080f684bb7.tar.bz2
gentoo-2-3c7c08a1ef2010aed1920e0287db0c080f684bb7.zip
gwenhywfar version bump
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.63
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.99.6.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 3d2776e8142d..de3da6c1c499 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.23 2006/01/27 23:03:28 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.24 2006/01/31 15:23:58 hanno Exp $
+
+*gwenhywfar-1.99.6 (31 Jan 2006)
+
+ 31 Jan 2006; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-1.99.6.ebuild:
+ Version bump.
*gwenhywfar-1.99.5 (27 Jan 2006)
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.6 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.6
new file mode 100644
index 000000000000..8bff5caa64c1
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.99.6
@@ -0,0 +1,3 @@
+MD5 ad8ff65ffc01189b20be39a7f977c6ea gwenhywfar-1.99.6.tar.gz 1122944
+RMD160 6190d9690d2843739237ea08dcb7521d6a5f6dbc gwenhywfar-1.99.6.tar.gz 1122944
+SHA256 3ded091204fb107860c0957751f5f4f63eea03e620d0d89829e4adaacafe6608 gwenhywfar-1.99.6.tar.gz 1122944
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.99.6.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.99.6.ebuild
new file mode 100644
index 000000000000..776481ae07a4
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.99.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.99.6.ebuild,v 1.1 2006/01/31 15:23:58 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )
+ ncurses? ( sys-libs/ncurses )"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ `use_enable ncurses gwenui` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}